summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-pbr_0.11.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-pbr_0.11.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-pbr_0.11.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-pbr_0.11.0.bb b/meta-openstack/recipes-devtools/python/python-pbr_0.11.0.bb
new file mode 100644
index 0000000..b81ed6f
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-pbr_0.11.0.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "Python Build Reasonableness: PBR is a library that injects some useful and sensible default behaviors into your setuptools run"
2HOMEPAGE = "https://pypi.python.org/pypi/pbr"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRCNAME = "pbr"
8
9SRC_URI = "https://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "e69466b4206e350f4f1e1db2e11ab73b"
12SRC_URI[sha256sum] = "d7f0d69aef367a764d69a4728afd966025ce9394d6029a924ef838ecdf592f6d"
13
14S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16inherit setuptools
17
18DEPENDS += " \
19 python-pip \
20 "
21
22RDEPENDS_${PN} += " \
23 "