summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-oslo.db_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-oslo.db_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.db_git.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.db_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.db_git.bb
new file mode 100644
index 0000000..f3f7074
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-oslo.db_git.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "oslo.db library"
2HOMEPAGE = "http://launchpad.net/oslo"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6
7PV = "3.1.0+git${SRCPV}"
8SRCREV = "3afd58f6ab0fc2acb1dd92f652cec48e87763cf6"
9
10SRCNAME = "oslo.db"
11SRC_URI = "git://github.com/openstack/${SRCNAME}.git"
12
13S = "${WORKDIR}/git"
14
15inherit setuptools
16
17DEPENDS += " \
18 python-pip \
19 python-pbr \
20 "
21
22RDEPENDS_${PN} += " \
23 python-six \
24 python-alembic \
25 python-babel \
26 python-iso8601 \
27 python-lockfile \
28 python-oslo.config \
29 python-oslo.i18n \
30 python-oslo.context \
31 python-oslo.utils \
32 python-sqlalchemy \
33 python-sqlalchemy-migrate \
34 python-stevedore \
35 python-pbr \
36 "