summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-mox3_0.26.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-mox3_0.26.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-mox3_0.26.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-mox3_0.26.0.bb b/meta-openstack/recipes-devtools/python/python-mox3_0.26.0.bb
new file mode 100644
index 0000000..73de2b3
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-mox3_0.26.0.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "mox3: mock object framework for Python"
2HOMEPAGE = "https://pypi.python.org/pypi/mox3/0.9.0"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://COPYING.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7SRC_URI[md5sum] = "c05b14ecb25d040f00b0d5ef3b370e20"
8SRC_URI[sha256sum] = "b13c0b8459d6fb0688f9a4e70feeec43fa2cca05b727fc01156789596e083bb1"
9
10inherit setuptools pypi
11
12DEPENDS += "\
13 python-pbr \
14 "
15
16# Satisfy setup.py 'setup_requires'
17DEPENDS += " \
18 python-pbr-native \
19 "
20
21RDEPENDS_${PN} += " \
22 python-pbr \
23 python-fixtures \
24"