summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-django-openstack-auth_1.1.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-django-openstack-auth_1.1.7.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-django-openstack-auth_1.1.7.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-django-openstack-auth_1.1.7.bb b/meta-openstack/recipes-devtools/python/python-django-openstack-auth_1.1.7.bb
new file mode 100644
index 0000000..625bcde
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-django-openstack-auth_1.1.7.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "A Django authentication backend for use with the OpenStack Keystone backend."
2HOMEPAGE = "http://django_openstack_auth.readthedocs.org/"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7PR = "r0"
8SRCNAME = "django_openstack_auth"
9
10SRC_URI = "https://pypi.python.org/packages/source/d/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
11"
12
13SRC_URI[md5sum] = "6afb0748dab95003b75f0d6f4f4a1100"
14SRC_URI[sha256sum] = "0884be8a97ff191799ed3f3d64b76c2f61299747af4a86d8a903766b2c175c6f"
15
16S = "${WORKDIR}/${SRCNAME}-${PV}"
17
18inherit setuptools
19
20DEPENDS += " \
21 python-pip \
22 python-pbr \
23 "
24
25RDEPENDS_${PN} += "python-django \
26 python-keystoneclient \
27 python-pbr \
28 " \ No newline at end of file