summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-cliff_2.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-cliff_2.4.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-cliff_2.4.0.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-cliff_2.4.0.bb b/meta-openstack/recipes-devtools/python/python-cliff_2.4.0.bb
new file mode 100644
index 0000000..20518bb
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-cliff_2.4.0.bb
@@ -0,0 +1,39 @@
1DESCRIPTION = "Command Line Interface Formulation Framework"
2HOMEPAGE = "https://github.com/dreamhost/cliff"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7SRCNAME = "cliff"
8
9SRC_URI = "https://pypi.python.org/packages/5a/86/61cb36713a6feb28cfb3201022a218c359dc988cf9f65b2e2681cb33cf8d/${SRCNAME}-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "26ef765d200e54aebf72984dfce5f255"
12SRC_URI[sha256sum] = "cc9175e3c2a42bc06343290a1218bc6b70f36883520b2948f743c5f9ae917675"
13
14S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16inherit setuptools rmargparse
17
18DEPENDS += "\
19 python-pbr \
20 "
21
22# Satisfy setup.py 'setup_requires'
23DEPENDS += " \
24 python-pbr-native \
25 "
26
27RDEPENDS_${PN} += "python-prettytable \
28 python-cmd2 \
29 python-pbr \
30 python-pyparsing \
31 python-prettytable \
32 python-pyparsing \
33 python-six \
34 python-stevedore \
35 python-unicodecsv \
36 python-pyyaml \
37"
38
39CLEANBROKEN = "1"