summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-posix-ipc.inc25
-rw-r--r--meta-openstack/recipes-devtools/python/python-posix-ipc_1.0.4.bb27
-rw-r--r--meta-openstack/recipes-devtools/python/python3-posix-ipc_1.0.4.bb2
3 files changed, 29 insertions, 25 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-posix-ipc.inc b/meta-openstack/recipes-devtools/python/python-posix-ipc.inc
new file mode 100644
index 0000000..32557f0
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-posix-ipc.inc
@@ -0,0 +1,25 @@
1DESCRIPTION = "POSIX IPC primitives (semaphores, shared memory and message queues) for Python"
2HOMEPAGE = "http://semanchuk.com/philip/posix_ipc/"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=dc089fb2f37e90799a54c19a20c9880f"
6
7PYPI_PACKAGE = "posix_ipc"
8
9# Archived version so we need to overwrite what the pypi class will derive
10PYPI_SRC_URI = "https://pypi.python.org/packages/source/p/${PYPI_PACKAGE}/${PYPI_PACKAGE}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "c4fd0065244ccb2f59cb8ceedf287cf6"
13SRC_URI[sha256sum] = "ff6c9077633fc62a491d6997c43b094d885bb45a7ca1f36c9a0d647c54b74b14"
14
15inherit pypi
16
17# DEPENDS_default: python-pip
18
19DEPENDS += " \
20 ${PYTHON_PN}-pip \
21 "
22
23# RDEPENDS_default:
24RDEPENDS_${PN} += " \
25 "
diff --git a/meta-openstack/recipes-devtools/python/python-posix-ipc_1.0.4.bb b/meta-openstack/recipes-devtools/python/python-posix-ipc_1.0.4.bb
index f1494d1..595af50 100644
--- a/meta-openstack/recipes-devtools/python/python-posix-ipc_1.0.4.bb
+++ b/meta-openstack/recipes-devtools/python/python-posix-ipc_1.0.4.bb
@@ -1,25 +1,2 @@
1DESCRIPTION = "POSIX IPC primitives (semaphores, shared memory and message queues) for Python" 1inherit setuptools
2HOMEPAGE = "http://semanchuk.com/philip/posix_ipc/" 2require python-posix-ipc.inc
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=dc089fb2f37e90799a54c19a20c9880f"
6
7PYPI_PACKAGE = "posix_ipc"
8
9# Archived version so we need to overwrite what the pypi class will derive
10PYPI_SRC_URI = "https://pypi.python.org/packages/source/p/${PYPI_PACKAGE}/${PYPI_PACKAGE}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "c4fd0065244ccb2f59cb8ceedf287cf6"
13SRC_URI[sha256sum] = "ff6c9077633fc62a491d6997c43b094d885bb45a7ca1f36c9a0d647c54b74b14"
14
15inherit setuptools pypi
16
17# DEPENDS_default: python-pip
18
19DEPENDS += " \
20 python-pip \
21 "
22
23# RDEPENDS_default:
24RDEPENDS_${PN} += " \
25 "
diff --git a/meta-openstack/recipes-devtools/python/python3-posix-ipc_1.0.4.bb b/meta-openstack/recipes-devtools/python/python3-posix-ipc_1.0.4.bb
new file mode 100644
index 0000000..9e79b1c
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-posix-ipc_1.0.4.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-posix-ipc.inc