summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-semantic-version.inc24
-rw-r--r--meta-openstack/recipes-devtools/python/python-semantic-version_2.4.2.bb26
-rw-r--r--meta-openstack/recipes-devtools/python/python3-semantic-version_2.4.2.bb2
3 files changed, 28 insertions, 24 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-semantic-version.inc b/meta-openstack/recipes-devtools/python/python-semantic-version.inc
new file mode 100644
index 0000000..e003c0c
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-semantic-version.inc
@@ -0,0 +1,24 @@
1DESCRIPTION = "A library which provides a few tools to handle SemVer in Python."
2HOMEPAGE = "http://pypi.python.org/pypi/semantic_version"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=a7dcaa0740d59f8f13ef05a3d0ed7313"
6
7PYPI_PACKAGE = "semantic_version"
8
9SRC_URI[md5sum] = "fd7d5ade76e78d8540b9a4044496a57c"
10SRC_URI[sha256sum] = "7e8b7fa74a3bc9b6e90b15b83b9bc2377c78eaeae3447516425f475d5d6932d2"
11
12#export BUILD_SYS
13#export HOST_SYS
14
15inherit pypi
16
17# DEPENDS_default: python-pip
18
19DEPENDS += " \
20 "
21
22# RDEPENDS_default:
23RDEPENDS_${PN} += " \
24 "
diff --git a/meta-openstack/recipes-devtools/python/python-semantic-version_2.4.2.bb b/meta-openstack/recipes-devtools/python/python-semantic-version_2.4.2.bb
index a038abb..2ca2d92 100644
--- a/meta-openstack/recipes-devtools/python/python-semantic-version_2.4.2.bb
+++ b/meta-openstack/recipes-devtools/python/python-semantic-version_2.4.2.bb
@@ -1,24 +1,2 @@
1DESCRIPTION = "A library which provides a few tools to handle SemVer in Python." 1require python-semantic-version.inc
2HOMEPAGE = "http://pypi.python.org/pypi/semantic_version" 2inherit setuptools
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=a7dcaa0740d59f8f13ef05a3d0ed7313"
6
7PYPI_PACKAGE = "semantic_version"
8
9SRC_URI[md5sum] = "fd7d5ade76e78d8540b9a4044496a57c"
10SRC_URI[sha256sum] = "7e8b7fa74a3bc9b6e90b15b83b9bc2377c78eaeae3447516425f475d5d6932d2"
11
12#export BUILD_SYS
13#export HOST_SYS
14
15inherit setuptools pypi
16
17# DEPENDS_default: python-pip
18
19DEPENDS += " \
20 "
21
22# RDEPENDS_default:
23RDEPENDS_${PN} += " \
24 "
diff --git a/meta-openstack/recipes-devtools/python/python3-semantic-version_2.4.2.bb b/meta-openstack/recipes-devtools/python/python3-semantic-version_2.4.2.bb
new file mode 100644
index 0000000..f4191f5
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-semantic-version_2.4.2.bb
@@ -0,0 +1,2 @@
1require python-semantic-version.inc
2inherit setuptools3