summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-lesscpy.inc18
-rw-r--r--meta-openstack/recipes-devtools/python/python-lesscpy_0.10.2.bb20
-rw-r--r--meta-openstack/recipes-devtools/python/python3-lesscpy_0.10.2.bb2
3 files changed, 22 insertions, 18 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-lesscpy.inc b/meta-openstack/recipes-devtools/python/python-lesscpy.inc
new file mode 100644
index 0000000..c10b0b8
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-lesscpy.inc
@@ -0,0 +1,18 @@
1DESCRIPTION = "Python lesscpy: Python LESS Compiler"
2HOMEPAGE = "https://pypi.python.org/pypi/lesscpy"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=a01aae31681ac25b4c46f98d627b9b5d"
6
7DEPENDS += "${PYTHON_PN}-ply"
8RDEPENDS_${PN} += "${PYTHON_PN}-ply"
9
10SRC_URI[md5sum] = "fedbad1f4eb19c3af37f09560156246d"
11SRC_URI[sha256sum] = "ccad1ad2a89ced1875c5ca4e16e5478b791d31fb187fe29f1541859318ed9055"
12
13inherit pypi
14
15DISTUTILS_INSTALL_ARGS = "--root=${D} \
16 --prefix=${prefix} \
17 --install-lib=${PYTHON_SITEPACKAGES_DIR} \
18 --install-data=${datadir}"
diff --git a/meta-openstack/recipes-devtools/python/python-lesscpy_0.10.2.bb b/meta-openstack/recipes-devtools/python/python-lesscpy_0.10.2.bb
index ca27cb5..43d7ff8 100644
--- a/meta-openstack/recipes-devtools/python/python-lesscpy_0.10.2.bb
+++ b/meta-openstack/recipes-devtools/python/python-lesscpy_0.10.2.bb
@@ -1,18 +1,2 @@
1DESCRIPTION = "Python lesscpy: Python LESS Compiler" 1require python-lesscpy.inc
2HOMEPAGE = "https://pypi.python.org/pypi/lesscpy" 2inherit setuptools
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=a01aae31681ac25b4c46f98d627b9b5d"
6
7DEPENDS += "python-ply"
8RDEPENDS_${PN} += "python-ply"
9
10SRC_URI[md5sum] = "fedbad1f4eb19c3af37f09560156246d"
11SRC_URI[sha256sum] = "ccad1ad2a89ced1875c5ca4e16e5478b791d31fb187fe29f1541859318ed9055"
12
13inherit setuptools pypi
14
15DISTUTILS_INSTALL_ARGS = "--root=${D} \
16 --prefix=${prefix} \
17 --install-lib=${PYTHON_SITEPACKAGES_DIR} \
18 --install-data=${datadir}"
diff --git a/meta-openstack/recipes-devtools/python/python3-lesscpy_0.10.2.bb b/meta-openstack/recipes-devtools/python/python3-lesscpy_0.10.2.bb
new file mode 100644
index 0000000..167b970
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-lesscpy_0.10.2.bb
@@ -0,0 +1,2 @@
1require python-lesscpy.inc
2inherit setuptools3