summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-connectivity/consul/consul-migrate_git.bb36
1 files changed, 19 insertions, 17 deletions
diff --git a/recipes-connectivity/consul/consul-migrate_git.bb b/recipes-connectivity/consul/consul-migrate_git.bb
index 935d663..8419cb8 100644
--- a/recipes-connectivity/consul/consul-migrate_git.bb
+++ b/recipes-connectivity/consul/consul-migrate_git.bb
@@ -1,12 +1,14 @@
1SUMMARY = "Provides data migration for Consul server nodes" 1SUMMARY = "Provides data migration for Consul server nodes"
2HOMEPAGE = "https://github.com/hashicorp/consul-migrate" 2HOMEPAGE = "https://github.com/hashicorp/consul-migrate"
3LICENSE = "MPL-2.0" 3LICENSE = "BSD & MPL-2.0 & MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b278a92d2c1509760384428817710378" 4LIC_FILES_CHKSUM = "file://src/github.com/hashicorp/consul-migrate/LICENSE;md5=b278a92d2c1509760384428817710378"
5 5
6PKG_NAME = "github.com/hashicorp/consul-migrate" 6GO_IMPORT = "github.com/hashicorp/consul-migrate"
7SRC_URI = "git://${PKG_NAME}.git" 7SRC_URI = "git://${GO_IMPORT}.git"
8SRCREV = "678fb10cdeae25ab309e99e655148f0bf65f9710" 8SRCREV = "678fb10cdeae25ab309e99e655148f0bf65f9710"
9 9
10S = "${WORKDIR}/git"
11
10SRCREV_raft = "057b893fd996696719e98b6c44649ea14968c811" 12SRCREV_raft = "057b893fd996696719e98b6c44649ea14968c811"
11SRCREV_go-metrics = "f303b03b91d770a11a39677f1d3b55da4002bbcb" 13SRCREV_go-metrics = "f303b03b91d770a11a39677f1d3b55da4002bbcb"
12SRCREV_raft-boltdb = "d1e82c1ec3f15ee991f7cc7ffd5b67ff6f5bbaee" 14SRCREV_raft-boltdb = "d1e82c1ec3f15ee991f7cc7ffd5b67ff6f5bbaee"
@@ -25,18 +27,18 @@ SRC_URI += " \
25 git://github.com/hashicorp/go-msgpack;name=go-msgpack;destsuffix=git/src/github.com/hashicorp/go-msgpack \ 27 git://github.com/hashicorp/go-msgpack;name=go-msgpack;destsuffix=git/src/github.com/hashicorp/go-msgpack \
26" 28"
27 29
28inherit golang 30inherit go
29
30SYSROOT_PREPROCESS_FUNCS += "consul_migrate_sysroot_preprocess"
31 31
32export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go" 32# GO packages shouldn't rely on external libs, but this one will
33# not build without this.
34LDFLAGS += "-lpthread"
33 35
34consul_migrate_sysroot_preprocess () { 36GO_INSTALL_FILTEROUT = " \
35 install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME} 37 github.com/hashicorp/raft \
36 cp -a ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME}) 38 github.com/armon/go-metrics \
37 install -d ${SYSROOT_DESTDIR}${prefix}/bin 39 github.com/hashicorp/raft-boltdb \
38 cp -a ${D}${prefix}/bin/* ${SYSROOT_DESTDIR}${prefix}/bin/ 40 github.com/hashicorp/raft-mdb \
39} 41 github.com/armon/gomdb \
40 42 github.com/boltdb/bolt \
41CLEANBROKEN = "1" 43 github.com/hashicorp/go-msgpack \
42INSANE_SKIP_${PN} = "ldflags" 44"