diff options
-rw-r--r-- | meta-openstack/recipes-devtools/python/python-manilaclient_git.bb | 40 | ||||
-rw-r--r-- | meta-openstack/recipes-devtools/python/python3-manilaclient_2.3.0.bb | 37 |
2 files changed, 37 insertions, 40 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-manilaclient_git.bb b/meta-openstack/recipes-devtools/python/python-manilaclient_git.bb deleted file mode 100644 index 2748efc..0000000 --- a/meta-openstack/recipes-devtools/python/python-manilaclient_git.bb +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | DESCRIPTION = "Python bindings to the OpenStack Manila API" | ||
2 | HOMEPAGE = "https://github.com/openstack/python-manilaclient" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "Apache-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=9edbbf5857ab51214ef0e8b79069bb07" | ||
6 | |||
7 | DEPENDS += " \ | ||
8 | python-pip \ | ||
9 | python-pbr \ | ||
10 | " | ||
11 | |||
12 | # Satisfy setup.py 'setup_requires' | ||
13 | DEPENDS += " \ | ||
14 | python-pbr-native \ | ||
15 | " | ||
16 | |||
17 | RDEPENDS_${PN} +=" \ | ||
18 | python-pbr \ | ||
19 | python-iso8601 \ | ||
20 | python-oslo.config \ | ||
21 | python-oslo.log \ | ||
22 | python-oslo.serialization \ | ||
23 | python-oslo.utils \ | ||
24 | python-prettytable \ | ||
25 | python-pycrypto \ | ||
26 | python-requests \ | ||
27 | python-simplejson \ | ||
28 | python-babel \ | ||
29 | python-six \ | ||
30 | python-keystoneclient \ | ||
31 | " | ||
32 | |||
33 | SRCNAME = "manilaclient" | ||
34 | SRC_URI = "git://github.com/openstack/${BPN}.git;branch=master" | ||
35 | |||
36 | PV = "1.29.0+git${SRCPV}" | ||
37 | SRCREV = "1b2cafb008bee70242b68a03212bcc575df683b9" | ||
38 | S = "${WORKDIR}/git" | ||
39 | |||
40 | inherit setuptools3 rmargparse | ||
diff --git a/meta-openstack/recipes-devtools/python/python3-manilaclient_2.3.0.bb b/meta-openstack/recipes-devtools/python/python3-manilaclient_2.3.0.bb new file mode 100644 index 0000000..78403c2 --- /dev/null +++ b/meta-openstack/recipes-devtools/python/python3-manilaclient_2.3.0.bb | |||
@@ -0,0 +1,37 @@ | |||
1 | DESCRIPTION = "Python bindings to the OpenStack Manila API" | ||
2 | HOMEPAGE = "https://github.com/openstack/python-manilaclient" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "Apache-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=9edbbf5857ab51214ef0e8b79069bb07" | ||
6 | |||
7 | SRC_URI[sha256sum] = "7b5b3215215a720ace08e53caca447a605dee9c8b3b3cfaa302b6bc7e63e4a28" | ||
8 | |||
9 | DEPENDS += " \ | ||
10 | python3-pip \ | ||
11 | python3-pbr \ | ||
12 | " | ||
13 | |||
14 | # Satisfy setup.py 'setup_requires' | ||
15 | DEPENDS += " \ | ||
16 | python3-pbr-native \ | ||
17 | " | ||
18 | |||
19 | RDEPENDS_${PN} +=" \ | ||
20 | python3-pbr \ | ||
21 | python3-iso8601 \ | ||
22 | python3-oslo.config \ | ||
23 | python3-oslo.log \ | ||
24 | python3-oslo.serialization \ | ||
25 | python3-oslo.utils \ | ||
26 | python3-prettytable \ | ||
27 | python3-pycrypto \ | ||
28 | python3-requests \ | ||
29 | python3-simplejson \ | ||
30 | python3-babel \ | ||
31 | python3-six \ | ||
32 | python3-keystoneclient \ | ||
33 | " | ||
34 | |||
35 | PYPI_PACKAGE = "python-manilaclient" | ||
36 | |||
37 | inherit setuptools3 pypi | ||