summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-httpd/apache2/apache2_2.4.10.bbappend15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-openstack/recipes-httpd/apache2/apache2_2.4.10.bbappend b/meta-openstack/recipes-httpd/apache2/apache2_2.4.10.bbappend
new file mode 100644
index 0000000..7aca867
--- /dev/null
+++ b/meta-openstack/recipes-httpd/apache2/apache2_2.4.10.bbappend
@@ -0,0 +1,15 @@
1INC := "${@int(PRINC) + 1}"
2
3do_install_append() {
4 sed -i -e 's/#ServerName.*$/ServerName 127.0.0.1:80/' ${D}${sysconfdir}/apache2/httpd.conf
5
6 # default layout for htdocsdir in 2.4.7 is different, create the following for
7 # backward compatibility reasons
8
9 mkdir -p ${D}${datadir}/${BPN}/default-site
10 ln -sf ../htdocs ${D}${datadir}/${BPN}/default-site/htdocs
11
12 sed -i '30i if [ ! -e /var/log/apache2 ]; then ln -sf /var/apache2/logs/ /var/log/apache2; fi' ${D}/etc/init.d/apache2
13}
14
15FILES_${PN} += "${datadir}/${BPN}/default-site"