diff options
4 files changed, 79 insertions, 0 deletions
diff --git a/meta-openstack-qemu/README b/meta-openstack-qemu/README new file mode 100644 index 0000000..63ef70a --- /dev/null +++ b/meta-openstack-qemu/README | |||
@@ -0,0 +1,48 @@ | |||
1 | meta-openstack-qemu | ||
2 | =================== | ||
3 | |||
4 | This layer provides support configuring and deploying OpenStack images that | ||
5 | are destined to be run under qemu system emulation. | ||
6 | |||
7 | Dependencies | ||
8 | ------------ | ||
9 | |||
10 | This layer depends on: | ||
11 | |||
12 | URI: git://github.com/openembedded/oe-core.git | ||
13 | branch: master | ||
14 | revision: HEAD | ||
15 | prio: default | ||
16 | |||
17 | URI: git://github.com/openembedded/meta-oe.git | ||
18 | patches: 0001-python-sqlalchemy-update-to-0.7.9.patch | ||
19 | revision: HEAD | ||
20 | layers: meta-oe | ||
21 | meta-networking | ||
22 | meta-ruby | ||
23 | |||
24 | URI: git://git.yoctoproject.org/meta-virtualization | ||
25 | branch: master | ||
26 | revision: head | ||
27 | |||
28 | meta-openstack | ||
29 | branch: master | ||
30 | revision: head | ||
31 | |||
32 | Maintenance | ||
33 | ----------- | ||
34 | |||
35 | Send pull requests, patches, comments or questions to meta-virtualization@yoctoproject.org | ||
36 | |||
37 | When sending single patches, please using something like: | ||
38 | 'git send-email -1 --to meta-virtualization@yoctoproject.org --subject-prefix=meta-virtualization][PATCH' | ||
39 | |||
40 | Maintainers: Bruce Ashfield <bruce.ashfield@windriver.com> | ||
41 | |||
42 | License | ||
43 | ------- | ||
44 | |||
45 | All metadata is MIT licensed unless otherwise stated. Source code included | ||
46 | in tree for individual recipes is under the LICENSE stated in each recipe | ||
47 | (.bb file) unless otherwise stated. | ||
48 | |||
diff --git a/meta-openstack-qemu/conf/layer.conf b/meta-openstack-qemu/conf/layer.conf new file mode 100644 index 0000000..6761143 --- /dev/null +++ b/meta-openstack-qemu/conf/layer.conf | |||
@@ -0,0 +1,9 @@ | |||
1 | # We have a conf and classes directory, append to BBPATH | ||
2 | BBPATH .= ":${LAYERDIR}" | ||
3 | |||
4 | # We have a recipes directory, add to BBFILES | ||
5 | BBFILES += "${LAYERDIR}/recipes*/*/*.bb ${LAYERDIR}/recipes*/*/*.bbappend" | ||
6 | |||
7 | BBFILE_COLLECTIONS += "openstack-qemu-layer" | ||
8 | BBFILE_PATTERN_openstack-qemu-layer := "^${LAYERDIR}/" | ||
9 | BBFILE_PRIORITY_openstack-qemu-layer = "6" | ||
diff --git a/meta-openstack-qemu/recipes-devtools/python/python-nova-compute_2013.1.3.bbappend b/meta-openstack-qemu/recipes-devtools/python/python-nova-compute_2013.1.3.bbappend new file mode 100644 index 0000000..45f4307 --- /dev/null +++ b/meta-openstack-qemu/recipes-devtools/python/python-nova-compute_2013.1.3.bbappend | |||
@@ -0,0 +1,11 @@ | |||
1 | do_install_append() { | ||
2 | if [ ! -f "${WORKDIR}/nova.conf" ]; then | ||
3 | return | ||
4 | fi | ||
5 | |||
6 | TEMPLATE_CONF_DIR=${S}${sysconfdir}/${SRCNAME} | ||
7 | NOVA_CONF_DIR=${D}/${sysconfdir}/nova | ||
8 | |||
9 | sed -e "s:^libvirt_type.*=.*$:libvirt_type = qemu:" \ | ||
10 | -i ${NOVA_CONF_DIR}/nova.conf | ||
11 | } | ||
diff --git a/meta-openstack-qemu/recipes-devtools/python/python-nova-controller_2013.1.3.bbappend b/meta-openstack-qemu/recipes-devtools/python/python-nova-controller_2013.1.3.bbappend new file mode 100644 index 0000000..f45a02b --- /dev/null +++ b/meta-openstack-qemu/recipes-devtools/python/python-nova-controller_2013.1.3.bbappend | |||
@@ -0,0 +1,11 @@ | |||
1 | do_install_append() { | ||
2 | if [ ! -f "${WORKDIR}/nova.conf" ]; then | ||
3 | return | ||
4 | fi | ||
5 | |||
6 | TEMPLATE_CONF_DIR=${S}${sysconfdir}/${SRCNAME} | ||
7 | NOVA_CONF_DIR=${D}/${sysconfdir}/nova | ||
8 | |||
9 | sed -e "s:^libvirt_type.*=.*$:libvirt_type = qemu:" \ | ||
10 | -i ${NOVA_CONF_DIR}/nova.conf | ||
11 | } \ No newline at end of file | ||