summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-support/memcached/memcached_1.4.17.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta-openstack/recipes-support/memcached/memcached_1.4.17.bb b/meta-openstack/recipes-support/memcached/memcached_1.4.17.bb
new file mode 100644
index 0000000..906896c
--- /dev/null
+++ b/meta-openstack/recipes-support/memcached/memcached_1.4.17.bb
@@ -0,0 +1,50 @@
1SUMMARY = "A high-performance memory object caching system"
2DESCRIPTION = "\
3 Danga Interactive developed memcached to enhance the speed of LiveJournal.com, \
4 a site which was already doing 20 million+ dynamic page views per day for 1 \
5 million users with a bunch of webservers and a bunch of database servers. \
6 memcached dropped the database load to almost nothing, yielding faster page \
7 load times for users, better resource utilization, and faster access to the \
8 databases on a memcache miss. \
9 . \
10 memcached optimizes specific high-load serving applications that are designed \
11 to take advantage of its versatile no-locking memory access system. Clients \
12 are available in several different programming languages, to suit the needs \
13 of the specific application. Traditionally this has been used in mod_perl \
14 apps to avoid storing large chunks of data in Apache memory, and to share \
15 this burden across several machines."
16
17HOMEPAGE = "http://www.danga.com/memcached/"
18LICENSE = "BSD"
19
20LIC_FILES_CHKSUM = "file://COPYING;md5=7e5ded7363d335e1bb18013ca08046ff"
21
22inherit autotools
23
24DEPENDS += "libevent"
25RDEPENDS += "perl perl-module-posix perl-module-autoloader perl-module-tie-hash"
26
27SRC_URI = "http://www.memcached.org/files/${PN}-${PV}.tar.gz"
28
29SRC_URI[md5sum] = "46402dfbd7faadf6182283dbbd18b1a6"
30SRC_URI[sha256sum] = "d9173ef6d99ba798c982ea4566cb4f0e64eb23859fdbf9926a89999d8cdc0458"
31
32python __anonymous () {
33 endianness = d.getVar('SITEINFO_ENDIANNESS', True)
34 if endianness == 'le':
35 d.setVar('EXTRA_OECONF', "ac_cv_c_endian=little")
36 else:
37 d.setVar('EXTRA_OECONF', "ac_cv_c_endian=big")
38}
39
40inherit update-rc.d
41
42INITSCRIPT_NAME = "memcached"
43INITSCRIPT_PARAMS = "defaults"
44
45do_install_append() {
46 install -D -m 755 ${S}/scripts/memcached-init ${D}${sysconfdir}/init.d/memcached
47 mkdir -p ${D}/usr/share/memcached/scripts
48 install -m 755 ${S}/scripts/memcached-tool ${D}/usr/share/memcached/scripts
49 install -m 755 ${S}/scripts/start-memcached ${D}/usr/share/memcached/scripts
50}