summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/ruby/chef-zero_git.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/chef-zero_git.bb b/meta-openstack/recipes-devtools/ruby/chef-zero_git.bb
new file mode 100644
index 0000000..7e8701d
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/chef-zero_git.bb
@@ -0,0 +1,39 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4SUMMARY = "Chef server that can be useful for chef-solo-like tasks"
5DESCRIPTION = "Chef Zero is a simple, easy-install, in-memory Chef \
6server that can be useful for Chef Client testing and chef-solo-like \
7tasks that require a full Chef Server. It IS intended to be simple, \
8Chef 11 compliant, easy to run and fast to start. It is NOT intended \
9to be secure, scalable, performant or persistent. It does NO input \
10validation, authentication or authorization (it will not throw a 400, \
11401 or 403). It does not save data, and will start up empty each time \
12you start it."
13
14LICENSE = "Apache-2.0"
15LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c"
16
17PR = "r0"
18
19BPV = "2.0.2"
20PV = "${BPV}"
21SRCREV = "1c87a463637b3d0c58755e2362cc8ef35b6da1fd"
22
23S = "${WORKDIR}/git"
24
25SRC_URI = " \
26 git://github.com/opscode/chef-zero.git \
27 "
28
29inherit ruby
30
31RDEPENDS += " \
32 mixlib-log \
33 json \
34 hashie \
35 mixlib-log \
36 rack \
37 "
38
39BBCLASSEXTEND = "native"