summaryrefslogtreecommitdiffstats
path: root/recipes-support
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2015-08-20 16:14:01 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-08-20 22:55:18 -0400
commit2b9a979b624eeb2fa9efdc64ebe5670498b044d7 (patch)
tree73d2226d6d0a78efcdbf7e0770271017b9f78540 /recipes-support
parentdcb148f4ccfa5896ebffaf4eb8b76a9999173faa (diff)
downloadmeta-cloud-services-2b9a979b624eeb2fa9efdc64ebe5670498b044d7.tar.gz
puppet: back-port some patches to fix issues with Ruby >= 2.0.0
We should uprev puppet at some point but for the sake of stabilizing first the following set of patches will allow puppet to work with the newer version of Ruby that we are using. The first two are upstream commits and the third is a commit which borrows a fix found in various puppet forks (repos which people host to stabalize older versions of puppet). With these patches puppet can now execute commands like 'help' and 'apply' without falling over. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/puppet/puppet/MAINT-Fix-duplicate-key-which-ruby-2.2-complains-abo.patch30
-rw-r--r--recipes-support/puppet/puppet/maint-Change-spec-test-to-pass-on-ruby-2.2.patch37
-rw-r--r--recipes-support/puppet/puppet/safe_yaml-syck-isn-t-available-for-Ruby-2.0.0.patch35
-rw-r--r--recipes-support/puppet/puppet_3.7.3.bb3
4 files changed, 105 insertions, 0 deletions
diff --git a/recipes-support/puppet/puppet/MAINT-Fix-duplicate-key-which-ruby-2.2-complains-abo.patch b/recipes-support/puppet/puppet/MAINT-Fix-duplicate-key-which-ruby-2.2-complains-abo.patch
new file mode 100644
index 0000000..696c642
--- /dev/null
+++ b/recipes-support/puppet/puppet/MAINT-Fix-duplicate-key-which-ruby-2.2-complains-abo.patch
@@ -0,0 +1,30 @@
1From 05dad9b1d30a8ff1e8e4a06bc5eaf0b19dab43e2 Mon Sep 17 00:00:00 2001
2From: Jasper Lievisse Adriaanse <jasper@humppa.nl>
3Date: Fri, 24 Jul 2015 20:18:08 +0200
4Subject: [PATCH] (MAINT) Fix duplicate key which ruby 2.2 complains about
5
6commit 05dad9b1d30a8ff1e8e4a06bc5eaf0b19dab43e2 from
7https://github.com/puppetlabs/puppet.git
8
9---
10 lib/puppet/defaults.rb | 4 ----
11 1 file changed, 4 deletions(-)
12
13diff --git a/lib/puppet/defaults.rb b/lib/puppet/defaults.rb
14index eeefefa..b591697 100644
15--- a/lib/puppet/defaults.rb
16+++ b/lib/puppet/defaults.rb
17@@ -486,10 +486,6 @@ module Puppet
18 :default => "stomp",
19 :desc => "Which type of queue to use for asynchronous processing.",
20 },
21- :queue_type => {
22- :default => "stomp",
23- :desc => "Which type of queue to use for asynchronous processing.",
24- },
25 :queue_source => {
26 :default => "stomp://localhost:61613/",
27 :desc => "Which type of queue to use for asynchronous processing. If your stomp server requires
28--
292.1.4
30
diff --git a/recipes-support/puppet/puppet/maint-Change-spec-test-to-pass-on-ruby-2.2.patch b/recipes-support/puppet/puppet/maint-Change-spec-test-to-pass-on-ruby-2.2.patch
new file mode 100644
index 0000000..73e1769
--- /dev/null
+++ b/recipes-support/puppet/puppet/maint-Change-spec-test-to-pass-on-ruby-2.2.patch
@@ -0,0 +1,37 @@
1From d183826136ca77847da5f3e460f2e460faabc5be Mon Sep 17 00:00:00 2001
2From: Kylo Ginsberg <kylo@puppetlabs.com>
3Date: Mon, 22 Dec 2014 10:11:38 -0800
4Subject: [PATCH] (maint) Change spec test to pass on ruby 2.2
5
6commit d183826136ca77847da5f3e460f2e460faabc5be from
7https://github.com/puppetlabs/puppet.git
8
9Prior to this change, this spec test failed on ruby 2.2.0-rc1 with:
10
11 Failure/Error: Time.stubs(:now).returns(Time.parse("2011-01-06 12:00:00 UTC"))
12 NoMethodError:
13 undefined method `utc_offset' for nil:NilClass
14
15I didn't track down the root cause of this failure, but just
16normalized this stub to use Time.utc, which (along with Time.local)
17is the more common way of stubbing Time objects in the codebase.
18---
19 spec/unit/reports/store_spec.rb | 2 +-
20 1 file changed, 1 insertion(+), 1 deletion(-)
21
22diff --git a/spec/unit/reports/store_spec.rb b/spec/unit/reports/store_spec.rb
23index 7f94f7d..f56eccd 100755
24--- a/spec/unit/reports/store_spec.rb
25+++ b/spec/unit/reports/store_spec.rb
26@@ -24,7 +24,7 @@ describe processor do
27 end
28
29 it "should write the report to the file in YAML" do
30- Time.stubs(:now).returns(Time.parse("2011-01-06 12:00:00 UTC"))
31+ Time.stubs(:now).returns(Time.utc(2011,01,06,12,00,00))
32 @report.process
33
34 File.read(File.join(Puppet[:reportdir], @report.host, "201101061200.yaml")).should == @report.to_yaml
35--
362.1.4
37
diff --git a/recipes-support/puppet/puppet/safe_yaml-syck-isn-t-available-for-Ruby-2.0.0.patch b/recipes-support/puppet/puppet/safe_yaml-syck-isn-t-available-for-Ruby-2.0.0.patch
new file mode 100644
index 0000000..1cd5e25
--- /dev/null
+++ b/recipes-support/puppet/puppet/safe_yaml-syck-isn-t-available-for-Ruby-2.0.0.patch
@@ -0,0 +1,35 @@
1From fca1579d62d5b978375511e062b9c18f4413dd5a Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Thu, 20 Aug 2015 14:06:32 -0400
4Subject: [PATCH] safe_yaml: syck isn't available for Ruby >= 2.0.0
5
6This change was taken from various puppet forks but does not exist in
7puppet upstream as they drop support for YAML on the network as part
8of work to fix PUP-3272.
9
10https://tickets.puppetlabs.com/browse/PUP-3272
11
12Community versions of this change:
13https://github.com/kylog/puppet/commit/42b2e77ec24dfbbf2317d08615a35127afbc4782
14
15Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
16---
17 lib/puppet/vendor/safe_yaml/lib/safe_yaml.rb | 2 +-
18 1 file changed, 1 insertion(+), 1 deletion(-)
19
20diff --git a/lib/puppet/vendor/safe_yaml/lib/safe_yaml.rb b/lib/puppet/vendor/safe_yaml/lib/safe_yaml.rb
21index 8670ace..722dd3e 100644
22--- a/lib/puppet/vendor/safe_yaml/lib/safe_yaml.rb
23+++ b/lib/puppet/vendor/safe_yaml/lib/safe_yaml.rb
24@@ -3,7 +3,7 @@ require "yaml"
25 # This needs to be defined up front in case any internal classes need to base
26 # their behavior off of this.
27 module SafeYAML
28- YAML_ENGINE = defined?(YAML::ENGINE) ? YAML::ENGINE.yamler : "syck"
29+ YAML_ENGINE = defined?(YAML::ENGINE) ? YAML::ENGINE.yamler : (defined?(Psych) && YAML == Psych ? "psych" : "syck")
30 end
31
32 require "set"
33--
342.1.4
35
diff --git a/recipes-support/puppet/puppet_3.7.3.bb b/recipes-support/puppet/puppet_3.7.3.bb
index 14e18d9..3e8f869 100644
--- a/recipes-support/puppet/puppet_3.7.3.bb
+++ b/recipes-support/puppet/puppet_3.7.3.bb
@@ -7,6 +7,9 @@ SRC_URI = " \
7 https://downloads.puppetlabs.com/puppet/puppet-${PV}.tar.gz \ 7 https://downloads.puppetlabs.com/puppet/puppet-${PV}.tar.gz \
8 file://add_puppet_gemspec.patch \ 8 file://add_puppet_gemspec.patch \
9 file://puppet.conf \ 9 file://puppet.conf \
10 file://maint-Change-spec-test-to-pass-on-ruby-2.2.patch \
11 file://MAINT-Fix-duplicate-key-which-ruby-2.2-complains-abo.patch \
12 file://safe_yaml-syck-isn-t-available-for-Ruby-2.0.0.patch \
10" 13"
11SRC_URI[md5sum] = "cc294da1d51df07bcc7f6cf78bd90ce0" 14SRC_URI[md5sum] = "cc294da1d51df07bcc7f6cf78bd90ce0"
12SRC_URI[sha256sum] = "4a3bd7ddb51072c3dd898a8de158cde204a2d8fd0b84e8ac806b84c074348637" 15SRC_URI[sha256sum] = "4a3bd7ddb51072c3dd898a8de158cde204a2d8fd0b84e8ac806b84c074348637"