summaryrefslogtreecommitdiffstats
path: root/recipes-support
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2016-01-09 14:04:14 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-01-11 09:33:32 -0500
commitf961d9626e97185247348a052fcd2cbd5802c3e1 (patch)
treea89b89421f46012621045abd50aceb2b2ae54886 /recipes-support
parent46c95437862c507672e425904b248ad86c938e97 (diff)
downloadmeta-cloud-services-f961d9626e97185247348a052fcd2cbd5802c3e1.tar.gz
puppet: add puppetlabs stdlib module
This module is used by many puppet modules so will be useful to have to extend our puppet capabilities. Additionally it offers some useful functionality such as the ability to append to a file. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/puppetlabs-stdlib/files/Add-gemspec.patch35
-rw-r--r--recipes-support/puppetlabs-stdlib/puppetlabs-stdlib_git.bb29
2 files changed, 64 insertions, 0 deletions
diff --git a/recipes-support/puppetlabs-stdlib/files/Add-gemspec.patch b/recipes-support/puppetlabs-stdlib/files/Add-gemspec.patch
new file mode 100644
index 0000000..d959aeb
--- /dev/null
+++ b/recipes-support/puppetlabs-stdlib/files/Add-gemspec.patch
@@ -0,0 +1,35 @@
1From e23971fcc1425e06a11484e552fbc631c43f44d4 Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Tue, 22 Dec 2015 11:05:22 -0500
4Subject: [PATCH] Add gemspec
5
6Started with an example from here
7http://guides.rubygems.org/make-your-own-gem/
8
9Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
10---
11 puppetlabs-stdlib.gemspec | 12 ++++++++++++
12 1 file changed, 12 insertions(+)
13 create mode 100644 puppetlabs-stdlib.gemspec
14
15diff --git a/puppetlabs-stdlib.gemspec b/puppetlabs-stdlib.gemspec
16new file mode 100644
17index 0000000..6b7eee3
18--- /dev/null
19+++ b/puppetlabs-stdlib.gemspec
20@@ -0,0 +1,12 @@
21+Gem::Specification.new do |s|
22+ s.name = 'puppetlabs-stdlib'
23+ s.version = '4.10.0'
24+ s.date = '2015-12-15'
25+ s.summary = "Puppet Labs Standard Library module"
26+ s.description = s.summary
27+ s.authors = ["Puppet Labs"]
28+ s.email = ''
29+ s.files = %w(LICENSE README.markdown Rakefile) + Dir.glob('{lib,spec}/**/*')
30+ s.homepage = 'https://github.com/puppetlabs/puppetlabs-stdlib'
31+ s.license = 'Apache 2.0'
32+end
33--
342.1.4
35
diff --git a/recipes-support/puppetlabs-stdlib/puppetlabs-stdlib_git.bb b/recipes-support/puppetlabs-stdlib/puppetlabs-stdlib_git.bb
new file mode 100644
index 0000000..2d3d9c2
--- /dev/null
+++ b/recipes-support/puppetlabs-stdlib/puppetlabs-stdlib_git.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Puppet Labs Standard Library module"
2HOMEPAGE = "https://github.com/puppetlabs/puppetlabs-stdlib"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=38a048b9d82e713d4e1b2573e370a756"
5
6PV = "4.10.0"
7SRCREV = "0b4822be3d2242e83c28ab7fed6c5817adc322d5"
8
9SRC_URI = " \
10 git://github.com/puppetlabs/puppetlabs-stdlib.git;branch=master \
11 file://Add-gemspec.patch \
12"
13
14inherit ruby
15
16S="${WORKDIR}/git"
17
18DEPENDS += " \
19 ruby \
20 facter \
21"
22
23RDEPENDS_${PN} += " \
24 ruby \
25 facter \
26 puppet \
27"
28
29RUBY_INSTALL_GEMS = "puppetlabs-stdlib-${PV}.gem"