summaryrefslogtreecommitdiffstats
path: root/recipes-support
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2014-03-25 15:35:16 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-03-26 09:26:45 -0400
commitd51c45ef928ccc33bdfe65ca13c78c42be01705a (patch)
tree8a9056b79424e17bc4f0b935110304cb63e70e72 /recipes-support
parent2604199265138f6c8522a7c694d218d1f639dfbb (diff)
downloadmeta-cloud-services-d51c45ef928ccc33bdfe65ca13c78c42be01705a.tar.gz
spice: updates to work with latest autotools
We were getting several errors during configure related to autoreconf. We need to create an empty m4 directory as well as enable the subdir-objects option to allow configure to complete successfully. There were indications that this second issue was fixed upstream but even using the latest git trees I am seeing this failure. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/spice/files/configure.ac-add-subdir-objects-to-AM_INIT_AUTOMAKE.patch29
-rw-r--r--recipes-support/spice/spice_git.bb12
2 files changed, 37 insertions, 4 deletions
diff --git a/recipes-support/spice/files/configure.ac-add-subdir-objects-to-AM_INIT_AUTOMAKE.patch b/recipes-support/spice/files/configure.ac-add-subdir-objects-to-AM_INIT_AUTOMAKE.patch
new file mode 100644
index 0000000..323ef52
--- /dev/null
+++ b/recipes-support/spice/files/configure.ac-add-subdir-objects-to-AM_INIT_AUTOMAKE.patch
@@ -0,0 +1,29 @@
1From 36efb79076420975f7fa7aa0b03a1fc282291b05 Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Tue, 25 Mar 2014 15:23:25 -0400
4Subject: [PATCH] configure.ac: add subdir-objects to AM_INIT_AUTOMAKE
5
6Without this you will get subdir-objects error which will cause
7autoreconf to complete successfully.
8
9Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
10---
11 spice-common/configure.ac | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-)
13
14diff --git a/spice-common/configure.ac b/spice-common/configure.ac
15index b5cb960..78f1360 100644
16--- a/spice-common/configure.ac
17+++ b/spice-common/configure.ac
18@@ -13,7 +13,7 @@ AC_CONFIG_AUX_DIR([build-aux])
19 m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
20
21 # Checks for programs
22-AM_INIT_AUTOMAKE([1.11 dist-xz no-dist-gzip tar-ustar foreign -Wall -Werror])
23+AM_INIT_AUTOMAKE([1.11 dist-xz no-dist-gzip tar-ustar foreign subdir-objects -Wall -Werror])
24 AM_MAINTAINER_MODE
25 AM_SILENT_RULES([yes])
26 LT_INIT
27--
281.8.3.2
29
diff --git a/recipes-support/spice/spice_git.bb b/recipes-support/spice/spice_git.bb
index 900259a..24870a1 100644
--- a/recipes-support/spice/spice_git.bb
+++ b/recipes-support/spice/spice_git.bb
@@ -29,7 +29,10 @@ SRC_URI = "git://anongit.freedesktop.org/spice/spice;name=spice \
29 git://anongit.freedesktop.org/spice/spice-protocol;destsuffix=git/spice-common/spice-protocol;name=spice-protocol \ 29 git://anongit.freedesktop.org/spice/spice-protocol;destsuffix=git/spice-common/spice-protocol;name=spice-protocol \
30 " 30 "
31 31
32SRC_URI += "file://spice-fix-CVE-2013-4282.patch" 32SRC_URI += " \
33 file://spice-fix-CVE-2013-4282.patch \
34 file://configure.ac-add-subdir-objects-to-AM_INIT_AUTOMAKE.patch \
35 "
33 36
34S = "${WORKDIR}/git" 37S = "${WORKDIR}/git"
35 38
@@ -37,9 +40,6 @@ inherit autotools gettext pythonnative python-dir pkgconfig
37 40
38DEPENDS += "python-native celt051 python-pyparsing jpeg pixman alsa-lib glib-2.0" 41DEPENDS += "python-native celt051 python-pyparsing jpeg pixman alsa-lib glib-2.0"
39 42
40EXTRA_OECONF_append = " -Wnone"
41EXTRA_AUTORECONF_append = " -Wnone"
42
43export PYTHON="${STAGING_BINDIR_NATIVE}/python-native/python" 43export PYTHON="${STAGING_BINDIR_NATIVE}/python-native/python"
44export PYTHONPATH="${PKG_CONFIG_SYSROOT_DIR}${libdir}/python2.7/site-packages" 44export PYTHONPATH="${PKG_CONFIG_SYSROOT_DIR}${libdir}/python2.7/site-packages"
45 45
@@ -56,6 +56,10 @@ LICENSE_${PN}-protocol = "BSD"
56FILES_${PN}-protocol += "${includedir}/spice-1" 56FILES_${PN}-protocol += "${includedir}/spice-1"
57FILES_${PN}-protocol += "${datadir}/pkgconfig" 57FILES_${PN}-protocol += "${datadir}/pkgconfig"
58 58
59do_configure_prepend() {
60 mkdir -p ${S}/spice-common/spice-protocol/m4
61}
62
59do_install_append() { 63do_install_append() {
60 cd ${S}/spice-common/spice-protocol 64 cd ${S}/spice-common/spice-protocol
61 oe_runmake DESTDIR="${D}" install 65 oe_runmake DESTDIR="${D}" install