summaryrefslogtreecommitdiffstats
path: root/recipes-support
diff options
context:
space:
mode:
authorJason Wessel <jason.wessel@windriver.com>2016-01-15 15:31:11 -0600
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-01-19 08:50:53 -0500
commit9ed0aef7b244773a9db644090b4e361fa7b3eea8 (patch)
treee778acbd212338bbcfb2ea63fb711694d1c69276 /recipes-support
parent850d27022a3685ee6821bf5856b02f54c58204a8 (diff)
downloadmeta-cloud-services-9ed0aef7b244773a9db644090b4e361fa7b3eea8.tar.gz
ruby-shadow: Work around cross compile gem problem
Prior to this commit it is not possible to cross build a ruby gem. In fact even on the x86 system the object files for the native gem are generated with the wrong compiler (the host compiler instead of the cross compiler). A better way to fix this in the future would be to use only gems that supported cross compile tool called rake. For now the bbclass can modify the extconf.rb just before creating the gem and insert some code into the Makefile so as to honor the cross compile environment. Signed-off-by: Jason Wessel <jason.wessel@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/ruby-shadow/ruby-shadow_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-support/ruby-shadow/ruby-shadow_git.bb b/recipes-support/ruby-shadow/ruby-shadow_git.bb
index 72be016..75588f3 100644
--- a/recipes-support/ruby-shadow/ruby-shadow_git.bb
+++ b/recipes-support/ruby-shadow/ruby-shadow_git.bb
@@ -20,4 +20,4 @@ RDEPENDS_${PN} += " \
20" 20"
21 21
22RUBY_INSTALL_GEMS = "ruby-shadow-${PV}.gem" 22RUBY_INSTALL_GEMS = "ruby-shadow-${PV}.gem"
23FILES_${PN}-dbg += "/usr/lib64/ruby/gems/*/gems/ruby-shadow-${PV}/.debug/shadow.so" 23FILES_${PN}-dbg += "/usr/lib*/ruby/gems/*/gems/ruby-shadow-${PV}/.debug/shadow.so"