summaryrefslogtreecommitdiffstats
path: root/recipes-support
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2016-01-09 14:04:15 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-01-11 09:33:32 -0500
commit20848accde109c8819f13a78eb37593b68f0b2e9 (patch)
treec184c159c806038945781aa8247a8af8945b8931 /recipes-support
parentf961d9626e97185247348a052fcd2cbd5802c3e1 (diff)
downloadmeta-cloud-services-20848accde109c8819f13a78eb37593b68f0b2e9.tar.gz
puppet: add new recipe for puppet-vswitch module
There are several puppet modules that provide functionality to interact with vSwitches, such as OpenVSwitch. This one is one of the more popular and is an officially sanctioned puppet module so using this one for the time being. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/puppet-vswitch/files/Add-gemspec.patch35
-rw-r--r--recipes-support/puppet-vswitch/puppet-vswitch_git.bb32
2 files changed, 67 insertions, 0 deletions
diff --git a/recipes-support/puppet-vswitch/files/Add-gemspec.patch b/recipes-support/puppet-vswitch/files/Add-gemspec.patch
new file mode 100644
index 0000000..2216c3b
--- /dev/null
+++ b/recipes-support/puppet-vswitch/files/Add-gemspec.patch
@@ -0,0 +1,35 @@
1From 66ffd1621d30b3fe9ccbc0a7d21319b351833afb Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Thu, 17 Dec 2015 14:06:18 -0500
4Subject: [PATCH] Add gemspec
5
6Started with an example from here
7http://guides.rubygems.org/make-your-own-gem/
8
9Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
10---
11 puppet-vswitch.gemspec | 12 ++++++++++++
12 1 file changed, 12 insertions(+)
13 create mode 100644 puppet-vswitch.gemspec
14
15diff --git a/puppet-vswitch.gemspec b/puppet-vswitch.gemspec
16new file mode 100644
17index 0000000..eb4c44e
18--- /dev/null
19+++ b/puppet-vswitch.gemspec
20@@ -0,0 +1,12 @@
21+Gem::Specification.new do |s|
22+ s.name = 'puppet-vswitch'
23+ s.version = '3.0.0'
24+ s.date = '2015-11-27'
25+ s.summary = "Puppet provider for virtual switches."
26+ s.description = s.summary
27+ s.authors = ["Puppet Labs"]
28+ s.email = ''
29+ s.files = %w(LICENSE README.md Rakefile) + Dir.glob('{lib,spec}/**/*')
30+ s.homepage = 'https://github.com/openstack/puppet-vswitch'
31+ s.license = 'Apache 2.0'
32+end
33--
342.1.4
35
diff --git a/recipes-support/puppet-vswitch/puppet-vswitch_git.bb b/recipes-support/puppet-vswitch/puppet-vswitch_git.bb
new file mode 100644
index 0000000..86922ae
--- /dev/null
+++ b/recipes-support/puppet-vswitch/puppet-vswitch_git.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Puppet provider for virtual switches."
2HOMEPAGE = "https://github.com/openstack/puppet-vswitch"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
5
6PV = "3.0.0"
7SRCREV = "c374840910c823f7669cf2e1229c7df7192ae880"
8
9SRC_URI = " \
10 git://github.com/openstack/puppet-vswitch.git;branch=master \
11 file://Add-gemspec.patch \
12"
13
14inherit ruby
15
16S="${WORKDIR}/git"
17
18DEPENDS += " \
19 ruby \
20 facter \
21"
22
23RDEPENDS_${PN} += " \
24 ruby \
25 facter \
26 puppet \
27"
28
29RUBY_INSTALL_GEMS = "puppet-vswitch-${PV}.gem"
30
31do_install_append() {
32}