summaryrefslogtreecommitdiffstats
path: root/recipes-support
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-03-12 23:27:48 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-03-12 23:27:48 -0400
commit691aa792135d8089df2865b2476331bb8d4e4d00 (patch)
treed5e3012201c49dbf705d6d6741e3e4cdb33fa0b0 /recipes-support
parent7f8de36343df74ba7aacc2ccb61e3b78d9b90ac0 (diff)
downloadmeta-cloud-services-691aa792135d8089df2865b2476331bb8d4e4d00.tar.gz
Revert "spice: Fix compile errors from gcc 7 with spice 0.12.4"
This reverts commit 7f8de36343df74ba7aacc2ccb61e3b78d9b90ac0.
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/spice/files/v0.12.4_0001-spice-Fix-compile-problems-against-spice-0.12.4-with.patch88
-rw-r--r--recipes-support/spice/spice_git.bb1
2 files changed, 0 insertions, 89 deletions
diff --git a/recipes-support/spice/files/v0.12.4_0001-spice-Fix-compile-problems-against-spice-0.12.4-with.patch b/recipes-support/spice/files/v0.12.4_0001-spice-Fix-compile-problems-against-spice-0.12.4-with.patch
deleted file mode 100644
index cd5eb85..0000000
--- a/recipes-support/spice/files/v0.12.4_0001-spice-Fix-compile-problems-against-spice-0.12.4-with.patch
+++ /dev/null
@@ -1,88 +0,0 @@
1From 26ae6be2c1ac03e6ea017f58d0b126c9eebae5f9 Mon Sep 17 00:00:00 2001
2From: Jason Wessel <jason.wessel@windriver.com>
3Date: Fri, 2 Mar 2018 10:47:09 -0600
4Subject: [PATCH] spice: Fix compile problems against spice 0.12.4 with gcc 7
5
6These errors are generated by gcc 7.
7
8../../git/server/red_parse_qxl.c:367:18: error: 'BITMAP_FMT_IS_RGB' defined but not used [-Werror=unused-const-variable=]
9 static const int BITMAP_FMT_IS_RGB[] = {0, 0, 0, 0, 0, 0, 1, 1, 1, 1, 1};
10 ^~~~~~~~~~~~~~~~~
11../../git/server/inputs_channel.c: In function 'inputs_channel_handle_parsed':
12../../git/server/inputs_channel.c:317:38: error: this statement may fall through [-Werror=implicit-fallthrough=]
13 case SPICE_MSGC_INPUTS_KEY_DOWN: {
14 ^
15../../git/server/inputs_channel.c:324:5: note: here
16 case SPICE_MSGC_INPUTS_KEY_UP: {
17 ^~~~
18../../git/server/reds.c: In function 'vdi_port_read_one_msg_from_device':
19../../git/server/reds.c:797:31: error: this statement may fall through [-Werror=implicit-fallthrough=]
20 state->read_state = VDI_PORT_READ_STATE_GET_BUFF;
21 ~~~~~~~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
22../../git/server/reds.c:798:9: note: here
23 case VDI_PORT_READ_STATE_GET_BUFF: {
24 ^~~~
25../../git/server/reds.c:807:31: error: this statement may fall through [-Werror=implicit-fallthrough=]
26 state->read_state = VDI_PORT_READ_STATE_READ_DATA;
27 ~~~~~~~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
28../../git/server/reds.c:809:9: note: here
29 case VDI_PORT_READ_STATE_READ_DATA:
30 ^~~~
31
32This patch just adds the fallthrough comments which are already
33checked in upstream along with the removal of the static variable
34which is not used.
35---
36 server/inputs_channel.c | 1 +
37 server/red_parse_qxl.c | 4 ----
38 server/reds.c | 2 ++
39 spice-common | 2 +-
40 4 files changed, 4 insertions(+), 5 deletions(-)
41
42diff --git a/server/inputs_channel.c b/server/inputs_channel.c
43index 931dac1..d6805c4 100644
44--- a/server/inputs_channel.c
45+++ b/server/inputs_channel.c
46@@ -321,6 +321,7 @@ static int inputs_channel_handle_parsed(RedChannelClient *rcc, uint32_t size, ui
47 activate_modifiers_watch();
48 }
49 }
50+ /* fallthrough */
51 case SPICE_MSGC_INPUTS_KEY_UP: {
52 SpiceMsgcKeyDown *key_down = (SpiceMsgcKeyDown *)buf;
53 for (i = 0; i < 4; i++) {
54diff --git a/server/red_parse_qxl.c b/server/red_parse_qxl.c
55index 6c0b065..c361e6b 100644
56--- a/server/red_parse_qxl.c
57+++ b/server/red_parse_qxl.c
58@@ -362,10 +362,6 @@ static int bitmap_consistent(SpiceBitmap *bitmap)
59 return TRUE;
60 }
61
62-// This is based on SPICE_BITMAP_FMT_*, copied from server/red_worker.c
63-// to avoid a possible unoptimization from making it non static.
64-static const int BITMAP_FMT_IS_RGB[] = {0, 0, 0, 0, 0, 0, 1, 1, 1, 1, 1};
65-
66 static SpiceImage *red_get_image(RedMemSlotInfo *slots, int group_id,
67 QXLPHYSICAL addr, uint32_t flags, int is_mask)
68 {
69diff --git a/server/reds.c b/server/reds.c
70index 6f262b0..4246170 100644
71--- a/server/reds.c
72+++ b/server/reds.c
73@@ -795,6 +795,7 @@ static SpiceCharDeviceMsgToClient *vdi_port_read_one_msg_from_device(SpiceCharDe
74 }
75 state->message_recive_len = state->vdi_chunk_header.size;
76 state->read_state = VDI_PORT_READ_STATE_GET_BUFF;
77+ /* fallthrough */
78 case VDI_PORT_READ_STATE_GET_BUFF: {
79 if (!(state->current_read_buf = vdi_port_read_buf_get())) {
80 return NULL;
81@@ -806,6 +807,7 @@ static SpiceCharDeviceMsgToClient *vdi_port_read_one_msg_from_device(SpiceCharDe
82 state->message_recive_len -= state->recive_len;
83 state->read_state = VDI_PORT_READ_STATE_READ_DATA;
84 }
85+ /* fallthrough */
86 case VDI_PORT_READ_STATE_READ_DATA:
87 n = sif->read(vdagent, state->recive_pos, state->recive_len);
88 if (!n) {
diff --git a/recipes-support/spice/spice_git.bb b/recipes-support/spice/spice_git.bb
index bca447d..c0fdd9c 100644
--- a/recipes-support/spice/spice_git.bb
+++ b/recipes-support/spice/spice_git.bb
@@ -35,7 +35,6 @@ SRC_URI += " \
35 file://spice-fix-CVE-2013-4282.patch \ 35 file://spice-fix-CVE-2013-4282.patch \
36 file://configure.ac-add-subdir-objects-to-AM_INIT_AUTOMAKE.patch \ 36 file://configure.ac-add-subdir-objects-to-AM_INIT_AUTOMAKE.patch \
37 file://build-allow-separated-src-and-build-dirs.patch \ 37 file://build-allow-separated-src-and-build-dirs.patch \
38 file://v0.12.4_0001-spice-Fix-compile-problems-against-spice-0.12.4-with.patch \
39 file://0001-red_parse_qxl-Fix-BITMAP_FMT_IS_RGB-defined-but-not-.patch \ 38 file://0001-red_parse_qxl-Fix-BITMAP_FMT_IS_RGB-defined-but-not-.patch \
40 file://0001-Use-PRI-macros-in-printf-to-keep-compatibility-betwe.patch \ 39 file://0001-Use-PRI-macros-in-printf-to-keep-compatibility-betwe.patch \
41 file://Fix-build-issues-with-gcc-7.patch \ 40 file://Fix-build-issues-with-gcc-7.patch \