summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-10-31 00:22:52 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-11-25 15:25:34 -0500
commita5a59d040b5db77a06346a516d30566a21d41586 (patch)
tree4de8d0e5f26396e1a66f668eec38d7b3bbb1465f /meta-openstack
parent0a962a285a529def3d3649544214bc36c9292d18 (diff)
downloadmeta-cloud-services-a5a59d040b5db77a06346a516d30566a21d41586.tar.gz
python-quantum/python-neutron: update to havana version
Updating the OpenStack networking component to the havana release version. As part of this switch, we rename the components from quantum to neutron and switch to a git based build for the client and servers. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone/identity.sh13
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron/fix-amqlib-version.patch (renamed from meta-openstack/recipes-devtools/python/python-quantum/fix-amqlib-version.patch)6
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron/linuxbridge_conf.ini (renamed from meta-openstack/recipes-devtools/python/python-quantum/linuxbridge_conf.ini)10
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron/neutron-agent.init (renamed from meta-openstack/recipes-devtools/python/python-quantum/quantum-agent.init)6
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron/neutron-server.init (renamed from meta-openstack/recipes-devtools/python/python-quantum/quantum-server.init)12
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron/ovs_neutron_plugin.ini (renamed from meta-openstack/recipes-devtools/python/python-quantum/ovs_quantum_plugin.ini)16
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron_git.bb (renamed from meta-openstack/recipes-devtools/python/python-quantum_2013.1.3.bb)108
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutronclient_git.bb23
-rw-r--r--meta-openstack/recipes-devtools/python/python-quantumclient_2.2.1.bb24
-rw-r--r--meta-openstack/recipes-extended/packagegroups/packagegroup-cloud-compute.bb2
-rw-r--r--meta-openstack/recipes-extended/packagegroups/packagegroup-cloud-controller.bb4
-rw-r--r--meta-openstack/recipes-extended/packagegroups/packagegroup-cloud-network.bb6
12 files changed, 114 insertions, 116 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystone/identity.sh b/meta-openstack/recipes-devtools/python/python-keystone/identity.sh
index df6fd1c..5027976 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone/identity.sh
+++ b/meta-openstack/recipes-devtools/python/python-keystone/identity.sh
@@ -73,12 +73,13 @@ if [ $? -eq 1 ]; then
73else 73else
74 GLANCE_USER=$(keystone user-get glance | grep " id " | get_field 2) 74 GLANCE_USER=$(keystone user-get glance | grep " id " | get_field 2)
75fi 75fi
76keystone user-get quantum 76keystone user-get neutron
77if [ $? -eq 1 ]; then 77if [ $? -eq 1 ]; then
78 QUANTUM_USER=$(keystone user-create --name=quantum --pass="$SERVICE_PASSWORD" --tenant-id $SERVICE_TENANT --email=quantum@domain.com | grep " id " | get_field 2) 78 NEUTRON_USER=$(keystone user-create --name=neutron --pass="$SERVICE_PASSWORD" --tenant-id $SERVICE_TENANT --email=neutron@domain.com | grep " id " | get_field 2)
79else 79else
80 QUANTUM_USER=$(keystone user-get quantum | grep " id " | get_field 2) 80 NEUTRON_USER=$(keystone user-get neutron | grep " id " | get_field 2)
81fi 81fi
82
82keystone user-get cinder 83keystone user-get cinder
83if [ $? -eq 1 ]; then 84if [ $? -eq 1 ]; then
84 CINDER_USER=$(keystone user-create --name=cinder --pass="$SERVICE_PASSWORD" --tenant-id $SERVICE_TENANT --email=cinder@domain.com | grep " id " | get_field 2) 85 CINDER_USER=$(keystone user-create --name=cinder --pass="$SERVICE_PASSWORD" --tenant-id $SERVICE_TENANT --email=cinder@domain.com | grep " id " | get_field 2)
@@ -110,8 +111,8 @@ keystone user-role-add --tenant-id $SERVICE_TENANT --user-id $NOVA_USER --role-i
110keystone user-role-list --user-id $GLANCE_USER --tenant-id $SERVICE_TENANT &> /dev/null 111keystone user-role-list --user-id $GLANCE_USER --tenant-id $SERVICE_TENANT &> /dev/null
111keystone user-role-add --tenant-id $SERVICE_TENANT --user-id $GLANCE_USER --role-id $ADMIN_ROLE 112keystone user-role-add --tenant-id $SERVICE_TENANT --user-id $GLANCE_USER --role-id $ADMIN_ROLE
112 113
113keystone user-role-list --user-id $QUANTUM_USER --tenant-id $SERVICE_TENANT &> /dev/null 114keystone user-role-list --user-id $NEUTRON_USER --tenant-id $SERVICE_TENANT &> /dev/null
114keystone user-role-add --tenant-id $SERVICE_TENANT --user-id $QUANTUM_USER --role-id $ADMIN_ROLE 115keystone user-role-add --tenant-id $SERVICE_TENANT --user-id $NEUTRON_USER --role-id $ADMIN_ROLE
115 116
116keystone user-role-list --user-id $CINDER_USER --tenant-id $SERVICE_TENANT &> /dev/null 117keystone user-role-list --user-id $CINDER_USER --tenant-id $SERVICE_TENANT &> /dev/null
117keystone user-role-add --tenant-id $SERVICE_TENANT --user-id $CINDER_USER --role-id $ADMIN_ROLE 118keystone user-role-add --tenant-id $SERVICE_TENANT --user-id $CINDER_USER --role-id $ADMIN_ROLE
@@ -125,7 +126,7 @@ VOLUME_SERVICE=$(keystone service-create --name cinder --type volume --descripti
125IMAGE_SERVICE=$(keystone service-create --name glance --type image --description 'OpenStack Image Service' | grep " id " | get_field 2) 126IMAGE_SERVICE=$(keystone service-create --name glance --type image --description 'OpenStack Image Service' | grep " id " | get_field 2)
126IDENTITY_SERVICE=$(keystone service-create --name keystone --type identity --description 'OpenStack Identity' | grep " id " | get_field 2) 127IDENTITY_SERVICE=$(keystone service-create --name keystone --type identity --description 'OpenStack Identity' | grep " id " | get_field 2)
127EC2_SERVICE=$(keystone service-create --name ec2 --type ec2 --description 'OpenStack EC2 service' | grep " id " | get_field 2) 128EC2_SERVICE=$(keystone service-create --name ec2 --type ec2 --description 'OpenStack EC2 service' | grep " id " | get_field 2)
128NETWORK_SERVICE=$(keystone service-create --name quantum --type network --description 'OpenStack Networking service' | grep " id " | get_field 2) 129NETWORK_SERVICE=$(keystone service-create --name neutron --type network --description 'OpenStack Networking service' | grep " id " | get_field 2)
129 130
130# Create endpoints 131# Create endpoints
131keystone endpoint-create --region $KEYSTONE_REGION --service-id $COMPUTE_SERVICE --publicurl 'http://'"$KEYSTONE_HOST"':8774/v2/$(tenant_id)s' --adminurl 'http://'"$KEYSTONE_HOST"':8774/v2/$(tenant_id)s' --internalurl 'http://'"$KEYSTONE_HOST"':8774/v2/$(tenant_id)s' 132keystone endpoint-create --region $KEYSTONE_REGION --service-id $COMPUTE_SERVICE --publicurl 'http://'"$KEYSTONE_HOST"':8774/v2/$(tenant_id)s' --adminurl 'http://'"$KEYSTONE_HOST"':8774/v2/$(tenant_id)s' --internalurl 'http://'"$KEYSTONE_HOST"':8774/v2/$(tenant_id)s'
diff --git a/meta-openstack/recipes-devtools/python/python-quantum/fix-amqlib-version.patch b/meta-openstack/recipes-devtools/python/python-neutron/fix-amqlib-version.patch
index 72aff5e..4a085b9 100644
--- a/meta-openstack/recipes-devtools/python/python-quantum/fix-amqlib-version.patch
+++ b/meta-openstack/recipes-devtools/python/python-neutron/fix-amqlib-version.patch
@@ -1,7 +1,7 @@
1Index: quantum-2013.1.1/tools/pip-requires 1Index: neutron-2013.1.1/tools/pip-requires
2=================================================================== 2===================================================================
3--- quantum-2013.1.1.orig/tools/pip-requires 3--- neutron-2013.1.1.orig/tools/pip-requires
4+++ quantum-2013.1.1/tools/pip-requires 4+++ neutron-2013.1.1/tools/pip-requires
5@@ -1,7 +1,7 @@ 5@@ -1,7 +1,7 @@
6 Paste 6 Paste
7 PasteDeploy>=1.5.0 7 PasteDeploy>=1.5.0
diff --git a/meta-openstack/recipes-devtools/python/python-quantum/linuxbridge_conf.ini b/meta-openstack/recipes-devtools/python/python-neutron/linuxbridge_conf.ini
index 7779621..d3646d5 100644
--- a/meta-openstack/recipes-devtools/python/python-quantum/linuxbridge_conf.ini
+++ b/meta-openstack/recipes-devtools/python/python-neutron/linuxbridge_conf.ini
@@ -23,10 +23,10 @@
23[DATABASE] 23[DATABASE]
24# This line MUST be changed to actually run the plugin. 24# This line MUST be changed to actually run the plugin.
25# Example: 25# Example:
26# sql_connection = mysql://root:nova@127.0.0.1:3306/quantum_linux_bridge 26# sql_connection = mysql://root:nova@127.0.0.1:3306/neutron_linux_bridge
27# Replace 127.0.0.1 above with the IP address of the database used by the 27# Replace 127.0.0.1 above with the IP address of the database used by the
28# main quantum server. (Leave it as is if the database runs on this host.) 28# main neutron server. (Leave it as is if the database runs on this host.)
29sql_connection = postgresql://%DB_USER%:%DB_PASSWORD%@localhost/quantum 29sql_connection = postgresql://%DB_USER%:%DB_PASSWORD%@localhost/neutron
30# Database reconnection retry times - in event connectivity is lost 30# Database reconnection retry times - in event connectivity is lost
31# set to -1 implies an infinite retry count 31# set to -1 implies an infinite retry count
32# sql_max_retries = 10 32# sql_max_retries = 10
@@ -59,5 +59,5 @@ reconnect_interval = 2
59polling_interval = 2 59polling_interval = 2
60 60
61[SECURITYGROUP] 61[SECURITYGROUP]
62# Firewall driver for realizing quantum security group function 62# Firewall driver for realizing neutron security group function
63firewall_driver = quantum.agent.linux.iptables_firewall.IptablesFirewallDriver 63firewall_driver = neutron.agent.linux.iptables_firewall.IptablesFirewallDriver
diff --git a/meta-openstack/recipes-devtools/python/python-quantum/quantum-agent.init b/meta-openstack/recipes-devtools/python/python-neutron/neutron-agent.init
index 1a33d06..f575746 100644
--- a/meta-openstack/recipes-devtools/python/python-quantum/quantum-agent.init
+++ b/meta-openstack/recipes-devtools/python/python-neutron/neutron-agent.init
@@ -9,9 +9,9 @@
9### END INIT INFO 9### END INIT INFO
10 10
11SUFFIX=@suffix@ 11SUFFIX=@suffix@
12DESC="quantum-$SUFFIX-agent" 12DESC="neutron-$SUFFIX-agent"
13DAEMON="/usr/bin/quantum-$SUFFIX-agent" 13DAEMON="/usr/bin/neutron-$SUFFIX-agent"
14PIDFILE="/var/run/quantum-$SUFFIX-agent.pid" 14PIDFILE="/var/run/neutron-$SUFFIX-agent.pid"
15 15
16start() 16start()
17{ 17{
diff --git a/meta-openstack/recipes-devtools/python/python-quantum/quantum-server.init b/meta-openstack/recipes-devtools/python/python-neutron/neutron-server.init
index e85bc48..387f602 100644
--- a/meta-openstack/recipes-devtools/python/python-quantum/quantum-server.init
+++ b/meta-openstack/recipes-devtools/python/python-neutron/neutron-server.init
@@ -1,19 +1,19 @@
1#!/bin/sh 1#!/bin/sh
2 2
3### BEGIN INIT INFO 3### BEGIN INIT INFO
4# Provides: quantum-server 4# Provides: neutron-server
5# Required-Start: $remote_fs $syslog 5# Required-Start: $remote_fs $syslog
6# Required-Stop: $remote_fs $syslog 6# Required-Stop: $remote_fs $syslog
7# Default-Start: 2 3 5 7# Default-Start: 2 3 5
8# Default-Stop: 0 1 6 8# Default-Stop: 0 1 6
9# Short-Description: quantum-server 9# Short-Description: neutron-server
10# Description: Provides the Quantum networking service 10# Description: Provides the Quantum networking service
11### END INIT INFO 11### END INIT INFO
12 12
13DESC="quantum-server" 13DESC="neutron-server"
14DAEMON="/usr/bin/quantum-server" 14DAEMON="/usr/bin/neutron-server"
15PIDFILE="/var/run/quantum-server.pid" 15PIDFILE="/var/run/neutron-server.pid"
16DAEMON_ARGS="--config-file=/etc/quantum/quantum.conf --config-file=@plugin@" 16DAEMON_ARGS="--config-file=/etc/neutron/neutron.conf --config-file=@plugin@"
17 17
18start() 18start()
19{ 19{
diff --git a/meta-openstack/recipes-devtools/python/python-quantum/ovs_quantum_plugin.ini b/meta-openstack/recipes-devtools/python/python-neutron/ovs_neutron_plugin.ini
index 0981afe..54f50b0 100644
--- a/meta-openstack/recipes-devtools/python/python-quantum/ovs_quantum_plugin.ini
+++ b/meta-openstack/recipes-devtools/python/python-neutron/ovs_neutron_plugin.ini
@@ -1,13 +1,13 @@
1[DATABASE] 1[DATABASE]
2# This line MUST be changed to actually run the plugin. 2# This line MUST be changed to actually run the plugin.
3# Example: 3# Example:
4# sql_connection = mysql://root:nova@127.0.0.1:3306/ovs_quantum 4# sql_connection = mysql://root:nova@127.0.0.1:3306/ovs_neutron
5# Replace 127.0.0.1 above with the IP address of the database used by the 5# Replace 127.0.0.1 above with the IP address of the database used by the
6# main quantum server. (Leave it as is if the database runs on this host.) 6# main neutron server. (Leave it as is if the database runs on this host.)
7 7
8# configs with listening issues, may need to use the localhost version 8# configs with listening issues, may need to use the localhost version
9# sql_connection = postgresql://%DB_USER%:%DB_PASSWORD%@localhost/ovs_quantum 9# sql_connection = postgresql://%DB_USER%:%DB_PASSWORD%@localhost/ovs_neutron
10sql_connection = postgresql://%DB_USER%:%DB_PASSWORD%@%CONTROLLER_IP%/ovs_quantum 10sql_connection = postgresql://%DB_USER%:%DB_PASSWORD%@%CONTROLLER_IP%/ovs_neutron
11# Database reconnection retry times - in event connectivity is lost 11# Database reconnection retry times - in event connectivity is lost
12# set to -1 implies an infinite retry count 12# set to -1 implies an infinite retry count
13# sql_max_retries = 10 13# sql_max_retries = 10
@@ -104,8 +104,8 @@ tunnel_id_ranges = 1:1000
104polling_interval = 2 104polling_interval = 2
105 105
106[SECURITYGROUP] 106[SECURITYGROUP]
107# Firewall driver for realizing quantum security group function 107# Firewall driver for realizing neutron security group function
108# firewall_driver = quantum.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver 108# firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
109 109
110#----------------------------------------------------------------------------- 110#-----------------------------------------------------------------------------
111# Sample Configurations. 111# Sample Configurations.
@@ -113,7 +113,7 @@ polling_interval = 2
113# 113#
114# 1. With VLANs on eth1. 114# 1. With VLANs on eth1.
115# [DATABASE] 115# [DATABASE]
116# sql_connection = mysql://root:nova@127.0.0.1:3306/ovs_quantum 116# sql_connection = mysql://root:nova@127.0.0.1:3306/ovs_neutron
117# [OVS] 117# [OVS]
118# network_vlan_ranges = default:2000:3999 118# network_vlan_ranges = default:2000:3999
119# tunnel_id_ranges = 119# tunnel_id_ranges =
@@ -124,7 +124,7 @@ polling_interval = 2
124# 124#
125# 2. With tunneling. 125# 2. With tunneling.
126# [DATABASE] 126# [DATABASE]
127# sql_connection = mysql://root:nova@127.0.0.1:3306/ovs_quantum 127# sql_connection = mysql://root:nova@127.0.0.1:3306/ovs_neutron
128# [OVS] 128# [OVS]
129# network_vlan_ranges = 129# network_vlan_ranges =
130# tunnel_id_ranges = 1:1000 130# tunnel_id_ranges = 1:1000
diff --git a/meta-openstack/recipes-devtools/python/python-quantum_2013.1.3.bb b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
index 8198e6a..588849a 100644
--- a/meta-openstack/recipes-devtools/python/python-quantum_2013.1.3.bb
+++ b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
@@ -1,42 +1,40 @@
1DESCRIPTION = "Quantum (virtual network service)" 1DESCRIPTION = "Neutron (virtual network service)"
2HOMEPAGE = "https://launchpad.net/quantum" 2HOMEPAGE = "https://launchpad.net/neutron"
3SECTION = "devel/python" 3SECTION = "devel/python"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6 6
7PR = "r0" 7PR = "r0"
8SRCNAME = "quantum" 8SRCNAME = "neutron"
9 9
10SRC_URI = "https://launchpad.net/${SRCNAME}/grizzly/${PV}/+download/${SRCNAME}-${PV}.tar.gz \ 10SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/havana \
11 file://ovs_quantum_plugin.ini \ 11 file://ovs_neutron_plugin.ini \
12 file://linuxbridge_conf.ini \ 12 file://linuxbridge_conf.ini \
13 file://quantum-server.init \ 13 file://neutron-server.init \
14 file://quantum-agent.init \ 14 file://neutron-agent.init \
15 " 15 "
16SRCREV="a3f8cf3513c01ed2f92af9d49a92a67a67f80308"
17PV="2013.2+git${SRCPV}"
16 18
17SRC_URI[md5sum] = "ca410283029db2cade16c8af003f9b7f" 19S = "${WORKDIR}/git"
18SRC_URI[sha256sum] = "79e60ec1aef800da3a4e1841909cdd8b2cf645979d08f27bc481957c7944e93d"
19
20
21S = "${WORKDIR}/${SRCNAME}-${PV}"
22 20
23inherit setuptools update-rc.d identity hosts 21inherit setuptools update-rc.d identity hosts
24 22
25do_install_append() { 23do_install_append() {
26 TEMPLATE_CONF_DIR=${S}${sysconfdir}/ 24 TEMPLATE_CONF_DIR=${S}${sysconfdir}/
27 QUANTUM_CONF_DIR=${D}${sysconfdir}/quantum 25 NEUTRON_CONF_DIR=${D}${sysconfdir}/neutron
28 26
29 sed -e "s:%SERVICE_TENANT_NAME%:${SERVICE_TENANT_NAME}:g" \ 27 sed -e "s:%SERVICE_TENANT_NAME%:${SERVICE_TENANT_NAME}:g" \
30 ${TEMPLATE_CONF_DIR}/quantum.conf > ${WORKDIR}/quantum.conf 28 ${TEMPLATE_CONF_DIR}/neutron.conf > ${WORKDIR}/neutron.conf
31 sed -e "s:%SERVICE_USER%:${SRCNAME}:g" -i ${WORKDIR}/quantum.conf 29 sed -e "s:%SERVICE_USER%:${SRCNAME}:g" -i ${WORKDIR}/neutron.conf
32 sed -e "s:%SERVICE_PASSWORD%:${SERVICE_PASSWORD}:g" \ 30 sed -e "s:%SERVICE_PASSWORD%:${SERVICE_PASSWORD}:g" \
33 -i ${WORKDIR}/quantum.conf 31 -i ${WORKDIR}/neutron.conf
34 sed -e "s:^# core_plugin.*:core_plugin = quantum.plugins.openvswitch.ovs_quantum_plugin.OVSQuantumPluginV2:g" \ 32 sed -e "s:^# core_plugin.*:core_plugin = neutron.plugins.openvswitch.ovs_neutron_plugin.OVSNeutronPluginV2:g" \
35 -i ${WORKDIR}/quantum.conf 33 -i ${WORKDIR}/neutron.conf
36 34
37 echo "rabbit_host = ${CONTROLLER_IP}" >> ${WORKDIR}/quantum.conf 35 echo "rabbit_host = ${CONTROLLER_IP}" >> ${WORKDIR}/neutron.conf
38 36
39 for file in ovs_quantum_plugin.ini linuxbridge_conf.ini 37 for file in ovs_neutron_plugin.ini linuxbridge_conf.ini
40 do 38 do
41 sed -e "s:%DB_USER%:${DB_USER}:g" -i ${WORKDIR}/${file} 39 sed -e "s:%DB_USER%:${DB_USER}:g" -i ${WORKDIR}/${file}
42 sed -e "s:%DB_PASSWORD%:${DB_PASSWORD}:g" -i ${WORKDIR}/${file} 40 sed -e "s:%DB_PASSWORD%:${DB_PASSWORD}:g" -i ${WORKDIR}/${file}
@@ -44,26 +42,26 @@ do_install_append() {
44 sed -e "s:%CONTROLLER_HOST%:${CONTROLLER_HOST}:g" -i ${WORKDIR}/${file} 42 sed -e "s:%CONTROLLER_HOST%:${CONTROLLER_HOST}:g" -i ${WORKDIR}/${file}
45 done 43 done
46 44
47 install -d ${QUANTUM_CONF_DIR} 45 install -d ${NEUTRON_CONF_DIR}
48 install -d ${QUANTUM_CONF_DIR}/plugins/openvswitch 46 install -d ${NEUTRON_CONF_DIR}/plugins/openvswitch
49 install -d ${QUANTUM_CONF_DIR}/plugins/linuxbridge 47 install -d ${NEUTRON_CONF_DIR}/plugins/linuxbridge
50 48
51 install -m 600 ${WORKDIR}/quantum.conf ${QUANTUM_CONF_DIR}/ 49 install -m 600 ${WORKDIR}/neutron.conf ${NEUTRON_CONF_DIR}/
52 install -m 600 ${WORKDIR}/ovs_quantum_plugin.ini ${QUANTUM_CONF_DIR}/plugins/openvswitch/ 50 install -m 600 ${WORKDIR}/ovs_neutron_plugin.ini ${NEUTRON_CONF_DIR}/plugins/openvswitch/
53 install -m 600 ${WORKDIR}/linuxbridge_conf.ini ${QUANTUM_CONF_DIR}/plugins/linuxbridge/ 51 install -m 600 ${WORKDIR}/linuxbridge_conf.ini ${NEUTRON_CONF_DIR}/plugins/linuxbridge/
54 install -m 600 ${S}/etc/api-paste.ini ${QUANTUM_CONF_DIR}/ 52 install -m 600 ${S}/etc/api-paste.ini ${NEUTRON_CONF_DIR}/
55 install -m 600 ${S}/etc/policy.json ${QUANTUM_CONF_DIR}/ 53 install -m 600 ${S}/etc/policy.json ${NEUTRON_CONF_DIR}/
56 54
57 install -d ${D}${localstatedir}/log/${SRCNAME} 55 install -d ${D}${localstatedir}/log/${SRCNAME}
58 56
59 PLUGIN=openvswitch 57 PLUGIN=openvswitch
60 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then 58 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
61 install -d ${D}${sysconfdir}/init.d 59 install -d ${D}${sysconfdir}/init.d
62 sed "s:@plugin@:/etc/quantum/plugins/$PLUGIN/ovs_quantum_plugin.ini:" \ 60 sed "s:@plugin@:/etc/neutron/plugins/$PLUGIN/ovs_neutron_plugin.ini:" \
63 < ${WORKDIR}/quantum-server.init >${WORKDIR}/quantum-server.init.sh 61 < ${WORKDIR}/neutron-server.init >${WORKDIR}/neutron-server.init.sh
64 install -m 0755 ${WORKDIR}/quantum-server.init.sh ${D}${sysconfdir}/init.d/quantum-server 62 install -m 0755 ${WORKDIR}/neutron-server.init.sh ${D}${sysconfdir}/init.d/neutron-server
65 sed "s:@suffix@:$PLUGIN:" < ${WORKDIR}/quantum-agent.init >${WORKDIR}/quantum-$PLUGIN.init.sh 63 sed "s:@suffix@:$PLUGIN:" < ${WORKDIR}/neutron-agent.init >${WORKDIR}/neutron-$PLUGIN.init.sh
66 install -m 0755 ${WORKDIR}/quantum-$PLUGIN.init.sh ${D}${sysconfdir}/init.d/quantum-$PLUGIN-agent 64 install -m 0755 ${WORKDIR}/neutron-$PLUGIN.init.sh ${D}${sysconfdir}/init.d/neutron-$PLUGIN-agent
67 fi 65 fi
68} 66}
69 67
@@ -79,7 +77,7 @@ pkg_postinst_${SRCNAME} () {
79 sleep 5 77 sleep 5
80 fi 78 fi
81 79
82 sudo -u postgres createdb ovs_quantum 80 sudo -u postgres createdb ovs_neutron
83} 81}
84 82
85pkg_postinst_${SRCNAME}-plugin-openvswitch () { 83pkg_postinst_${SRCNAME}-plugin-openvswitch () {
@@ -106,43 +104,43 @@ PACKAGES += " \
106FILES_${PN} = "${libdir}/*" 104FILES_${PN} = "${libdir}/*"
107 105
108FILES_${SRCNAME} = " \ 106FILES_${SRCNAME} = " \
109 ${bindir}/quantum-db-manage \ 107 ${bindir}/neutron-db-manage \
110 ${bindir}/quantum-rootwrap \ 108 ${bindir}/neutron-rootwrap \
111 ${bindir}/quantum-debug \ 109 ${bindir}/neutron-debug \
112 ${bindir}/quantum-netns-cleanup \ 110 ${bindir}/neutron-netns-cleanup \
113 ${bindir}/quantum-ovs-cleanup \ 111 ${bindir}/neutron-ovs-cleanup \
114 ${sysconfdir}/${SRCNAME}/* \ 112 ${sysconfdir}/${SRCNAME}/* \
115 ${localstatedir}/* \ 113 ${localstatedir}/* \
116 " 114 "
117 115
118FILES_${SRCNAME}-server = "${bindir}/quantum-server \ 116FILES_${SRCNAME}-server = "${bindir}/neutron-server \
119 ${sysconfdir}/init.d/quantum-server \ 117 ${sysconfdir}/init.d/neutron-server \
120 " 118 "
121 119
122FILES_${SRCNAME}-plugin-openvswitch = " \ 120FILES_${SRCNAME}-plugin-openvswitch = " \
123 ${bindir}/quantum-openvswitch-agent \ 121 ${bindir}/neutron-openvswitch-agent \
124 ${sysconfdir}/${SRCNAME}/plugins/openvswitch/ovs_quantum_plugin.ini \ 122 ${sysconfdir}/${SRCNAME}/plugins/openvswitch/ovs_neutron_plugin.ini \
125 ${sysconfdir}/init.d/quantum-openvswitch-agent \ 123 ${sysconfdir}/init.d/neutron-openvswitch-agent \
126 " 124 "
127 125
128FILES_${SRCNAME}-plugin-linuxbridge = " \ 126FILES_${SRCNAME}-plugin-linuxbridge = " \
129 ${bindir}/quantum-linuxbridge-agent \ 127 ${bindir}/neutron-linuxbridge-agent \
130 ${sysconfdir}/${SRCNAME}/plugins/linuxbridge/linuxbridge_conf.ini \ 128 ${sysconfdir}/${SRCNAME}/plugins/linuxbridge/linuxbridge_conf.ini \
131 ${sysconfdir}/init.d/quantum-linuxbridge-agent \ 129 ${sysconfdir}/init.d/neutron-linuxbridge-agent \
132 " 130 "
133 131
134FILES_${SRCNAME}-dhcp-agent = "${bindir}/quantum-dhcp-agent \ 132FILES_${SRCNAME}-dhcp-agent = "${bindir}/neutron-dhcp-agent \
135 ${bindir}/quantum-dhcp-agent-dnsmasq-lease-update \ 133 ${bindir}/neutron-dhcp-agent-dnsmasq-lease-update \
136 ${sysconfdir}/${SRCNAME}/dhcp_agent.ini \ 134 ${sysconfdir}/${SRCNAME}/dhcp_agent.ini \
137 ${sysconfdir}/init.d/dhcp_agent \ 135 ${sysconfdir}/init.d/dhcp_agent \
138 " 136 "
139 137
140FILES_${SRCNAME}-l3-agent = "${bindir}/quantum-l3-agent \ 138FILES_${SRCNAME}-l3-agent = "${bindir}/neutron-l3-agent \
141 ${sysconfdir}/${SRCNAME}/l3_agent.ini \ 139 ${sysconfdir}/${SRCNAME}/l3_agent.ini \
142 ${sysconfdir}/init.d/l3_agent \ 140 ${sysconfdir}/init.d/l3_agent \
143 " 141 "
144 142
145FILES_${SRCNAME}-metadata-agent = "${bindir}/quantum-metadata-agent \ 143FILES_${SRCNAME}-metadata-agent = "${bindir}/neutron-metadata-agent \
146 ${sysconfdir}/${SRCNAME}/metadata_agent.ini \ 144 ${sysconfdir}/${SRCNAME}/metadata_agent.ini \
147 ${sysconfdir}/init.d/metadata_agent \ 145 ${sysconfdir}/init.d/metadata_agent \
148 " 146 "
@@ -163,7 +161,7 @@ RDEPENDS_${PN} += "python-paste \
163 python-iso8601 \ 161 python-iso8601 \
164 python-kombu \ 162 python-kombu \
165 python-netaddr \ 163 python-netaddr \
166 python-quantumclient \ 164 python-neutronclient \
167 python-sqlalchemy \ 165 python-sqlalchemy \
168 python-webob \ 166 python-webob \
169 python-keystoneclient \ 167 python-keystoneclient \
@@ -187,6 +185,6 @@ RDEPENDS_${SRCNAME}-l3-agent = "${SRCNAME} ${SRCNAME}-metadata-agent iputils"
187RRECOMMENDS_${SRCNAME}-server = "${SRCNAME}-plugin-openvswitch" 185RRECOMMENDS_${SRCNAME}-server = "${SRCNAME}-plugin-openvswitch"
188 186
189INITSCRIPT_PACKAGES = "${SRCNAME}-server ${SRCNAME}-plugin-openvswitch ${SRCNAME}-plugin-linuxbridge" 187INITSCRIPT_PACKAGES = "${SRCNAME}-server ${SRCNAME}-plugin-openvswitch ${SRCNAME}-plugin-linuxbridge"
190INITSCRIPT_NAME_${SRCNAME}-server = "quantum-server" 188INITSCRIPT_NAME_${SRCNAME}-server = "neutron-server"
191INITSCRIPT_NAME_${SRCNAME}-plugin-openvswitch = "quantum-openvswitch-agent" 189INITSCRIPT_NAME_${SRCNAME}-plugin-openvswitch = "neutron-openvswitch-agent"
192INITSCRIPT_NAME_${SRCNAME}-plugin-linuxbridge = "quantum-linuxbridge-agent" 190INITSCRIPT_NAME_${SRCNAME}-plugin-linuxbridge = "neutron-linuxbridge-agent"
diff --git a/meta-openstack/recipes-devtools/python/python-neutronclient_git.bb b/meta-openstack/recipes-devtools/python/python-neutronclient_git.bb
new file mode 100644
index 0000000..7bcd057
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-neutronclient_git.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "CLI and python client library for OpenStack Neutron"
2HOMEPAGE = "https://launchpad.net/neutron"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7RDEPENDS_${PN} +="python-cliff \
8 python-httplib2 \
9 python-iso8601 \
10 python-prettytable \
11 python-pyparsing \
12 python-simplejson \
13 "
14
15PR = "r0"
16
17SRC_URI = "git://github.com/openstack/python-neutronclient.git;branch=master"
18
19PV="git${SRCPV}"
20SRCREV="1598fc0f75503f8c357ac4b58f77edf6e0443a69"
21S = "${WORKDIR}/git"
22
23inherit setuptools
diff --git a/meta-openstack/recipes-devtools/python/python-quantumclient_2.2.1.bb b/meta-openstack/recipes-devtools/python/python-quantumclient_2.2.1.bb
deleted file mode 100644
index ccbc665..0000000
--- a/meta-openstack/recipes-devtools/python/python-quantumclient_2.2.1.bb
+++ /dev/null
@@ -1,24 +0,0 @@
1DESCRIPTION = "CLI and python client library for OpenStack Quantum"
2HOMEPAGE = "https://launchpad.net/quantum"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7RDEPENDS_${PN} +="python-cliff \
8 python-httplib2 \
9 python-iso8601 \
10 python-prettytable \
11 python-pyparsing \
12 python-simplejson \
13 "
14
15PR = "r0"
16
17SRC_URI = "https://pypi.python.org/packages/source/p/${PN}/${PN}-${PV}.tar.gz"
18
19SRC_URI[md5sum] = "d319be32c95aa6e0110db925d5c3cfc9"
20SRC_URI[sha256sum] = "9c445a8a2fc751561e84e8633542bc8e77666cf8e4f01acce7cc8137acd43bee"
21
22S = "${WORKDIR}/${PN}-${PV}"
23
24inherit setuptools
diff --git a/meta-openstack/recipes-extended/packagegroups/packagegroup-cloud-compute.bb b/meta-openstack/recipes-extended/packagegroups/packagegroup-cloud-compute.bb
index 9f6cd22..d519827 100644
--- a/meta-openstack/recipes-extended/packagegroups/packagegroup-cloud-compute.bb
+++ b/meta-openstack/recipes-extended/packagegroups/packagegroup-cloud-compute.bb
@@ -12,7 +12,7 @@ RDEPENDS_${PN} = " qemu \
12 libvirt-virsh \ 12 libvirt-virsh \
13 nova-compute \ 13 nova-compute \
14 python-novaclient \ 14 python-novaclient \
15 quantum-plugin-openvswitch \ 15 neutron-plugin-openvswitch \
16 openvswitch-switch \ 16 openvswitch-switch \
17 " 17 "
18 18
diff --git a/meta-openstack/recipes-extended/packagegroups/packagegroup-cloud-controller.bb b/meta-openstack/recipes-extended/packagegroups/packagegroup-cloud-controller.bb
index a5a61e2..a9813b6 100644
--- a/meta-openstack/recipes-extended/packagegroups/packagegroup-cloud-controller.bb
+++ b/meta-openstack/recipes-extended/packagegroups/packagegroup-cloud-controller.bb
@@ -16,8 +16,8 @@ RDEPENDS_${PN} = " postgresql \
16 glance-api \ 16 glance-api \
17 glance-registry \ 17 glance-registry \
18 keystone \ 18 keystone \
19 quantum-server \ 19 neutron-server \
20 quantum-plugin-openvswitch \ 20 neutron-plugin-openvswitch \
21 openvswitch-controller \ 21 openvswitch-controller \
22 cinder-api \ 22 cinder-api \
23 cinder-volume \ 23 cinder-volume \
diff --git a/meta-openstack/recipes-extended/packagegroups/packagegroup-cloud-network.bb b/meta-openstack/recipes-extended/packagegroups/packagegroup-cloud-network.bb
index 430453b..f6dadc1 100644
--- a/meta-openstack/recipes-extended/packagegroups/packagegroup-cloud-network.bb
+++ b/meta-openstack/recipes-extended/packagegroups/packagegroup-cloud-network.bb
@@ -7,8 +7,8 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3
7inherit packagegroup 7inherit packagegroup
8 8
9RDEPENDS_${PN} = " \ 9RDEPENDS_${PN} = " \
10 quantum-plugin-openvswitch \ 10 neutron-plugin-openvswitch \
11 quantum-dhcp-agent \ 11 neutron-dhcp-agent \
12 quantum-l3-agent \ 12 neutron-l3-agent \
13 openvswitch-switch \ 13 openvswitch-switch \
14 " 14 "