summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorMark Asselstine <asselsm@gmail.com>2016-02-03 20:41:26 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:17 -0500
commitea5eb7a0243bea75ef479f46ed4b6384a4c9d062 (patch)
treed2a7334919c1f35cb1e5800c6d0f77d04937876e /meta-openstack
parent692cb2244e03bc015d5442dec6b69959fd110a0b (diff)
downloadmeta-cloud-services-ea5eb7a0243bea75ef479f46ed4b6384a4c9d062.tar.gz
python-designateclient: initial version
This package provides Python bindings to the Designate API. This package is required by heat. Signed-off-by: Mark Asselstine <asselsm@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-designateclient_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-designateclient_git.bb b/meta-openstack/recipes-devtools/python/python-designateclient_git.bb
new file mode 100644
index 0000000..d8477d5
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-designateclient_git.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "Python bindings to the Designate API"
2HOMEPAGE = "https://github.com/openstack/python-designateclient"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7DEPENDS += " \
8 python-pip \
9 python-pbr \
10 "
11
12RDEPENDS_${PN} +=" \
13 python-cliff \
14 python-jsonschema \
15 python-oslo.utils \
16 python-pbr \
17 python-keystoneclient \
18 python-requests \
19 python-six \
20 python-stevedore \
21 python-debtcollector \
22 "
23
24SRCNAME = "designateclient"
25SRC_URI = "git://github.com/openstack/${BPN}.git;branch=master"
26
27PV = "1.5.0+git${SRCPV}"
28SRCREV = "b97ae05612522180cc6f64485212811329da9645"
29S = "${WORKDIR}/git"
30
31inherit setuptools