summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorMark Asselstine <asselsm@gmail.com>2016-02-03 20:41:24 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:17 -0500
commitd4bb2d204e4a4efbb69c6a9308e2ac5346dec216 (patch)
tree1ff71c08364a6838570d3d955b6d98202717092f /meta-openstack
parent4fb3f26b6f38f3bd7282e21f7f3a324120a129e0 (diff)
downloadmeta-cloud-services-d4bb2d204e4a4efbb69c6a9308e2ac5346dec216.tar.gz
python-manilaclient: initial version
This package provides Python bindings to the OpenStack Manila API. This package is required by heat. Signed-off-by: Mark Asselstine <asselsm@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-manilaclient_git.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-manilaclient_git.bb b/meta-openstack/recipes-devtools/python/python-manilaclient_git.bb
new file mode 100644
index 0000000..5cabf2e
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-manilaclient_git.bb
@@ -0,0 +1,35 @@
1DESCRIPTION = "Python bindings to the OpenStack Manila API"
2HOMEPAGE = "https://github.com/openstack/python-manilaclient"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=9edbbf5857ab51214ef0e8b79069bb07"
6
7DEPENDS += " \
8 python-pip \
9 python-pbr \
10 "
11
12RDEPENDS_${PN} +=" \
13 python-pbr \
14 python-iso8601 \
15 python-oslo.config \
16 python-oslo.log \
17 python-oslo.serialization \
18 python-oslo.utils \
19 python-prettytable \
20 python-pycrypto \
21 python-requests \
22 python-simplejson \
23 python-babel \
24 python-six \
25 python-keystoneclient \
26 "
27
28SRCNAME = "manilaclient"
29SRC_URI = "git://github.com/openstack/${BPN}.git;branch=master"
30
31PV = "1.4.0+git${SRCPV}"
32SRCREV = "0bbd2144f701df3408b1435b16611c2ba3c22221"
33S = "${WORKDIR}/git"
34
35inherit setuptools rmargparse