summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorMark Asselstine <asselsm@gmail.com>2016-02-03 20:41:25 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:17 -0500
commit692cb2244e03bc015d5442dec6b69959fd110a0b (patch)
treeebb40ecb59c7bbba34469e681d815b16812c83bc /meta-openstack
parentd4bb2d204e4a4efbb69c6a9308e2ac5346dec216 (diff)
downloadmeta-cloud-services-692cb2244e03bc015d5442dec6b69959fd110a0b.tar.gz
python-magnumclient: initial version
This package provides a Python client for containers service. This package is required by heat. Signed-off-by: Mark Asselstine <asselsm@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-magnumclient_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-magnumclient_git.bb b/meta-openstack/recipes-devtools/python/python-magnumclient_git.bb
new file mode 100644
index 0000000..fd12589
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-magnumclient_git.bb
@@ -0,0 +1,34 @@
1DESCRIPTION = "Python client for containers service"
2HOMEPAGE = "https://github.com/openstack/python-magnumclient"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
6
7DEPENDS += " \
8 python-pip \
9 python-pbr \
10 "
11
12RDEPENDS_${PN} +=" \
13 python-pbr \
14 python-babel \
15 python-oslo.config \
16 python-oslo.i18n \
17 python-oslo.serialization \
18 python-oslo.utils \
19 python-iso8601 \
20 python-requests \
21 python-keystoneclient \
22 python-pyyaml \
23 python-stevedore \
24 python-six \
25 "
26
27SRCNAME = "magnumclient"
28SRC_URI = "git://github.com/openstack/${BPN}.git;branch=master"
29
30PV = "1.0.0.0b1+git${SRCPV}"
31SRCREV = "fb1ff6777eb96a5b7ba38156bf8354cda9b88ad4"
32S = "${WORKDIR}/git"
33
34inherit setuptools rmargparse