summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorMark Asselstine <asselsm@gmail.com>2016-02-03 20:41:23 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:17 -0500
commit4fb3f26b6f38f3bd7282e21f7f3a324120a129e0 (patch)
treed4f12026f05d2d142e14d83d522a5d2fc5590be5 /meta-openstack
parent27dca14941e32ec7897a6a9bfa28908f849a0651 (diff)
downloadmeta-cloud-services-4fb3f26b6f38f3bd7282e21f7f3a324120a129e0.tar.gz
python-mistralclient: initial version
This package provides a Python client for Mistral REST API. This package is required by heat. Signed-off-by: Mark Asselstine <asselsm@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-mistralclient_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-mistralclient_git.bb b/meta-openstack/recipes-devtools/python/python-mistralclient_git.bb
new file mode 100644
index 0000000..f721bd3
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-mistralclient_git.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "Python client for Mistral REST API"
2HOMEPAGE = "https://github.com/openstack/python-mistralclient"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6
7DEPENDS += " \
8 python-pip \
9 python-pbr \
10 "
11
12RDEPENDS_${PN} +=" \
13 python-cliff \
14 python-pbr \
15 python-keystoneclient \
16 python-pyyaml \
17 python-requests \
18 "
19
20SRCNAME = "mistralclient"
21SRC_URI = "git://github.com/openstack/${BPN}.git;branch=master"
22
23PV = "1.1.0+git${SRCPV}"
24SRCREV = "48e2780ee0148efc186c8972ca22e572fa2433c5"
25S = "${WORKDIR}/git"
26
27inherit setuptools