diff options
author | Amy Fong <amy.fong@windriver.com> | 2014-07-30 18:16:53 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2014-07-31 11:57:20 -0400 |
commit | e7275931b151529c343f9c5039e5d5c382b35f8b (patch) | |
tree | 110e58367518f6ff35f1365278bd7222fba4a816 /meta-openstack | |
parent | f7238d1d3d127954c3460e2ad015f68f3bfe95d8 (diff) | |
download | meta-cloud-services-e7275931b151529c343f9c5039e5d5c382b35f8b.tar.gz |
openldap: Fix paths
Explicitly set the libexec dir to /usr/libexec for openstack
Signed-off-by: Amy Fong <amy.fong@windriver.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r-- | meta-openstack/recipes-support/openldap/files/initscript | 2 | ||||
-rw-r--r-- | meta-openstack/recipes-support/openldap/openldap_2.4.39.bbappend | 11 |
2 files changed, 10 insertions, 3 deletions
diff --git a/meta-openstack/recipes-support/openldap/files/initscript b/meta-openstack/recipes-support/openldap/files/initscript index f9c343a..51bdeff 100644 --- a/meta-openstack/recipes-support/openldap/files/initscript +++ b/meta-openstack/recipes-support/openldap/files/initscript | |||
@@ -6,7 +6,7 @@ | |||
6 | # | 6 | # |
7 | 7 | ||
8 | 8 | ||
9 | slapd=/usr/libexec/slapd | 9 | slapd=%LIBEXEC%/slapd |
10 | test -x "$slapd" || exit 0 | 10 | test -x "$slapd" || exit 0 |
11 | 11 | ||
12 | src_data_dir=/etc/openldap/ | 12 | src_data_dir=/etc/openldap/ |
diff --git a/meta-openstack/recipes-support/openldap/openldap_2.4.39.bbappend b/meta-openstack/recipes-support/openldap/openldap_2.4.39.bbappend index d8166ce..3f9fc7d 100644 --- a/meta-openstack/recipes-support/openldap/openldap_2.4.39.bbappend +++ b/meta-openstack/recipes-support/openldap/openldap_2.4.39.bbappend | |||
@@ -10,10 +10,15 @@ SRC_URI += "file://ops-base.ldif" | |||
10 | LDAP_DN ?= "dc=my-domain,dc=com" | 10 | LDAP_DN ?= "dc=my-domain,dc=com" |
11 | LDAP_DATADIR ?= "/etc/openldap-data/" | 11 | LDAP_DATADIR ?= "/etc/openldap-data/" |
12 | 12 | ||
13 | OPENLDAP_LIBEXECDIR = "/usr/libexec" | ||
14 | |||
15 | EXTRA_OECONF += "--libexecdir=${OPENLDAP_LIBEXECDIR}" | ||
16 | |||
13 | do_install_append() { | 17 | do_install_append() { |
14 | install -D -m 0755 ${WORKDIR}/initscript ${D}${sysconfdir}/init.d/openldap | 18 | install -D -m 0755 ${WORKDIR}/initscript ${D}${sysconfdir}/init.d/openldap |
15 | sed -i -e 's/%DEFAULT_DN%/${LDAP_DN}/g' ${D}${sysconfdir}/init.d/openldap | 19 | sed -i -e 's/%DEFAULT_DN%/${LDAP_DN}/g' ${D}${sysconfdir}/init.d/openldap |
16 | sed -i -e 's#%LDAP_DATADIR%#${LDAP_DATADIR}#g' ${D}${sysconfdir}/init.d/openldap | 20 | sed -i -e 's#%LDAP_DATADIR%#${LDAP_DATADIR}#g' ${D}${sysconfdir}/init.d/openldap |
21 | sed -i -e 's#%LIBEXEC%#${OPENLDAP_LIBEXECDIR}#g' ${D}${sysconfdir}/init.d/openldap | ||
17 | 22 | ||
18 | # This is duplicated in /etc/openldap and is for slapd | 23 | # This is duplicated in /etc/openldap and is for slapd |
19 | rm -f ${D}${localstatedir}/openldap-data/DB_CONFIG.example | 24 | rm -f ${D}${localstatedir}/openldap-data/DB_CONFIG.example |
@@ -21,7 +26,7 @@ do_install_append() { | |||
21 | rmdir --ignore-fail-on-non-empty "${D}${localstatedir}" | 26 | rmdir --ignore-fail-on-non-empty "${D}${localstatedir}" |
22 | 27 | ||
23 | # remove symlinks for backends, recreating in postinstall | 28 | # remove symlinks for backends, recreating in postinstall |
24 | rm ${D}/${libexecdir}/openldap/*.so | 29 | rm -f ${D}/${OPENLDAP_LIBEXECDIR}/openldap/*.so |
25 | 30 | ||
26 | sed -i -e '/^include\s*/a \ | 31 | sed -i -e '/^include\s*/a \ |
27 | include /etc/openldap/schema/cosine.schema \ | 32 | include /etc/openldap/schema/cosine.schema \ |
@@ -31,7 +36,7 @@ include /etc/openldap/schema/misc.schema' \ | |||
31 | ${D}/etc/openldap/slapd.conf | 36 | ${D}/etc/openldap/slapd.conf |
32 | 37 | ||
33 | sed -i -e '/^# Load dynamic backend modules:/a \ | 38 | sed -i -e '/^# Load dynamic backend modules:/a \ |
34 | modulepath /usr/libexec/openldap \ | 39 | modulepath ${OPENLDAP_LIBEXECDIR}/openldap \ |
35 | moduleload back_bdb.la' \ | 40 | moduleload back_bdb.la' \ |
36 | ${D}/etc/openldap/slapd.conf | 41 | ${D}/etc/openldap/slapd.conf |
37 | 42 | ||
@@ -65,3 +70,5 @@ inherit update-rc.d | |||
65 | INITSCRIPT_NAME = "openldap" | 70 | INITSCRIPT_NAME = "openldap" |
66 | INITSCRIPT_PARAMS = "defaults" | 71 | INITSCRIPT_PARAMS = "defaults" |
67 | 72 | ||
73 | FILES_${PN} += "${OPENLDAP_LIBEXECDIR}/*" | ||
74 | FILES_${PN}-dbg += "${OPENLDAP_LIBEXECDIR}/openldap/.debug ${OPENLDAP_LIBEXECDIR}/.debug" | ||