summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorVu Tran <vu.tran@windriver.com>2014-04-02 16:01:36 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-04-11 14:15:27 -0400
commit9ab68dd7f77fa44773697d005b63ef5c06136812 (patch)
tree533fe7736e8400ed47e4bc32eb0e2dc94013241c /meta-openstack
parenta3570a566ce8637277b60a61b1c0d9296e54123e (diff)
downloadmeta-cloud-services-9ab68dd7f77fa44773697d005b63ef5c06136812.tar.gz
introduce python-dnspython package
python-dnspython is DNS toolkit for Python (http://www.dnspython.org/) which is required by python-swift, so introduce it here. Signed-off-by: Vu Tran <vu.tran@windriver.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-dnspython_1.11.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-dnspython_1.11.1.bb b/meta-openstack/recipes-devtools/python/python-dnspython_1.11.1.bb
new file mode 100644
index 0000000..4a65f65
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-dnspython_1.11.1.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "DNS toolkit for Python"
2HOMEPAGE = "http://www.dnspython.org/"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=397eddfcb4bc7e2ece2fc79724a7cca2"
6
7PR = "r0"
8SRCNAME = "dnspython"
9SRC_URI = "http://www.dnspython.org/kits/${PV}/${SRCNAME}-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "6167344ca849bd2ba108a8aa6118cb2b"
12SRC_URI[sha256sum] = "c0c6fcf3ff52939e7eadd931282d083271f65cf0a174555a703563a400289768"
13
14S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16inherit setuptools
17
18# avoid "error: option --single-version-externally-managed not recognized"
19DISTUTILS_INSTALL_ARGS = "--root=${D} \
20 --prefix=${prefix} \
21 --install-lib=${PYTHON_SITEPACKAGES_DIR} \
22 --install-data=${datadir}"