diff options
author | Liam R. Howlett <Liam.Howlett@WindRiver.com> | 2014-09-19 15:52:17 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2014-09-22 11:46:43 -0400 |
commit | 1c34736247f8ae18d054cfecfec54152bf27f1d9 (patch) | |
tree | f5c2a952d804fc43c00e1be89751551b579aa6c0 /meta-openstack | |
parent | bf51fa4f053a6aecb816ed7b4dcca64e9bd5b9b3 (diff) | |
download | meta-cloud-services-1c34736247f8ae18d054cfecfec54152bf27f1d9.tar.gz |
keystone: Change packages configuration to use apache keystone.
This commit changes all required configurations to use keystone running
on apache. The following packages configurations were modified for
keystone running on apache: python-neutron, python-nova, tempest,
python-swift, python-rally, python-heat, python-glance,
python-cinder, python-ceilmoeter, python-horizon.
Signed-off-by: Liam R. Howlett <Liam.Howlett@WindRiver.com>
Diffstat (limited to 'meta-openstack')
14 files changed, 24 insertions, 42 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-ceilometer/ceilometer.conf b/meta-openstack/recipes-devtools/python/python-ceilometer/ceilometer.conf index db78580..c96462d 100644 --- a/meta-openstack/recipes-devtools/python/python-ceilometer/ceilometer.conf +++ b/meta-openstack/recipes-devtools/python/python-ceilometer/ceilometer.conf | |||
@@ -680,7 +680,7 @@ os_tenant_name=%SERVICE_TENANT_NAME% | |||
680 | 680 | ||
681 | # Auth URL to use for openstack service access (string value) | 681 | # Auth URL to use for openstack service access (string value) |
682 | #os_auth_url=http://localhost:5000/v2.0 | 682 | #os_auth_url=http://localhost:5000/v2.0 |
683 | os_auth_url=http://%CONTROLLER_IP%:5000/v2.0 | 683 | os_auth_url=http://%CONTROLLER_IP%:8081/keystone/main/v2.0 |
684 | 684 | ||
685 | # Region name to use for openstack service endpoints (string | 685 | # Region name to use for openstack service endpoints (string |
686 | # value) | 686 | # value) |
@@ -713,25 +713,11 @@ os_auth_url=http://%CONTROLLER_IP%:5000/v2.0 | |||
713 | # | 713 | # |
714 | # Options defined in keystoneclient.middleware.auth_token | 714 | # Options defined in keystoneclient.middleware.auth_token |
715 | # | 715 | # |
716 | 716 | identity_uri=http://127.0.0.1:8081/keystone/admin/ | |
717 | # Prefix to prepend at the beginning of the path (string | 717 | # Prefix to prepend at the beginning of the path (string |
718 | # value) | 718 | # value) |
719 | #auth_admin_prefix= | 719 | #auth_admin_prefix= |
720 | 720 | ||
721 | # Host providing the admin Identity API endpoint (string | ||
722 | # value) | ||
723 | auth_host=%CONTROLLER_IP% | ||
724 | |||
725 | # Port of the admin Identity API endpoint (integer value) | ||
726 | #auth_port=35357 | ||
727 | |||
728 | # Protocol of the admin Identity API endpoint(http or https) | ||
729 | # (string value) | ||
730 | auth_protocol=http | ||
731 | |||
732 | # Complete public Identity API endpoint (string value) | ||
733 | #auth_uri=<None> | ||
734 | |||
735 | # API version of the admin Identity API endpoint (string | 721 | # API version of the admin Identity API endpoint (string |
736 | # value) | 722 | # value) |
737 | #auth_version=<None> | 723 | #auth_version=<None> |
diff --git a/meta-openstack/recipes-devtools/python/python-cinder/cinder.conf b/meta-openstack/recipes-devtools/python/python-cinder/cinder.conf index 2772fb1..8b2bc84 100644 --- a/meta-openstack/recipes-devtools/python/python-cinder/cinder.conf +++ b/meta-openstack/recipes-devtools/python/python-cinder/cinder.conf | |||
@@ -1242,9 +1242,7 @@ volume_backend_name=RBD_CEPH | |||
1242 | # max_timing_buffer=100 | 1242 | # max_timing_buffer=100 |
1243 | 1243 | ||
1244 | [keystone_authtoken] | 1244 | [keystone_authtoken] |
1245 | auth_host = 127.0.0.1 | 1245 | identity_uri=http://127.0.0.1:8081/keystone/admin |
1246 | auth_port = 35357 | ||
1247 | auth_protocol = http | ||
1248 | admin_tenant_name = %SERVICE_TENANT_NAME% | 1246 | admin_tenant_name = %SERVICE_TENANT_NAME% |
1249 | admin_user = %SERVICE_USER% | 1247 | admin_user = %SERVICE_USER% |
1250 | admin_password = %SERVICE_PASSWORD% | 1248 | admin_password = %SERVICE_PASSWORD% |
diff --git a/meta-openstack/recipes-devtools/python/python-glance_git.bb b/meta-openstack/recipes-devtools/python/python-glance_git.bb index 52c0ebf..7775956 100644 --- a/meta-openstack/recipes-devtools/python/python-glance_git.bb +++ b/meta-openstack/recipes-devtools/python/python-glance_git.bb | |||
@@ -68,6 +68,7 @@ do_install_append() { | |||
68 | -i ${WORKDIR}/glance-$file.conf | 68 | -i ${WORKDIR}/glance-$file.conf |
69 | sed -e "s!^#connection =.*!connection = postgresql://${DB_USER}:${DB_PASSWORD}@localhost/glance!g" \ | 69 | sed -e "s!^#connection =.*!connection = postgresql://${DB_USER}:${DB_PASSWORD}@localhost/glance!g" \ |
70 | -i ${WORKDIR}/glance-$file.conf | 70 | -i ${WORKDIR}/glance-$file.conf |
71 | sed -i '/\[keystone_authtoken\]/aidentity_uri=http://127.0.0.1:8081/keystone/admin' ${WORKDIR}/glance-$file.conf | ||
71 | done | 72 | done |
72 | sed -e "s:^filesystem_store_datadir =.*:filesystem_store_datadir = ${sysconfdir}/${SRCNAME}/images/:g" \ | 73 | sed -e "s:^filesystem_store_datadir =.*:filesystem_store_datadir = ${sysconfdir}/${SRCNAME}/images/:g" \ |
73 | -i ${WORKDIR}/glance-api.conf | 74 | -i ${WORKDIR}/glance-api.conf |
@@ -77,7 +78,7 @@ do_install_append() { | |||
77 | -i ${WORKDIR}/glance-api.conf | 78 | -i ${WORKDIR}/glance-api.conf |
78 | 79 | ||
79 | sed 's:^default_store =.*:default_store = ${GLANCE_DEFAULT_STORE}:g' -i ${WORKDIR}/glance-api.conf | 80 | sed 's:^default_store =.*:default_store = ${GLANCE_DEFAULT_STORE}:g' -i ${WORKDIR}/glance-api.conf |
80 | sed 's:^swift_store_auth_address =.*:swift_store_auth_address = http\://127.0.0.1\:5000/v2.0/:g' -i ${WORKDIR}/glance-api.conf | 81 | sed 's:^swift_store_auth_address =.*:swift_store_auth_address = http\://127.0.0.1\:8081/keystone/main/:g' -i ${WORKDIR}/glance-api.conf |
81 | sed 's:^swift_store_user =.*:swift_store_user = ${SERVICE_TENANT_NAME}\:${SRCNAME}:g' -i ${WORKDIR}/glance-api.conf | 82 | sed 's:^swift_store_user =.*:swift_store_user = ${SERVICE_TENANT_NAME}\:${SRCNAME}:g' -i ${WORKDIR}/glance-api.conf |
82 | sed 's:^swift_store_key =.*:swift_store_key = ${SERVICE_PASSWORD}:g' -i ${WORKDIR}/glance-api.conf | 83 | sed 's:^swift_store_key =.*:swift_store_key = ${SERVICE_PASSWORD}:g' -i ${WORKDIR}/glance-api.conf |
83 | sed 's:^swift_store_create_container_on_put =.*:swift_store_create_container_on_put = True:g' -i ${WORKDIR}/glance-api.conf | 84 | sed 's:^swift_store_create_container_on_put =.*:swift_store_create_container_on_put = True:g' -i ${WORKDIR}/glance-api.conf |
diff --git a/meta-openstack/recipes-devtools/python/python-heat/heat.conf b/meta-openstack/recipes-devtools/python/python-heat/heat.conf index 95c88a1..4d84412 100644 --- a/meta-openstack/recipes-devtools/python/python-heat/heat.conf +++ b/meta-openstack/recipes-devtools/python/python-heat/heat.conf | |||
@@ -725,10 +725,7 @@ heat_waitcondition_server_url=http://%CONTROLLER_IP%:8000/v1/waitcondition | |||
725 | #password=<None> | 725 | #password=<None> |
726 | 726 | ||
727 | [keystone_authtoken] | 727 | [keystone_authtoken] |
728 | auth_host = %CONTROLLER_IP% | 728 | identity_uri=http://%CONTROLLER_IP%:8081/keystone/main |
729 | auth_port = 35357 | ||
730 | auth_protocol = http | ||
731 | auth_uri = http://%CONTROLLER_IP%:5000/v2.0 | ||
732 | 729 | ||
733 | admin_tenant_name = %SERVICE_TENANT_NAME% | 730 | admin_tenant_name = %SERVICE_TENANT_NAME% |
734 | admin_user = heat | 731 | admin_user = heat |
diff --git a/meta-openstack/recipes-devtools/python/python-horizon/local_settings.py b/meta-openstack/recipes-devtools/python/python-horizon/local_settings.py index 8046b69..3ba4ab0 100644 --- a/meta-openstack/recipes-devtools/python/python-horizon/local_settings.py +++ b/meta-openstack/recipes-devtools/python/python-horizon/local_settings.py | |||
@@ -125,7 +125,7 @@ EMAIL_BACKEND = 'django.core.mail.backends.console.EmailBackend' | |||
125 | # ] | 125 | # ] |
126 | 126 | ||
127 | OPENSTACK_HOST = "127.0.0.1" | 127 | OPENSTACK_HOST = "127.0.0.1" |
128 | OPENSTACK_KEYSTONE_URL = "http://%s:5000/v2.0" % OPENSTACK_HOST | 128 | OPENSTACK_KEYSTONE_URL = "http://%s:8081/keystone/main/v2.0" % OPENSTACK_HOST |
129 | OPENSTACK_KEYSTONE_DEFAULT_ROLE = "Member" | 129 | OPENSTACK_KEYSTONE_DEFAULT_ROLE = "Member" |
130 | 130 | ||
131 | # Disable SSL certificate checks (useful for self-signed certificates): | 131 | # Disable SSL certificate checks (useful for self-signed certificates): |
diff --git a/meta-openstack/recipes-devtools/python/python-neutron/0001-neutron.conf-jumpstart-nova-state-reporting-configur.patch b/meta-openstack/recipes-devtools/python/python-neutron/0001-neutron.conf-jumpstart-nova-state-reporting-configur.patch index dbe55db..77674a6 100644 --- a/meta-openstack/recipes-devtools/python/python-neutron/0001-neutron.conf-jumpstart-nova-state-reporting-configur.patch +++ b/meta-openstack/recipes-devtools/python/python-neutron/0001-neutron.conf-jumpstart-nova-state-reporting-configur.patch | |||
@@ -34,7 +34,7 @@ Index: git/etc/neutron.conf | |||
34 | 34 | ||
35 | # Authorization URL for connection to nova in admin context. | 35 | # Authorization URL for connection to nova in admin context. |
36 | -# nova_admin_auth_url = | 36 | -# nova_admin_auth_url = |
37 | +# nova_admin_auth_url = http://%CONTROLLER_IP%:35357/v2.0 | 37 | +# nova_admin_auth_url = http://%CONTROLLER_IP%:8081/keystone/admin |
38 | 38 | ||
39 | # CA file for novaclient to verify server certificates | 39 | # CA file for novaclient to verify server certificates |
40 | # nova_ca_certificates_file = | 40 | # nova_ca_certificates_file = |
diff --git a/meta-openstack/recipes-devtools/python/python-neutron/metadata_agent.ini b/meta-openstack/recipes-devtools/python/python-neutron/metadata_agent.ini index 98d958d..f9d5725 100644 --- a/meta-openstack/recipes-devtools/python/python-neutron/metadata_agent.ini +++ b/meta-openstack/recipes-devtools/python/python-neutron/metadata_agent.ini | |||
@@ -3,7 +3,7 @@ | |||
3 | # debug = True | 3 | # debug = True |
4 | 4 | ||
5 | # The Neutron user information for accessing the Neutron API. | 5 | # The Neutron user information for accessing the Neutron API. |
6 | auth_url = http://localhost:5000/v2.0 | 6 | identity_uri = http://localhost:8081/keystone/main |
7 | auth_region = RegionOne | 7 | auth_region = RegionOne |
8 | admin_tenant_name = %SERVICE_TENANT_NAME% | 8 | admin_tenant_name = %SERVICE_TENANT_NAME% |
9 | admin_user = %SERVICE_USER% | 9 | admin_user = %SERVICE_USER% |
diff --git a/meta-openstack/recipes-devtools/python/python-neutron_git.bb b/meta-openstack/recipes-devtools/python/python-neutron_git.bb index fb859af..295db97 100644 --- a/meta-openstack/recipes-devtools/python/python-neutron_git.bb +++ b/meta-openstack/recipes-devtools/python/python-neutron_git.bb | |||
@@ -113,7 +113,7 @@ do_install_append() { | |||
113 | install -m 0755 ${WORKDIR}/neutron-$AGENT.init.sh ${D}${sysconfdir}/init.d/neutron-$AGENT-agent | 113 | install -m 0755 ${WORKDIR}/neutron-$AGENT.init.sh ${D}${sysconfdir}/init.d/neutron-$AGENT-agent |
114 | install -m 600 ${WORKDIR}/${AGENT}_agent.ini ${NEUTRON_CONF_DIR}/ | 114 | install -m 600 ${WORKDIR}/${AGENT}_agent.ini ${NEUTRON_CONF_DIR}/ |
115 | fi | 115 | fi |
116 | 116 | ||
117 | AGENT=metadata | 117 | AGENT=metadata |
118 | ARGS="--config-file=${sysconfdir}/${SRCNAME}/neutron.conf --config-file=${sysconfdir}/${SRCNAME}/metadata_agent.ini" | 118 | ARGS="--config-file=${sysconfdir}/${SRCNAME}/neutron.conf --config-file=${sysconfdir}/${SRCNAME}/metadata_agent.ini" |
119 | if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then | 119 | if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then |
@@ -130,6 +130,11 @@ do_install_append() { | |||
130 | sed -e "s:%METADATA_SHARED_SECRET%:${METADATA_SHARED_SECRET}:g" \ | 130 | sed -e "s:%METADATA_SHARED_SECRET%:${METADATA_SHARED_SECRET}:g" \ |
131 | -i ${NEUTRON_CONF_DIR}/metadata_agent.ini | 131 | -i ${NEUTRON_CONF_DIR}/metadata_agent.ini |
132 | 132 | ||
133 | sed -e "s:^auth_host.*:#auth_host:g" -i ${NEUTRON_CONF_DIR}/neutron.conf | ||
134 | sed -e "s:^auth_port.*:#auth_port:g" -i ${NEUTRON_CONF_DIR}/neutron.conf | ||
135 | sed -e "s:^auth_protocol.*:#auth_protocol:g" -i ${NEUTRON_CONF_DIR}/neutron.conf | ||
136 | sed -i '/\[keystone_authtoken\]/aidentity_uri=http://127.0.0.1:8081/keystone/admin/' ${NEUTRON_CONF_DIR}/neutron.conf | ||
137 | |||
133 | cp run_tests.sh ${NEUTRON_CONF_DIR} | 138 | cp run_tests.sh ${NEUTRON_CONF_DIR} |
134 | 139 | ||
135 | sed 's:%PYTHON_SITEPACKAGES_DIR%:${PYTHON_SITEPACKAGES_DIR}:g' -i ${D}${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}/tests/unit/nec/test_nec_plugin.py | 140 | sed 's:%PYTHON_SITEPACKAGES_DIR%:${PYTHON_SITEPACKAGES_DIR}:g' -i ${D}${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}/tests/unit/nec/test_nec_plugin.py |
diff --git a/meta-openstack/recipes-devtools/python/python-nova/nova.conf b/meta-openstack/recipes-devtools/python/python-nova/nova.conf index 09ae44c..3cb143d 100644 --- a/meta-openstack/recipes-devtools/python/python-nova/nova.conf +++ b/meta-openstack/recipes-devtools/python/python-nova/nova.conf | |||
@@ -50,7 +50,7 @@ neutron_auth_strategy=keystone | |||
50 | neutron_admin_tenant_name=service | 50 | neutron_admin_tenant_name=service |
51 | neutron_admin_username=neutron | 51 | neutron_admin_username=neutron |
52 | neutron_admin_password=password | 52 | neutron_admin_password=password |
53 | neutron_admin_auth_url=http://%CONTROLLER_IP%:5000/v2.0/ | 53 | neutron_admin_auth_url=http://%CONTROLLER_IP%:8081/keystone/main/v2.0 |
54 | 54 | ||
55 | # Disables reporting of network state to the controller | 55 | # Disables reporting of network state to the controller |
56 | vif_plugging_timeout=10 | 56 | vif_plugging_timeout=10 |
@@ -85,9 +85,7 @@ server_proxyclient_address=%COMPUTE_IP% | |||
85 | 85 | ||
86 | auth_strategy=keystone | 86 | auth_strategy=keystone |
87 | [keystone_authtoken] | 87 | [keystone_authtoken] |
88 | auth_host = %CONTROLLER_IP% | 88 | identity_uri=http://127.0.0.1:8081/keystone/admin |
89 | auth_port = 35357 | ||
90 | auth_protocol = http | ||
91 | admin_tenant_name = %SERVICE_TENANT_NAME% | 89 | admin_tenant_name = %SERVICE_TENANT_NAME% |
92 | admin_user = %SERVICE_USER% | 90 | admin_user = %SERVICE_USER% |
93 | admin_password = %SERVICE_PASSWORD% | 91 | admin_password = %SERVICE_PASSWORD% |
diff --git a/meta-openstack/recipes-devtools/python/python-nova/openrc b/meta-openstack/recipes-devtools/python/python-nova/openrc index 35327ac..e8507f2 100644 --- a/meta-openstack/recipes-devtools/python/python-nova/openrc +++ b/meta-openstack/recipes-devtools/python/python-nova/openrc | |||
@@ -1,8 +1,8 @@ | |||
1 | export OS_TENANT_NAME=admin | 1 | export OS_TENANT_NAME=admin |
2 | export OS_USERNAME=admin | 2 | export OS_USERNAME=admin |
3 | export OS_PASSWORD=%OS_PASSWORD% | 3 | export OS_PASSWORD=%OS_PASSWORD% |
4 | export OS_AUTH_URL="http://%CONTROLLER_HOST%:5000/v2.0/" | 4 | export OS_AUTH_URL="http://%CONTROLLER_HOST%:8081/keystone/main/v2.0/" |
5 | export SERVICE_ENDPOINT="http://%CONTROLLER_HOST%:35357/v2.0" | 5 | export SERVICE_ENDPOINT="http://%CONTROLLER_HOST%:8081/keystone/admin/v2.0" |
6 | export SERVICE_TOKEN=%SERVICE_TOKEN% | 6 | export SERVICE_TOKEN=%SERVICE_TOKEN% |
7 | 7 | ||
8 | function get_field() { | 8 | function get_field() { |
diff --git a/meta-openstack/recipes-devtools/python/python-rally/deployment-existing.json b/meta-openstack/recipes-devtools/python/python-rally/deployment-existing.json index 8249860..dd08e41 100644 --- a/meta-openstack/recipes-devtools/python/python-rally/deployment-existing.json +++ b/meta-openstack/recipes-devtools/python/python-rally/deployment-existing.json | |||
@@ -1,7 +1,7 @@ | |||
1 | { | 1 | { |
2 | "type": "ExistingCloud", | 2 | "type": "ExistingCloud", |
3 | "endpoint": { | 3 | "endpoint": { |
4 | "auth_url": "http://%CONTROLLER_IP%:5000/v2.0/", | 4 | "auth_url": "http://%CONTROLLER_IP%:8081/keystone/main", |
5 | "username": "%ADMIN_USER%", | 5 | "username": "%ADMIN_USER%", |
6 | "password": "%ADMIN_PASSWORD%", | 6 | "password": "%ADMIN_PASSWORD%", |
7 | "tenant_name": "%ADMIN_TENANT_NAME%" | 7 | "tenant_name": "%ADMIN_TENANT_NAME%" |
diff --git a/meta-openstack/recipes-devtools/python/python-swift/dispersion.conf b/meta-openstack/recipes-devtools/python/python-swift/dispersion.conf index 25119ff..2557abb 100644 --- a/meta-openstack/recipes-devtools/python/python-swift/dispersion.conf +++ b/meta-openstack/recipes-devtools/python/python-swift/dispersion.conf | |||
@@ -1,5 +1,5 @@ | |||
1 | [dispersion] | 1 | [dispersion] |
2 | auth_url = http://localhost:5000/v2.0/ | 2 | auth_url = http://localhost:8081/keystone/main |
3 | auth_user = %SERVICE_TENANT_NAME%:%SERVICE_USER% | 3 | auth_user = %SERVICE_TENANT_NAME%:%SERVICE_USER% |
4 | auth_key = %SERVICE_PASSWORD% | 4 | auth_key = %SERVICE_PASSWORD% |
5 | auth_version = 2.0 | 5 | auth_version = 2.0 |
diff --git a/meta-openstack/recipes-devtools/python/python-swift/proxy-server.conf b/meta-openstack/recipes-devtools/python/python-swift/proxy-server.conf index d005d8e..eef6ac5 100644 --- a/meta-openstack/recipes-devtools/python/python-swift/proxy-server.conf +++ b/meta-openstack/recipes-devtools/python/python-swift/proxy-server.conf | |||
@@ -247,10 +247,7 @@ user_test_tester3 = testing3 | |||
247 | # | 247 | # |
248 | [filter:authtoken] | 248 | [filter:authtoken] |
249 | paste.filter_factory = keystoneclient.middleware.auth_token:filter_factory | 249 | paste.filter_factory = keystoneclient.middleware.auth_token:filter_factory |
250 | auth_host = 127.0.0.1 | 250 | identity_uri=http://127.0.0.1:8081/keystone/main |
251 | auth_port = 35357 | ||
252 | auth_protocol = http | ||
253 | # auth_uri = http://127.0.0.1:5000/ | ||
254 | admin_tenant_name = %SERVICE_TENANT_NAME% | 251 | admin_tenant_name = %SERVICE_TENANT_NAME% |
255 | admin_user = %SERVICE_USER% | 252 | admin_user = %SERVICE_USER% |
256 | admin_password = %SERVICE_PASSWORD% | 253 | admin_password = %SERVICE_PASSWORD% |
diff --git a/meta-openstack/recipes-extended/tempest/tempest/tempest.conf b/meta-openstack/recipes-extended/tempest/tempest/tempest.conf index 7a5bf3b..2a81536 100644 --- a/meta-openstack/recipes-extended/tempest/tempest/tempest.conf +++ b/meta-openstack/recipes-extended/tempest/tempest/tempest.conf | |||
@@ -25,9 +25,9 @@ catalog_type = identity | |||
25 | # environments that have self-signed SSL certs. | 25 | # environments that have self-signed SSL certs. |
26 | disable_ssl_certificate_validation = False | 26 | disable_ssl_certificate_validation = False |
27 | # URL for where to find the OpenStack Identity API endpoint (Keystone) | 27 | # URL for where to find the OpenStack Identity API endpoint (Keystone) |
28 | uri = http://127.0.0.1:5000/v2.0/ | 28 | uri = http://127.0.0.1:8081/keystone/main/v2.0/ |
29 | # URL for where to find the OpenStack V3 Identity API endpoint (Keystone) | 29 | # URL for where to find the OpenStack V3 Identity API endpoint (Keystone) |
30 | uri_v3 = http://127.0.0.1:5000/v3/ | 30 | uri_v3 = http://127.0.0.1:8081/keystone/main/v3/ |
31 | # The identity region. Also used as the other services' region name unless | 31 | # The identity region. Also used as the other services' region name unless |
32 | # they are set explicitly. | 32 | # they are set explicitly. |
33 | region = RegionOne | 33 | region = RegionOne |