summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorJosep Puigdemont <josep.puigdemont@enea.com>2015-12-02 17:32:36 +0100
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-12-07 10:52:38 -0500
commitaeadd2779cc475a2dc74bd555a69703908370445 (patch)
tree431dca64165694beeaa23767b3b136658830e70b /meta-openstack
parent4889d831f31f1a0c21f7f212d81261cb4505bd52 (diff)
downloadmeta-cloud-services-aeadd2779cc475a2dc74bd555a69703908370445.tar.gz
python-cryptography, -vectors: add 0.8.1
python-cryptography is required by python-pyopenssl >= 0.14 Keystone requires python-cryptography >=0.8 Includes python-cryptography-vectors package for ptest Over 75k unit tests (100% coverage): * tested on nuc (x86) and beaglebone (arm) hardware. ** will overload ram on default qemux86/qemuarm These commit is taken from meta-openembedded/meta-python revision c346f605766754c02004478371f22609f15ecd1a Signed-off-by: Josep Puigdemont <josep.puigdemont@enea.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-cryptography-vectors_0.8.1.bb14
-rw-r--r--meta-openstack/recipes-devtools/python/python-cryptography/run-ptest2
-rw-r--r--meta-openstack/recipes-devtools/python/python-cryptography_0.8.1.bb46
3 files changed, 62 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-cryptography-vectors_0.8.1.bb b/meta-openstack/recipes-devtools/python/python-cryptography-vectors_0.8.1.bb
new file mode 100644
index 0000000..a9b64ed
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-cryptography-vectors_0.8.1.bb
@@ -0,0 +1,14 @@
1SUMMARY = "Test vectors for the cryptography package."
2SECTION = "devel/python"
3LICENSE = "Apache-2.0 | BSD"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4"
5DEPENDS = "python-cryptography"
6SRCNAME = "cryptography_vectors"
7
8SRC_URI = "https://pypi.python.org/packages/source/c/cryptography-vectors/${SRCNAME}-${PV}.tar.gz"
9S = "${WORKDIR}/${SRCNAME}-${PV}"
10
11SRC_URI[md5sum] = "04fcfcc61aee62e3b4beb1740cd120ac"
12SRC_URI[sha256sum] = "4a69e66026bfce4b97f75e72fe262f5e8f71daddc081f6608e5b0db89e552504"
13
14inherit setuptools
diff --git a/meta-openstack/recipes-devtools/python/python-cryptography/run-ptest b/meta-openstack/recipes-devtools/python/python-cryptography/run-ptest
new file mode 100644
index 0000000..0ba239c
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-cryptography/run-ptest
@@ -0,0 +1,2 @@
1#!/bin/sh
2py.test
diff --git a/meta-openstack/recipes-devtools/python/python-cryptography_0.8.1.bb b/meta-openstack/recipes-devtools/python/python-cryptography_0.8.1.bb
new file mode 100644
index 0000000..41e4acd
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-cryptography_0.8.1.bb
@@ -0,0 +1,46 @@
1SUMMARY = "Provides cryptographic recipes and primitives to Python developers"
2SECTION = "devel/python"
3LICENSE = "Apache-2.0 | BSD"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4"
5DEPENDS += " python-cffi-native python-cffi python-enum34 python-six python-pyasn1"
6SRCNAME = "cryptography"
7
8SRC_URI = "https://pypi.python.org/packages/source/c/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
9 file://run-ptest \
10"
11S = "${WORKDIR}/${SRCNAME}-${PV}"
12
13SRC_URI[md5sum] = "70dde78a5515abdbfd7a3d58f15689ab"
14SRC_URI[sha256sum] = "f4e041bc83c1be94d87116a7aa201c378b7c6581be4d83994b2da0a84499f73b"
15
16inherit pypi
17
18RDEPENDS_${PN} = "\
19 python-pyasn1\
20 python-six\
21 python-cffi\
22 python-enum34\
23 python-setuptools\
24 python-pycparser\
25 python-subprocess\
26 python-threading\
27 python-numbers\
28 python-contextlib\
29"
30
31RDEPENDS_${PN}-ptest = "\
32 ${PN}\
33 python-pytest\
34 python-pretend\
35 python-iso8601\
36 python-cryptography-vectors\
37"
38
39inherit ptest
40
41do_install_ptest() {
42 install -d ${D}${PTEST_PATH}/tests
43 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
44 install -d ${D}${PTEST_PATH}/tests/hazmat
45 cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/
46}