summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2015-12-08 18:33:16 +0100
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-12-11 12:11:28 -0500
commit2719089b3c90234c714fb7b905d6c5ab5f5da6ce (patch)
tree8baf3735982fe8f218cb5ef8dc2c01a214300f94 /meta-openstack
parent5e4c6f860802e1b392305fe4d6bbf94170aba0e2 (diff)
downloadmeta-cloud-services-2719089b3c90234c714fb7b905d6c5ab5f5da6ce.tar.gz
python-enum: add new recipe
It's required by python-pyscss. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-enum_0.4.4.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-enum_0.4.4.bb b/meta-openstack/recipes-devtools/python/python-enum_0.4.4.bb
new file mode 100644
index 0000000..4671a59
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-enum_0.4.4.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Robust enumerated type support in Python"
2DESCRIPTION = "This package provides a module for robust enumerations in Python."
3HOMEPAGE = "https://pypi.python.org/pypi/enum"
4SECTION = "devel/python"
5LICENSE = "GPLv2 | PSFv2"
6LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=4325afd396febcb659c36b49533135d4 \
7 file://LICENSE.PSF;md5=1ad8a43fc3bbfea1585223c99f4c3e6f \
8"
9
10SRCNAME = "enum"
11SRC_URI = "http://pypi.python.org/packages/source/e/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
12
13SRC_URI[md5sum] = "ce75c7c3c86741175a84456cc5bd531e"
14SRC_URI[sha256sum] = "9bdfacf543baf2350df7613eb37f598a802f346985ca0dc1548be6494140fdff"
15
16S = "${WORKDIR}/${SRCNAME}-${PV}"
17
18inherit setuptools
19
20DEPENDS += " \
21 python-pip \
22"
23
24RDEPENDS_${PN} += " \
25"