summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorJosep Puigdemont <josep.puigdemont@enea.com>2015-12-08 18:33:44 +0100
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-12-11 12:11:29 -0500
commit24d3a97bf45883814ccfc6951d5fc52784d35008 (patch)
tree392e8b32f50f77d9414cba9db751c0e0826ef8a5 /meta-openstack
parent9b7c477913c7da9a95c87eac143c8e85dfd8f309 (diff)
downloadmeta-cloud-services-24d3a97bf45883814ccfc6951d5fc52784d35008.tar.gz
python-cliff: Fix object has no attribute debug error
Apply fix provided by upstream for the "object has no attribute error" when help is called. Signed-off-by: Josep Puigdemont <josep.puigdemont@enea.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-cliff/0001-Fix-object-has-no-attribute-debug-error.patch32
-rw-r--r--meta-openstack/recipes-devtools/python/python-cliff_1.10.0.bb5
2 files changed, 35 insertions, 2 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-cliff/0001-Fix-object-has-no-attribute-debug-error.patch b/meta-openstack/recipes-devtools/python/python-cliff/0001-Fix-object-has-no-attribute-debug-error.patch
new file mode 100644
index 0000000..38d5343
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-cliff/0001-Fix-object-has-no-attribute-debug-error.patch
@@ -0,0 +1,32 @@
1From f2c997161df01579cabf312a694289a1a83ae6ca Mon Sep 17 00:00:00 2001
2From: TerryHowe <terrylhowe@gmail.com>
3Date: Thu, 28 May 2015 07:55:11 -0600
4Subject: [PATCH] Fix object has no attribute debug error
5
6When print_help_if_requested is called, if there is an error,
7"object has no attribute 'debug'" gets printed out. This is
8because the parser is passed in to the command rather than the
9parsed arguments.
10
11Change-Id: I1863421eff82b3f493d276432369ada9f783b165
12Partial-Bug: #1459519
13---
14 cliff/app.py | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/cliff/app.py b/cliff/app.py
18index e052571..a41386a 100644
19--- a/cliff/app.py
20+++ b/cliff/app.py
21@@ -198,7 +198,7 @@ class App(object):
22 def print_help_if_requested(self):
23 if self.deferred_help and self.options.deferred_help:
24 action = HelpAction(None, None, default=self)
25- action(self.parser, self.parser, None, None)
26+ action(self.parser, self.options, None, None)
27
28 def run(self, argv):
29 """Equivalent to the main program for the application.
30--
312.1.0
32
diff --git a/meta-openstack/recipes-devtools/python/python-cliff_1.10.0.bb b/meta-openstack/recipes-devtools/python/python-cliff_1.10.0.bb
index e107a28..e7e1f7e 100644
--- a/meta-openstack/recipes-devtools/python/python-cliff_1.10.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-cliff_1.10.0.bb
@@ -4,10 +4,11 @@ SECTION = "devel/python"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6 6
7PR = "r0"
8SRCNAME = "cliff" 7SRCNAME = "cliff"
9 8
10SRC_URI = "https://pypi.python.org/packages/source/c/${SRCNAME}/${SRCNAME}-${PV}.tar.gz" 9SRC_URI = "https://pypi.python.org/packages/source/c/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
10 file://0001-Fix-object-has-no-attribute-debug-error.patch \
11 "
11 12
12SRC_URI[md5sum] = "8f3f67d57bf5a2541efeedcea1aa64ab" 13SRC_URI[md5sum] = "8f3f67d57bf5a2541efeedcea1aa64ab"
13SRC_URI[sha256sum] = "209882e199fdf98aeed0db44b922aa688e5a66d81c45148a5743804f9aa680e1" 14SRC_URI[sha256sum] = "209882e199fdf98aeed0db44b922aa688e5a66d81c45148a5743804f9aa680e1"