summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorLiam R. Howlett <Liam.Howlett@WindRiver.com>2014-08-28 10:47:33 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-09-04 15:27:59 -0400
commit83fee5b3333cce58ad5fa20e02ce43e5939c2b0e (patch)
treea232f6aa1d631b3af6130bb288a31a211d764878 /meta-openstack
parentdd84f8b58f38dbfa79c6ef56d4ee608979e23e3e (diff)
downloadmeta-cloud-services-83fee5b3333cce58ad5fa20e02ce43e5939c2b0e.tar.gz
python-horizon: Fix whitespace in recipe.
The horizon recipe had lines running well over 80 characters and indentation that was not a multiple of 4. This patch fixes those issues. Signed-off-by: Liam R. Howlett <Liam.Howlett@WindRiver.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-horizon_git.bb22
1 files changed, 14 insertions, 8 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-horizon_git.bb b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
index 0768b2d..b472aa9 100644
--- a/meta-openstack/recipes-devtools/python/python-horizon_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
@@ -75,17 +75,21 @@ do_install_append() {
75 sed -e "s:^LANGUAGE_CODE =.*:LANGUAGE_CODE = 'en-us':g" \ 75 sed -e "s:^LANGUAGE_CODE =.*:LANGUAGE_CODE = 'en-us':g" \
76 -i ${DASHBOARD_DIR}/settings.py 76 -i ${DASHBOARD_DIR}/settings.py
77 sed -e "s:^# from horizon.utils:from horizon.utils:g" \ 77 sed -e "s:^# from horizon.utils:from horizon.utils:g" \
78 ${DASHBOARD_DIR}/local/local_settings.py.example > ${DASHBOARD_DIR}/local/local_settings.py 78 ${DASHBOARD_DIR}/local/local_settings.py.example > \
79 ${DASHBOARD_DIR}/local/local_settings.py
79 sed -e "s:^# SECRET_KEY =:SECRET_KEY =:g" \ 80 sed -e "s:^# SECRET_KEY =:SECRET_KEY =:g" \
80 -i ${DASHBOARD_DIR}/local/local_settings.py 81 -i ${DASHBOARD_DIR}/local/local_settings.py
81 install -m 644 ${S}/manage.py ${DASHBOARD_DIR}/manage.py 82 install -m 644 ${S}/manage.py ${DASHBOARD_DIR}/manage.py
82 83
83 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then 84 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)};
85 then
84 install -d ${D}${sysconfdir}/init.d 86 install -d ${D}${sysconfdir}/init.d
85 sed 's:@PYTHON_SITEPACKAGES@:${PYTHON_SITEPACKAGES_DIR}:' ${WORKDIR}/horizon.init >${WORKDIR}/horizon 87 sed 's:@PYTHON_SITEPACKAGES@:${PYTHON_SITEPACKAGES_DIR}:' \
88 ${WORKDIR}/horizon.init >${WORKDIR}/horizon
86 install -m 0755 ${WORKDIR}/horizon ${D}${sysconfdir}/init.d/horizon 89 install -m 0755 ${WORKDIR}/horizon ${D}${sysconfdir}/init.d/horizon
87 fi 90 fi
88 sed -i -e 's#%PYTHON_SITEPACKAGES%#${PYTHON_SITEPACKAGES_DIR}#g' ${D}${PYTHON_SITEPACKAGES_DIR}/horizon/test/settings.py 91 sed -i -e 's#%PYTHON_SITEPACKAGES%#${PYTHON_SITEPACKAGES_DIR}#g' \
92 ${D}${PYTHON_SITEPACKAGES_DIR}/horizon/test/settings.py
89 93
90 # no longer required. kept as reference. 94 # no longer required. kept as reference.
91 # mv ${D}${datadir}/bin ${DASHBOARD_DIR}/bin 95 # mv ${D}${datadir}/bin ${DASHBOARD_DIR}/bin
@@ -98,14 +102,16 @@ do_install_append() {
98 cp ${S}/manage.py ${DASHBOARD_SHARE_DIR} 102 cp ${S}/manage.py ${DASHBOARD_SHARE_DIR}
99 103
100 install -D -m 644 ${WORKDIR}/local_settings.py \ 104 install -D -m 644 ${WORKDIR}/local_settings.py \
101 ${DASHBOARD_CONF_DIR}/local_settings.py 105 ${DASHBOARD_CONF_DIR}/local_settings.py
102 ln -fs ${sysconfdir}/openstack-dashboard/local_settings.py \ 106 ln -fs ${sysconfdir}/openstack-dashboard/local_settings.py \
103 ${DASHBOARD_SHARE_DIR}/openstack_dashboard/local/local_settings.py 107 ${DASHBOARD_SHARE_DIR}/openstack_dashboard/local/local_settings.py
104 108
105 install -D -m 644 ${WORKDIR}/openstack-dashboard-apache.conf \ 109 install -D -m 644 ${WORKDIR}/openstack-dashboard-apache.conf \
106 ${SYSCONF_DIR}/apache2/conf.d/openstack-dashboard-apache.conf 110 ${SYSCONF_DIR}/apache2/conf.d/openstack-dashboard-apache.conf
107 sed -i -e 's#%PYTHON_SITEPACKAGES%#${PYTHON_SITEPACKAGES_DIR}#' ${SYSCONF_DIR}/apache2/conf.d/openstack-dashboard-apache.conf 111 sed -i -e 's#%PYTHON_SITEPACKAGES%#${PYTHON_SITEPACKAGES_DIR}#' \
108 sed -i -e 's#%LIBDIR%#${libdir}#' ${SYSCONF_DIR}/apache2/conf.d/openstack-dashboard-apache.conf 112 ${SYSCONF_DIR}/apache2/conf.d/openstack-dashboard-apache.conf
113 sed -i -e 's#%LIBDIR%#${libdir}#' \
114 ${SYSCONF_DIR}/apache2/conf.d/openstack-dashboard-apache.conf
109 115
110 ln -fs openstack_dashboard/static ${DASHBOARD_SHARE_DIR}/static 116 ln -fs openstack_dashboard/static ${DASHBOARD_SHARE_DIR}/static
111 117