summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-support
diff options
context:
space:
mode:
authorAlejandro del Castillo <alejandro.delcastillo@ni.com>2015-05-28 11:13:59 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-06-01 12:11:54 -0400
commit44de8d81153a9efe97112533e28d99a242c463cc (patch)
tree6bc4171f7b22d511f994876044f8150b7d356ed0 /meta-openstack/recipes-support
parent2947e3015f74abae6c9e798d34d574ba6df02efb (diff)
downloadmeta-cloud-services-44de8d81153a9efe97112533e28d99a242c463cc.tar.gz
salt: upgrade to 2015.5
python-request is now only a dependency of salt-cloud. Signed-off-by: Alejandro del Castillo <alejandro.delcastillo@ni.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-support')
-rw-r--r--meta-openstack/recipes-support/salt/salt_2014.7.4.bb145
1 files changed, 0 insertions, 145 deletions
diff --git a/meta-openstack/recipes-support/salt/salt_2014.7.4.bb b/meta-openstack/recipes-support/salt/salt_2014.7.4.bb
deleted file mode 100644
index 5b618e0..0000000
--- a/meta-openstack/recipes-support/salt/salt_2014.7.4.bb
+++ /dev/null
@@ -1,145 +0,0 @@
1HOMEPAGE = "http://saltstack.com/"
2SECTION = "admin"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5357642471cfab4740d1d0a20c51af6a"
5DEPENDS = "\
6 python-msgpack \
7 python-pyyaml \
8 python-jinja2 \
9 python-markupsafe \
10 python-requests \
11 python-pyzmq \
12 python-pycrypto \
13 python-m2crypto \
14"
15
16SRCNAME = "salt"
17SRC_URI = "http://pypi.python.org/packages/source/s/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
18 file://set_python_location_hashbang.patch \
19 file://minion \
20 file://salt-minion \
21 file://salt-common.bash_completion \
22 file://salt-common.logrotate \
23 file://salt-api \
24 file://salt-master \
25 file://master \
26 file://salt-syndic \
27 file://cloud \
28 file://roster \
29"
30
31SRC_URI[md5sum] = "622404c0a6c38224f82a4c7b2927db61"
32SRC_URI[sha256sum] = "0adf4c138ebd26745b1d1157be0772d89da3582fe8a6622a8031cbe32a28e9f3"
33
34S = "${WORKDIR}/${SRCNAME}-${PV}"
35
36inherit setuptools update-rc.d
37
38PACKAGES += "\
39 ${PN}-api \
40 ${PN}-cloud \
41 ${PN}-common \
42 ${PN}-master \
43 ${PN}-minion \
44 ${PN}-ssh \
45 ${PN}-syndic \
46 ${PN}-bash-completion \
47"
48
49do_install_append() {
50 install -d ${D}${sysconfdir}/bash_completion.d/
51 install -m 0644 ${WORKDIR}/salt-common.bash_completion ${D}${sysconfdir}/bash_completion.d/${PN}-common
52 install -d ${D}${sysconfdir}/logrotate.d/
53 install -m 0644 ${WORKDIR}/salt-common.logrotate ${D}${sysconfdir}/logrotate.d/${PN}-common
54 install -d ${D}${sysconfdir}/init.d/
55 install -m 0755 ${WORKDIR}/salt-minion ${D}${sysconfdir}/init.d/${PN}-minion
56 install -m 0755 ${WORKDIR}/salt-api ${D}${sysconfdir}/init.d/${PN}-api
57 install -m 0755 ${WORKDIR}/salt-master ${D}${sysconfdir}/init.d/${PN}-master
58 install -m 0755 ${WORKDIR}/salt-syndic ${D}${sysconfdir}/init.d/${PN}-syndic
59 install -d ${D}${sysconfdir}/${PN}/
60 install -m 0644 ${WORKDIR}/minion ${D}${sysconfdir}/${PN}/minion
61 install -m 0644 ${WORKDIR}/master ${D}${sysconfdir}/${PN}/master
62 install -m 0644 ${WORKDIR}/cloud ${D}${sysconfdir}/${PN}/cloud
63 install -m 0644 ${WORKDIR}/roster ${D}${sysconfdir}/${PN}/roster
64 install -d ${D}${sysconfdir}/${PN}/cloud.conf.d ${D}${sysconfdir}/${PN}/cloud.profiles.d ${D}${sysconfdir}/${PN}/cloud.providers.d
65}
66
67ALLOW_EMPTY_${PN} = "1"
68FILES_${PN} = ""
69
70INITSCRIPT_PACKAGES = "${PN}-minion ${PN}-api ${PN}-master ${PN}-syndic"
71
72DESCRIPTION_COMMON = "salt is a powerful remote execution manager that can be used to administer servers in a\
73 fast and efficient way. It allows commands to be executed across large groups of servers. This means systems\
74 can be easily managed, but data can also be easily gathered. Quick introspection into running systems becomes\
75 a reality. Remote execution is usually used to set up a certain state on a remote system. Salt addresses this\
76 problem as well, the salt state system uses salt state files to define the state a server needs to be in. \
77Between the remote execution system, and state management Salt addresses the backbone of cloud and data center\
78 management."
79
80SUMMARY_${PN}-minion = "client package for salt, the distributed remote execution system"
81DESCRIPTION_${PN}-minion = "${DESCRIPTION_COMMON} This particular package provides the worker agent for salt."
82RDEPENDS_${PN}-minion = "python ${PN}-common (= ${EXTENDPKGV}) python-m2crypto python-pycrypto python-msgpack python-pyzmq (>= 13.1.0)"
83RRECOMMENDS_${PN}-minion_append_x64 = "dmidecode"
84RSUGGESTS_${PN}-minion = "python-augeas"
85CONFFILES_${PN}-minion = "${sysconfdir}/${PN}/minion ${sysconfdir}/init.d/${PN}-minion"
86FILES_${PN}-minion = "${bindir}/${PN}-minion ${sysconfdir}/${PN}/minion.d/ ${CONFFILES_${PN}-minion}"
87INITSCRIPT_NAME_${PN}-minion = "${PN}-minion"
88INITSCRIPT_PARAMS_${PN}-minion = "defaults"
89
90SUMMARY_${PN}-common = "shared libraries that salt requires for all packages"
91DESCRIPTION_${PN}-common ="${DESCRIPTION_COMMON} This particular package provides shared libraries that \
92salt-master, salt-minion, and salt-syndic require to function."
93RDEPENDS_${PN}-common = "python (>= 2.7) python (< 2.8) python-jinja2 python-pyyaml python-requests"
94RRECOMMENDS_${PN}-common = "lsb"
95RSUGGESTS_${PN}-common = "python-mako python-git"
96RCONFLICTS_${PN}-common = "python-mako (< 0.7.0)"
97CONFFILES_${PN}-common="${sysconfdir}/logrotate.d/${PN}-common"
98FILES_${PN}-common = "${bindir}/${PN}-call ${libdir}/python2.7/ ${CONFFILES_${PN}-common}"
99
100SUMMARY_${PN}-ssh = "remote manager to administer servers via salt"
101DESCRIPTION_${PN}-ssh = "${DESCRIPTION_COMMON} This particular package provides the salt ssh controller. It \
102is able to run salt modules and states on remote hosts via ssh. No minion or other salt specific software needs\
103 to be installed on the remote host."
104RDEPENDS_${PN}-ssh = "python ${PN}-common (= ${EXTENDPKGV}) python-msgpack"
105CONFFILES_${PN}-ssh="${sysconfdir}/${PN}/roster"
106FILES_${PN}-ssh = "${bindir}/${PN}-ssh ${CONFFILES_${PN}-ssh}"
107
108SUMMARY_${PN}-api = "generic, modular network access system"
109DESCRIPTION_${PN}-api = "a modular interface on top of Salt that can provide a variety of entry points into a \
110running Salt system. It can start and manage multiple interfaces allowing a REST API to coexist with XMLRPC or \
111even a Websocket API. The Salt API system is used to expose the fundamental aspects of Salt control to external\
112 sources. salt-api acts as the bridge between Salt itself and REST, Websockets, etc. Documentation is available\
113 on Read the Docs: http://salt-api.readthedocs.org/"
114RDEPENDS_${PN}-api = "python ${PN}-master"
115RSUGGESTS_${PN}-api = "python-cherrypy"
116CONFFILES_${PN}-api = "${sysconfdir}/init.d/${PN}-api"
117FILES_${PN}-api = "${bindir}/${PN}-api ${CONFFILES_${PN}-api}"
118INITSCRIPT_NAME_${PN}-api = "${PN}-api"
119INITSCRIPT_PARAMS_${PN}-api = "defaults"
120
121SUMMARY_${PN}-master = "remote manager to administer servers via salt"
122DESCRIPTION_${PN}-master ="${DESCRIPTION_COMMON} This particular package provides the salt controller."
123RDEPENDS_${PN}-master = "python ${PN}-common (= ${EXTENDPKGV}) python-m2crypto python-pycrypto python-msgpack python-pyzmq (>= 13.1.0)"
124CONFFILES_${PN}-master="${sysconfdir}/init.d/${PN}-master ${sysconfdir}/${PN}/master"
125FILES_${PN}-master = "${bindir}/${PN} ${bindir}/${PN}-cp ${bindir}/${PN}-key ${bindir}/${PN}-master ${bindir}/${PN}-run ${bindir}/${PN}-unity ${CONFFILES_${PN}-master}"
126INITSCRIPT_NAME_${PN}-master = "${PN}-master"
127INITSCRIPT_PARAMS_${PN}-master = "defaults"
128
129SUMMARY_${PN}-syndic = "master-of-masters for salt, the distributed remote execution system"
130DESCRIPTION_${PN}-syndic = "${DESCRIPTION_COMMON} This particular package provides the master of masters for \
131salt; it enables the management of multiple masters at a time."
132RDEPENDS_${PN}-syndic = "python ${PN}-master (= ${EXTENDPKGV})"
133CONFFILES_${PN}-syndic="${sysconfdir}/init.d/${PN}-syndic"
134FILES_${PN}-syndic = "${bindir}/${PN}-syndic ${CONFFILES_${PN}-syndic}"
135INITSCRIPT_NAME_${PN}-syndic = "${PN}-syndic"
136INITSCRIPT_PARAMS_${PN}-syndic = "defaults"
137
138SUMMARY_${PN}-cloud = "public cloud VM management system"
139DESCRIPTION_${PN}-cloud = "provision virtual machines on various public clouds via a cleanly controlled profile and mapping system."
140RDEPENDS_${PN}-cloud = "python ${PN}-common (= ${EXTENDPKGV}) python-msgpack"
141RSUGGESTS_${PN}-cloud = "python-netaddr python-botocore"
142CONFFILES_${PN}-cloud = "${sysconfdir}/${PN}/cloud"
143FILES_${PN}-cloud = "${bindir}/${PN}-cloud ${sysconfdir}/${PN}/cloud.conf.d/ ${sysconfdir}/${PN}/cloud.profiles.d/ ${sysconfdir}/${PN}/cloud.providers.d/ ${CONFFILES_${PN}-cloud}"
144
145FILES_${PN}-bash-completion = "${sysconfdir}/bash_completion.d/${PN}-common"