summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-support
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2014-04-10 11:40:40 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-04-15 19:43:32 -0400
commit3af9bf1831b89887da53e7804930010784338b4b (patch)
tree406371c176b102bbe7f925400b639b699d3ef715 /meta-openstack/recipes-support
parent388b3c78448bcb77bdb80af3749743a0a0a1ce5c (diff)
downloadmeta-cloud-services-3af9bf1831b89887da53e7804930010784338b4b.tar.gz
tgt: Fix the path of header files check
Current Makefile will check headers on host instead of Yocto sysroot, following error appears. Change the path of header check. | bs_aio.c:34:20: fatal error: libaio.h: No such file or directory | #include <libaio.h> | ^ | compilation terminated. Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-support')
-rw-r--r--meta-openstack/recipes-support/tgt/files/0001-Correct-the-path-of-header-files-check-in-Yocto-buil.patch48
-rw-r--r--meta-openstack/recipes-support/tgt/tgt_git.bb6
2 files changed, 52 insertions, 2 deletions
diff --git a/meta-openstack/recipes-support/tgt/files/0001-Correct-the-path-of-header-files-check-in-Yocto-buil.patch b/meta-openstack/recipes-support/tgt/files/0001-Correct-the-path-of-header-files-check-in-Yocto-buil.patch
new file mode 100644
index 0000000..6106b90
--- /dev/null
+++ b/meta-openstack/recipes-support/tgt/files/0001-Correct-the-path-of-header-files-check-in-Yocto-buil.patch
@@ -0,0 +1,48 @@
1From 5f6a261e44fec387e66d8b89d69f9602de5d5c53 Mon Sep 17 00:00:00 2001
2From: Zhenhua Luo <zhenhua.luo@freescale.com>
3Date: Thu, 10 Apr 2014 11:26:39 +0800
4Subject: [PATCH] Correct the path of header files check in Yocto build env
5
6Upstream-Status: Inappropriate [the fix is specific to Yocto build env]
7
8Current Makefile will check headers on host instead of Yocto sysroot, following
9error appears. Change the path of header check.
10| bs_aio.c:34:20: fatal error: libaio.h: No such file or directory
11| #include <libaio.h>
12| ^
13| compilation terminated.
14
15Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
16---
17 usr/Makefile | 6 +++---
18 1 file changed, 3 insertions(+), 3 deletions(-)
19
20diff --git a/usr/Makefile b/usr/Makefile
21index 453eb1a..191503d 100644
22--- a/usr/Makefile
23+++ b/usr/Makefile
24@@ -1,10 +1,10 @@
25 sbindir ?= $(PREFIX)/sbin
26
27-ifneq ($(shell test -e /usr/include/linux/signalfd.h && echo 1),)
28+ifneq ($(shell test -e $(SYSROOT)/usr/include/linux/signalfd.h && echo 1),)
29 CFLAGS += -DUSE_SIGNALFD
30 endif
31
32-ifneq ($(shell test -e /usr/include/sys/timerfd.h && echo 1),)
33+ifneq ($(shell test -e $(SYSROOT)/usr/include/sys/timerfd.h && echo 1),)
34 CFLAGS += -DUSE_TIMERFD
35 endif
36
37@@ -18,7 +18,7 @@ TGTD_OBJS += bs_rbd.o
38 LIBS += -lrados -lrbd
39 endif
40
41-ifneq ($(shell test -e /usr/include/sys/eventfd.h && test -e /usr/include/libaio.h && echo 1),)
42+ifneq ($(shell test -e $(SYSROOT)/usr/include/sys/eventfd.h && test -e $(SYSROOT)/usr/include/libaio.h && echo 1),)
43 CFLAGS += -DUSE_EVENTFD
44 TGTD_OBJS += bs_aio.o
45 LIBS += -laio
46--
471.9.1
48
diff --git a/meta-openstack/recipes-support/tgt/tgt_git.bb b/meta-openstack/recipes-support/tgt/tgt_git.bb
index db4f56b..8be9fe4 100644
--- a/meta-openstack/recipes-support/tgt/tgt_git.bb
+++ b/meta-openstack/recipes-support/tgt/tgt_git.bb
@@ -8,7 +8,9 @@ SRCREV = "0ee382bab57a8ecd9ece18d511bd098298478409"
8PV = "1.0.36+git${SRCPV}" 8PV = "1.0.36+git${SRCPV}"
9PR = "r0" 9PR = "r0"
10 10
11SRC_URI = "git://github.com/fujita/tgt.git" 11SRC_URI = "git://github.com/fujita/tgt.git \
12 file://0001-Correct-the-path-of-header-files-check-in-Yocto-buil.patch \
13"
12SRC_URI += "file://tgtd.init" 14SRC_URI += "file://tgtd.init"
13 15
14S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
@@ -16,7 +18,7 @@ S = "${WORKDIR}/git"
16inherit update-rc.d 18inherit update-rc.d
17 19
18do_compile() { 20do_compile() {
19 oe_runmake -e programs conf scripts 21 oe_runmake SYSROOT="${STAGING_DIR_TARGET}" -e programs conf scripts
20} 22}
21 23
22do_install() { 24do_install() {