summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-support/postgresql
diff options
context:
space:
mode:
authorJason Wessel <jason.wessel@windriver.com>2013-10-04 14:04:25 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-10-04 15:09:40 -0400
commit5f7811e53c82a0f248b0a757335bcb0ac4d0f802 (patch)
treef4b69c5058ba0296d300c5a93fe8c01a55a0c6dd /meta-openstack/recipes-support/postgresql
parent2d94422db8c142993f59a277ea945b048bfd1979 (diff)
downloadmeta-cloud-services-5f7811e53c82a0f248b0a757335bcb0ac4d0f802.tar.gz
postgresql: Fix runtime depends
When using the target installer with postgresql can end up installing in the wrong order due to bad dependencies and cause the install transaction to fail as follows: ==== initdb: invalid locale name "" initdb: invalid locale name "" initdb: invalid locale name "" initdb: invalid locale name "" initdb: invalid locale name "" could not open directory "/usr/share/postgresql/timezone": No such file or directory sh: locale: command not found WARNING: enabling "trust" authentication for local connections You can change this by editing pg_hba.conf or using the option -A, or --auth-local and --auth-host, the next time you run initdb. /etc/init.d/postgresql: line 25: start-stop-daemon: command not found ==== Signed-off-by: Jason Wessel <jason.wessel@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-support/postgresql')
-rw-r--r--meta-openstack/recipes-support/postgresql/postgresql_9.2.4.bbappend1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-openstack/recipes-support/postgresql/postgresql_9.2.4.bbappend b/meta-openstack/recipes-support/postgresql/postgresql_9.2.4.bbappend
index 3174e94..ecaaef0 100644
--- a/meta-openstack/recipes-support/postgresql/postgresql_9.2.4.bbappend
+++ b/meta-openstack/recipes-support/postgresql/postgresql_9.2.4.bbappend
@@ -26,6 +26,7 @@ do_install_append() {
26 26
27} 27}
28 28
29RDEPENDS_${PN} += "postgresql-timezone eglibc-utils update-rc.d"
29USERADD_PACKAGES = "${PN}" 30USERADD_PACKAGES = "${PN}"
30GROUPADD_PARAM_${PN} = "--system postgres" 31GROUPADD_PARAM_${PN} = "--system postgres"
31USERADD_PARAM_${PN} = "--system --home /var/lib/postgres -g postgres \ 32USERADD_PARAM_${PN} = "--system --home /var/lib/postgres -g postgres \