diff options
author | Mark Asselstine <mark.asselstine@windriver.com> | 2015-08-05 16:29:46 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2015-08-06 09:35:50 -0400 |
commit | 4c5711daa52b584d73c69d4c7a3818c9982b1480 (patch) | |
tree | ddafd0a6bf65ff8205266cf26e582e6d0e4c9487 /meta-openstack/recipes-support/postgresql/postgresql_9.2.4.bbappend | |
parent | 0de609c86dc5fd37c4333eaf03ad05421013b6e1 (diff) | |
download | meta-cloud-services-4c5711daa52b584d73c69d4c7a3818c9982b1480.tar.gz |
meta-openstack: fix dangling bbappends by adding wildcard
Several bbappends were raising 'dangling' warnings since the base
recipe version has changed without a similar change being made in this
repo. The following are renames that include a wildcard to broaden the
versions to which these bbappends will be applied to. This will
address the 'dangling' warnings while ensuring the changes made in
this repo are properly applied to the associated recipes.
For the most part the files remain unchanged, in the case of
postgresql the 'brokensep' has been removed as there exists no more S
!= B issues in the base recipe.
Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-support/postgresql/postgresql_9.2.4.bbappend')
-rw-r--r-- | meta-openstack/recipes-support/postgresql/postgresql_9.2.4.bbappend | 65 |
1 files changed, 0 insertions, 65 deletions
diff --git a/meta-openstack/recipes-support/postgresql/postgresql_9.2.4.bbappend b/meta-openstack/recipes-support/postgresql/postgresql_9.2.4.bbappend deleted file mode 100644 index db247e5..0000000 --- a/meta-openstack/recipes-support/postgresql/postgresql_9.2.4.bbappend +++ /dev/null | |||
@@ -1,65 +0,0 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
2 | |||
3 | SRC_URI += "file://postgresql \ | ||
4 | file://postgresql-init" | ||
5 | |||
6 | inherit useradd update-rc.d identity hosts autotools-brokensep openstackchef | ||
7 | |||
8 | PACKAGECONFIG[libxml] = "--with-libxml CFLAGS=-I${STAGING_INCDIR}/libxml2,--without-libxml,libxml2,libxml2" | ||
9 | |||
10 | # default | ||
11 | DB_DATADIR ?= "/var/lib/postgres/data" | ||
12 | |||
13 | do_install_append() { | ||
14 | INIT_D_DEST_DIR=${D}${sysconfdir}/init.d | ||
15 | |||
16 | install -d ${D}${sysconfdir}/init.d/ | ||
17 | install -m 0755 ${WORKDIR}/postgresql ${INIT_D_DEST_DIR}/postgresql | ||
18 | install -m 0755 ${WORKDIR}/postgresql-init ${INIT_D_DEST_DIR}/postgresql-init | ||
19 | if [ -z "${OPENSTACKCHEF_ENABLED}" ]; then | ||
20 | sed -e "s:%DB_DATADIR%:${DB_DATADIR}:g" -i ${INIT_D_DEST_DIR}/postgresql | ||
21 | sed -e "s:%DB_DATADIR%:${DB_DATADIR}:g" -i ${INIT_D_DEST_DIR}/postgresql-init | ||
22 | |||
23 | sed -e "s:%DB_USER%:${DB_USER}:g" -i ${INIT_D_DEST_DIR}/postgresql-init | ||
24 | sed -e "s:%DB_PASSWORD%:${DB_PASSWORD}:g" -i ${INIT_D_DEST_DIR}/postgresql-init | ||
25 | |||
26 | sed -e "s:%CONTROLLER_IP%:${CONTROLLER_IP}:g" -i ${INIT_D_DEST_DIR}/postgresql-init | ||
27 | sed -e "s:%CONTROLLER_HOST%:${CONTROLLER_HOST}:g" -i ${INIT_D_DEST_DIR}/postgresql-init | ||
28 | |||
29 | sed -e "s:%COMPUTE_IP%:${COMPUTE_IP}:g" -i ${INIT_D_DEST_DIR}/postgresql-init | ||
30 | sed -e "s:%COMPUTE_HOST%:${COMPUTE_HOST}:g" -i ${INIT_D_DEST_DIR}/postgresql-init | ||
31 | fi | ||
32 | } | ||
33 | |||
34 | CHEF_SERVICES_CONF_FILES := "\ | ||
35 | ${sysconfdir}/init.d/postgresql \ | ||
36 | ${sysconfdir}/init.d/postgresql-init \ | ||
37 | " | ||
38 | |||
39 | RDEPENDS_${PN} += "postgresql-timezone eglibc-utils update-rc.d" | ||
40 | USERADD_PACKAGES = "${PN}" | ||
41 | GROUPADD_PARAM_${PN} = "--system postgres" | ||
42 | USERADD_PARAM_${PN} = "--system --home /var/lib/postgres -g postgres \ | ||
43 | --no-create-home --shell /bin/false postgres" | ||
44 | |||
45 | PACKAGES += " ${PN}-setup" | ||
46 | ALLOW_EMPTY_${PN}-setup = "1" | ||
47 | |||
48 | pkg_postinst_${PN}-setup () { | ||
49 | # postgres 9.2.4 postinst | ||
50 | if [ "x$D" != "x" ]; then | ||
51 | exit 1 | ||
52 | fi | ||
53 | |||
54 | /etc/init.d/postgresql-init | ||
55 | if [ $? -ne 0 ]; then | ||
56 | echo "[ERROR] postgres: unable to create admin account" | ||
57 | exit 1 | ||
58 | fi | ||
59 | } | ||
60 | |||
61 | FILES_${PN} += "${localstatedir}/run/${PN}" | ||
62 | |||
63 | INITSCRIPT_PACKAGES = "${PN}" | ||
64 | INITSCRIPT_NAME = "${PN}" | ||
65 | INITSCRIPT_PARAMS = "defaults" | ||