diff options
author | Mark Asselstine <mark.asselstine@windriver.com> | 2017-01-09 10:04:50 -0500 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2017-01-09 12:23:58 -0500 |
commit | 8e747fd2ab71d93a7d9b5bfa0bbe54705f56e2ce (patch) | |
tree | 7aec036fb590b27bae7d593bf7ab9b8ad22713b1 /meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb | |
parent | eeabc7a45f9463c7862de8392b6c5f121b4c93a6 (diff) | |
download | meta-cloud-services-8e747fd2ab71d93a7d9b5bfa0bbe54705f56e2ce.tar.gz |
mod-wsgi: uprev to use git and latest release
Apache2 was just uprev'd to the latest release in meta-oe so we should
really matching this. Additionally the version we are replacing had
build issue with the latest gcc, so the uprev solves these as well.
Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb')
-rw-r--r-- | meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb | 57 |
1 files changed, 57 insertions, 0 deletions
diff --git a/meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb b/meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb new file mode 100644 index 0000000..eab28b0 --- /dev/null +++ b/meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb | |||
@@ -0,0 +1,57 @@ | |||
1 | SUMMARY = "Supports the Python WSGI interface" | ||
2 | DESCRIPTION = "\ | ||
3 | The aim of mod_wsgi is to implement a simple to use Apache module which can host \ | ||
4 | any Python application which supports the Python WSGI interface. The module would \ | ||
5 | be suitable for use in hosting high performance production web sites, as well as \ | ||
6 | your average self managed personal sites running on web hosting services." | ||
7 | |||
8 | HOMEPAGE = "http://code.google.com/p/modwsgi/" | ||
9 | LICENSE = "Apache-2.0" | ||
10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | ||
11 | |||
12 | SRCREV = "f22376f5141e8505f183b1b48f276c31168e2b6a" | ||
13 | PV = "4.5.13+git${SRCPV}" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | SRCNAME = "mod_wsgi" | ||
18 | SRC_URI = "\ | ||
19 | git://github.com/GrahamDumpleton/mod_wsgi.git \ | ||
20 | file://configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch \ | ||
21 | " | ||
22 | |||
23 | inherit autotools-brokensep distutils-base | ||
24 | |||
25 | DEPENDS += "apache2-native apache2 python" | ||
26 | RDEPENDS_${PN} = "python" | ||
27 | |||
28 | EXTRA_OECONF = "\ | ||
29 | --with-apxs=${STAGING_BINDIR_CROSS}/apxs \ | ||
30 | --disable-framework \ | ||
31 | PYTHON_VERSION=${PYTHON_BASEVERSION} \ | ||
32 | PYTHON_INCLUDEPY=-I${STAGING_INCDIR}/python${PYTHON_BASEVERSION} \ | ||
33 | PYTHON_CFLAGS='-DNDEBUG' \ | ||
34 | PYTHON_LIBDIR=${STAGING_LIBDIR} \ | ||
35 | PYTHON_CFGDIR=${STAGING_LIBDIR}/python${PYTHON_BASEVERSION}/config \ | ||
36 | PYTHON_FRAMEWORKDIR='no-framework' \ | ||
37 | PYTHON_FRAMEWORKPREFIX=' ' \ | ||
38 | PYTHON_FRAMEWORK=' ' \ | ||
39 | PYTHON_LIBS='-lpthread -ldl -lpthread -lutil' \ | ||
40 | PYTHON_SYSLIBS='-lm' \ | ||
41 | " | ||
42 | |||
43 | CFLAGS += " -I${STAGING_INCDIR}/apache2" | ||
44 | |||
45 | FILES_${PN} += "/etc/apache2/" | ||
46 | FILES_${PN}-dbg += "${libdir}/apache2/modules/.debug" | ||
47 | |||
48 | do_install_append() { | ||
49 | mkdir -p ${D}/etc/apache2/modules.d/ | ||
50 | echo "LoadModule wsgi_module ${libdir}/apache2/modules/mod_wsgi.so" > \ | ||
51 | ${D}/etc/apache2/modules.d/wsgi.load | ||
52 | } | ||
53 | |||
54 | # to load: | ||
55 | # LoadModule wsgi_module modules/mod_wsgi.so | ||
56 | |||
57 | # Apache/2.2.2 (Unix) mod_wsgi/1.0 Python/2.3 configured | ||