summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-kernel
diff options
context:
space:
mode:
authorMihai Prica <prica.mihai@gmail.com>2013-05-17 17:46:39 +0300
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-08-28 18:41:55 -0400
commitffff52b647e3941c6fd4852774d8d021c39c0803 (patch)
tree4efca6cdb6ac16f96f96bfffc064683e75ec440b /meta-openstack/recipes-kernel
parenteaed2eaebabe8f5abce177d6ca43766c83f78c70 (diff)
downloadmeta-cloud-services-ffff52b647e3941c6fd4852774d8d021c39c0803.tar.gz
linux-yocto: added kernel configurations for iptables nat table
Signed-off-by: Mihai Prica <prica.mihai@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-kernel')
-rw-r--r--meta-openstack/recipes-kernel/linux/linux-yocto/iptables-nat.cfg21
-rw-r--r--meta-openstack/recipes-kernel/linux/linux-yocto/iptables-nat.scc4
-rw-r--r--meta-openstack/recipes-kernel/linux/linux-yocto_3.4.bbappend5
-rw-r--r--meta-openstack/recipes-kernel/linux/linux-yocto_3.8.bbappend5
4 files changed, 35 insertions, 0 deletions
diff --git a/meta-openstack/recipes-kernel/linux/linux-yocto/iptables-nat.cfg b/meta-openstack/recipes-kernel/linux/linux-yocto/iptables-nat.cfg
new file mode 100644
index 0000000..6e1cff7
--- /dev/null
+++ b/meta-openstack/recipes-kernel/linux/linux-yocto/iptables-nat.cfg
@@ -0,0 +1,21 @@
1CONFIG_NF_NAT=m
2CONFIG_NF_NAT_NEEDED=y
3CONFIG_NF_NAT_PROTO_UDPLITE=m
4CONFIG_NF_NAT_PROTO_SCTP=m
5CONFIG_NF_NAT_AMANDA=m
6CONFIG_NF_NAT_FTP=m
7CONFIG_NF_NAT_IRC=m
8CONFIG_NF_NAT_SIP=m
9CONFIG_NF_NAT_TFTP=m
10
11CONFIG_NETFILTER_XT_TARGET_NETMAP=m
12
13CONFIG_NETFILTER_XT_TARGET_REDIRECT=m
14
15CONFIG_NF_NAT_IPV4=m
16CONFIG_IP_NF_TARGET_MASQUERADE=m
17CONFIG_IP_NF_TARGET_NETMAP=m
18CONFIG_IP_NF_TARGET_REDIRECT=m
19CONFIG_NF_NAT_PROTO_GRE=m
20CONFIG_NF_NAT_PPTP=m
21CONFIG_NF_NAT_H323=m
diff --git a/meta-openstack/recipes-kernel/linux/linux-yocto/iptables-nat.scc b/meta-openstack/recipes-kernel/linux/linux-yocto/iptables-nat.scc
new file mode 100644
index 0000000..9faf22e
--- /dev/null
+++ b/meta-openstack/recipes-kernel/linux/linux-yocto/iptables-nat.scc
@@ -0,0 +1,4 @@
1define KFEATURE_DESCRIPTION "Enable iptables nat"
2define KFEATURE_COMPATIBILITY board
3
4kconf non-hardware iptables-nat.cfg
diff --git a/meta-openstack/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-openstack/recipes-kernel/linux/linux-yocto_3.4.bbappend
new file mode 100644
index 0000000..02bf487
--- /dev/null
+++ b/meta-openstack/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -0,0 +1,5 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2PRINC := "${@int(PRINC) + 1}"
3
4SRC_URI += "file://iptables-nat.scc"
5
diff --git a/meta-openstack/recipes-kernel/linux/linux-yocto_3.8.bbappend b/meta-openstack/recipes-kernel/linux/linux-yocto_3.8.bbappend
new file mode 100644
index 0000000..02bf487
--- /dev/null
+++ b/meta-openstack/recipes-kernel/linux/linux-yocto_3.8.bbappend
@@ -0,0 +1,5 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2PRINC := "${@int(PRINC) + 1}"
3
4SRC_URI += "file://iptables-nat.scc"
5