summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-07-29 09:41:18 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-07-29 12:41:27 -0400
commit2bd873f566e7279c87a81119c888b7b4813a3c82 (patch)
tree731c15866c04e9419095dec5034c1ffb22bc93cd /meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb
parent1491d54da84195dda8c7d5ce1fac21437f2bc519 (diff)
downloadmeta-cloud-services-2bd873f566e7279c87a81119c888b7b4813a3c82.tar.gz
uwsgi: remove floating yajl dependency
uwsgi is using pkg-config to detect whether or not yajl is present in the build. We do want to use yajl, so we add an explicit dependency and pkgconfig inherit. Without this, build errors may occur, since the build paths that don't use yajl are not supported. And finally, to prevent the searching of host include paths, we set UWSGI_REMOVE_INCLUDES and purge local directories. This ensures that only the sysroot and package config settings are used. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb')
-rw-r--r--meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb b/meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb
index e8c0fb4..7de85e8 100644
--- a/meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb
+++ b/meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb
@@ -14,12 +14,16 @@ SRCREV="7604c6701809602804e3961f7fdb201049b8c993"
14PV="2.0.4+git${SRCPV}" 14PV="2.0.4+git${SRCPV}"
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
17inherit setuptools 17inherit setuptools pkgconfig
18
19# prevent host contamination and remove local search paths
20export UWSGI_REMOVE_INCLUDES = "/usr/include,/usr/local/include"
18 21
19DEPENDS += " \ 22DEPENDS += " \
20 e2fsprogs \ 23 e2fsprogs \
21 python-pip \ 24 python-pip \
22 python-six \ 25 python-six \
26 yajl \
23 " 27 "
24 28
25# RDEPENDS_default: 29# RDEPENDS_default: