summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2016-12-21 10:22:41 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-12-21 11:47:05 -0500
commitbd2525ceb47699747f9370773fa629bf28c999d6 (patch)
tree1748ce0f1e237277440967a405e7145ca42876c3 /meta-openstack/recipes-devtools
parentd2a69f5e890b040cbc774f64275c27c8a1ea67a9 (diff)
downloadmeta-cloud-services-bd2525ceb47699747f9370773fa629bf28c999d6.tar.gz
housekeeping: replace deprecated base_contains
Fixes: base_contains is deprecated, please use bb.utils.contains instead. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools')
-rw-r--r--meta-openstack/recipes-devtools/python/python-barbican_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-ceilometer_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-cinder_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-glance_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-heat_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-horizon_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_git.bb8
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron_git.bb8
-rw-r--r--meta-openstack/recipes-devtools/python/python-nova_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-rally_git.bb2
-rwxr-xr-xmeta-openstack/recipes-devtools/python/python-trove_git.bb2
11 files changed, 17 insertions, 17 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-barbican_git.bb b/meta-openstack/recipes-devtools/python/python-barbican_git.bb
index 15459f1..aa896ac 100644
--- a/meta-openstack/recipes-devtools/python/python-barbican_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-barbican_git.bb
@@ -52,7 +52,7 @@ do_install_append() {
52 sed -e "s:%BARBICAN_MAX_PACKET_SIZE%:${BARBICAN_MAX_PACKET_SIZE}:g" -i ${BARBICAN_CONF_DIR}/vassals/barbican-api.ini 52 sed -e "s:%BARBICAN_MAX_PACKET_SIZE%:${BARBICAN_MAX_PACKET_SIZE}:g" -i ${BARBICAN_CONF_DIR}/vassals/barbican-api.ini
53 sed -e "s:%BARBICAN_MAX_PACKET_SIZE%:${BARBICAN_MAX_PACKET_SIZE}:g" -i ${BARBICAN_CONF_DIR}/vassals/barbican-admin.ini 53 sed -e "s:%BARBICAN_MAX_PACKET_SIZE%:${BARBICAN_MAX_PACKET_SIZE}:g" -i ${BARBICAN_CONF_DIR}/vassals/barbican-admin.ini
54 fi 54 fi
55 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then 55 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
56 install -d ${D}${sysconfdir}/init.d 56 install -d ${D}${sysconfdir}/init.d
57 57
58 for binary in api; do 58 for binary in api; do
diff --git a/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb b/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
index 2825e60..0d6e2d3 100644
--- a/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
@@ -78,7 +78,7 @@ do_install_append() {
78 sed -e "s:%ADMIN_PASSWORD%:${ADMIN_PASSWORD}:g" -i ${CEILOMETER_CONF_DIR}/ceilometer.conf 78 sed -e "s:%ADMIN_PASSWORD%:${ADMIN_PASSWORD}:g" -i ${CEILOMETER_CONF_DIR}/ceilometer.conf
79 sed -e "s:%SERVICE_TENANT_NAME%:${SERVICE_TENANT_NAME}:g" -i ${CEILOMETER_CONF_DIR}/ceilometer.conf 79 sed -e "s:%SERVICE_TENANT_NAME%:${SERVICE_TENANT_NAME}:g" -i ${CEILOMETER_CONF_DIR}/ceilometer.conf
80 fi 80 fi
81 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then 81 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
82 install -d ${D}${sysconfdir}/init.d 82 install -d ${D}${sysconfdir}/init.d
83 83
84 sed 's:@suffix@:api:' < ${WORKDIR}/ceilometer.init >${WORKDIR}/ceilometer-api.init.sh 84 sed 's:@suffix@:api:' < ${WORKDIR}/ceilometer.init >${WORKDIR}/ceilometer-api.init.sh
diff --git a/meta-openstack/recipes-devtools/python/python-cinder_git.bb b/meta-openstack/recipes-devtools/python/python-cinder_git.bb
index 3203c43..91098c4 100644
--- a/meta-openstack/recipes-devtools/python/python-cinder_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-cinder_git.bb
@@ -92,7 +92,7 @@ do_install_append() {
92 done 92 done
93 fi 93 fi
94 94
95 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then 95 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
96 install -d ${D}${sysconfdir}/init.d 96 install -d ${D}${sysconfdir}/init.d
97 sed 's:@suffix@:api:' < ${WORKDIR}/cinder.init >${WORKDIR}/cinder-api.init.sh 97 sed 's:@suffix@:api:' < ${WORKDIR}/cinder.init >${WORKDIR}/cinder-api.init.sh
98 install -m 0755 ${WORKDIR}/cinder-api.init.sh ${D}${sysconfdir}/init.d/cinder-api 98 install -m 0755 ${WORKDIR}/cinder-api.init.sh ${D}${sysconfdir}/init.d/cinder-api
diff --git a/meta-openstack/recipes-devtools/python/python-glance_git.bb b/meta-openstack/recipes-devtools/python/python-glance_git.bb
index e6f5f5f..bce373d 100644
--- a/meta-openstack/recipes-devtools/python/python-glance_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-glance_git.bb
@@ -112,7 +112,7 @@ do_install_append() {
112 done 112 done
113 fi 113 fi
114 114
115 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then 115 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
116 install -d ${D}${sysconfdir}/init.d 116 install -d ${D}${sysconfdir}/init.d
117 sed 's:@suffix@:api:' < ${WORKDIR}/glance.init >${WORKDIR}/glance-api.init.sh 117 sed 's:@suffix@:api:' < ${WORKDIR}/glance.init >${WORKDIR}/glance-api.init.sh
118 install -m 0755 ${WORKDIR}/glance-api.init.sh ${D}${sysconfdir}/init.d/glance-api 118 install -m 0755 ${WORKDIR}/glance-api.init.sh ${D}${sysconfdir}/init.d/glance-api
diff --git a/meta-openstack/recipes-devtools/python/python-heat_git.bb b/meta-openstack/recipes-devtools/python/python-heat_git.bb
index c2b2da7..75d5ba6 100644
--- a/meta-openstack/recipes-devtools/python/python-heat_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-heat_git.bb
@@ -89,7 +89,7 @@ do_install_append() {
89 sed -e "s:%ADMIN_PASSWORD%:${ADMIN_PASSWORD}:g" -i ${HEAT_CONF_DIR}/heat.conf 89 sed -e "s:%ADMIN_PASSWORD%:${ADMIN_PASSWORD}:g" -i ${HEAT_CONF_DIR}/heat.conf
90 sed -e "s:%SERVICE_TENANT_NAME%:${SERVICE_TENANT_NAME}:g" -i ${HEAT_CONF_DIR}/heat.conf 90 sed -e "s:%SERVICE_TENANT_NAME%:${SERVICE_TENANT_NAME}:g" -i ${HEAT_CONF_DIR}/heat.conf
91 fi 91 fi
92 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then 92 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
93 install -d ${D}${sysconfdir}/init.d 93 install -d ${D}${sysconfdir}/init.d
94 94
95 sed 's:@suffix@:api:' < ${WORKDIR}/heat.init >${WORKDIR}/heat-api.init.sh 95 sed 's:@suffix@:api:' < ${WORKDIR}/heat.init >${WORKDIR}/heat-api.init.sh
diff --git a/meta-openstack/recipes-devtools/python/python-horizon_git.bb b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
index 2a96190..01ce598 100644
--- a/meta-openstack/recipes-devtools/python/python-horizon_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
@@ -107,7 +107,7 @@ do_install_append() {
107 -i ${DASHBOARD_DIR}/local/local_settings.py 107 -i ${DASHBOARD_DIR}/local/local_settings.py
108 install -m 644 ${S}/manage.py ${DASHBOARD_DIR}/manage.py 108 install -m 644 ${S}/manage.py ${DASHBOARD_DIR}/manage.py
109 109
110 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; 110 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)};
111 then 111 then
112 install -d ${D}${sysconfdir}/init.d 112 install -d ${D}${sysconfdir}/init.d
113 sed 's:@PYTHON_SITEPACKAGES@:${PYTHON_SITEPACKAGES_DIR}:' \ 113 sed 's:@PYTHON_SITEPACKAGES@:${PYTHON_SITEPACKAGES_DIR}:' \
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_git.bb b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
index 4bd739a..e79a6a4 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
@@ -100,7 +100,7 @@ do_install_append() {
100 100
101 cp -r ${S}/examples ${KEYSTONE_PACKAGE_DIR} 101 cp -r ${S}/examples ${KEYSTONE_PACKAGE_DIR}
102 102
103 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; 103 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)};
104 then 104 then
105 install -d ${D}${sysconfdir}/init.d 105 install -d ${D}${sysconfdir}/init.d
106 install -m 0755 ${WORKDIR}/keystone ${D}${sysconfdir}/init.d/keystone 106 install -m 0755 ${WORKDIR}/keystone ${D}${sysconfdir}/init.d/keystone
@@ -144,7 +144,7 @@ do_install_append() {
144 -i ${KEYSTONE_PACKAGE_DIR}/tests/test_overrides.conf 144 -i ${KEYSTONE_PACKAGE_DIR}/tests/test_overrides.conf
145 fi 145 fi
146 146
147 if ${@base_contains('DISTRO_FEATURES', 'OpenLDAP', 'true', 'false', d)}; 147 if ${@bb.utils.contains('DISTRO_FEATURES', 'OpenLDAP', 'true', 'false', d)};
148 then 148 then
149 sed -i -e '/^\[identity\]/a \ 149 sed -i -e '/^\[identity\]/a \
150driver = keystone.identity.backends.hybrid_identity.Identity \ 150driver = keystone.identity.backends.hybrid_identity.Identity \
@@ -215,7 +215,7 @@ pkg_postinst_${SRCNAME}-setup () {
215 keystone-manage db_sync 215 keystone-manage db_sync
216 keystone-manage pki_setup --keystone-user=root --keystone-group=daemon 216 keystone-manage pki_setup --keystone-user=root --keystone-group=daemon
217 217
218 if ${@base_contains('DISTRO_FEATURES', 'OpenLDAP', 'true', 'false', d)}; then 218 if ${@bb.utils.contains('DISTRO_FEATURES', 'OpenLDAP', 'true', 'false', d)}; then
219 /etc/init.d/openldap start 219 /etc/init.d/openldap start
220 fi 220 fi
221 /etc/init.d/keystone start 221 /etc/init.d/keystone start
@@ -292,7 +292,7 @@ RDEPENDS_${PN} += " \
292 292
293RDEPENDS_${SRCNAME}-tests += " bash" 293RDEPENDS_${SRCNAME}-tests += " bash"
294 294
295PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'OpenLDAP', 'OpenLDAP', '', d)}" 295PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'OpenLDAP', 'OpenLDAP', '', d)}"
296PACKAGECONFIG[OpenLDAP] = ",,,python-ldap python-keystone-hybrid-backend" 296PACKAGECONFIG[OpenLDAP] = ",,,python-ldap python-keystone-hybrid-backend"
297 297
298# TODO: 298# TODO:
diff --git a/meta-openstack/recipes-devtools/python/python-neutron_git.bb b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
index cadc80f..f651a8f 100644
--- a/meta-openstack/recipes-devtools/python/python-neutron_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
@@ -82,7 +82,7 @@ do_install_append() {
82 82
83 PLUGIN=openvswitch 83 PLUGIN=openvswitch
84 ARGS="--config-file=${sysconfdir}/${SRCNAME}/neutron.conf --config-file=${sysconfdir}/${SRCNAME}/plugins/ml2/ml2_conf.ini" 84 ARGS="--config-file=${sysconfdir}/${SRCNAME}/neutron.conf --config-file=${sysconfdir}/${SRCNAME}/plugins/ml2/ml2_conf.ini"
85 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then 85 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
86 install -d ${D}${sysconfdir}/init.d 86 install -d ${D}${sysconfdir}/init.d
87 sed "s:@plugin@:/etc/neutron/plugins/ml2/ml2_conf.ini:" \ 87 sed "s:@plugin@:/etc/neutron/plugins/ml2/ml2_conf.ini:" \
88 < ${WORKDIR}/neutron-server.init >${WORKDIR}/neutron-server.init.sh 88 < ${WORKDIR}/neutron-server.init >${WORKDIR}/neutron-server.init.sh
@@ -93,7 +93,7 @@ do_install_append() {
93 93
94 AGENT=dhcp 94 AGENT=dhcp
95 ARGS="--config-file=${sysconfdir}/${SRCNAME}/neutron.conf --config-file=${sysconfdir}/${SRCNAME}/dhcp_agent.ini" 95 ARGS="--config-file=${sysconfdir}/${SRCNAME}/neutron.conf --config-file=${sysconfdir}/${SRCNAME}/dhcp_agent.ini"
96 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then 96 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
97 sed "s:@suffix@:$AGENT:;s:@args@:$ARGS:" < ${WORKDIR}/neutron-agent.init >${WORKDIR}/neutron-$AGENT.init.sh 97 sed "s:@suffix@:$AGENT:;s:@args@:$ARGS:" < ${WORKDIR}/neutron-agent.init >${WORKDIR}/neutron-$AGENT.init.sh
98 install -m 0755 ${WORKDIR}/neutron-$AGENT.init.sh ${D}${sysconfdir}/init.d/neutron-$AGENT-agent 98 install -m 0755 ${WORKDIR}/neutron-$AGENT.init.sh ${D}${sysconfdir}/init.d/neutron-$AGENT-agent
99 install -m 600 ${WORKDIR}/${AGENT}_agent.ini ${NEUTRON_CONF_DIR}/ 99 install -m 600 ${WORKDIR}/${AGENT}_agent.ini ${NEUTRON_CONF_DIR}/
@@ -104,7 +104,7 @@ do_install_append() {
104 104
105 AGENT=l3 105 AGENT=l3
106 ARGS="--config-file=${sysconfdir}/${SRCNAME}/neutron.conf --config-file=${sysconfdir}/${SRCNAME}/l3_agent.ini" 106 ARGS="--config-file=${sysconfdir}/${SRCNAME}/neutron.conf --config-file=${sysconfdir}/${SRCNAME}/l3_agent.ini"
107 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then 107 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
108 sed "s:@suffix@:$AGENT:;s:@args@:$ARGS:" < ${WORKDIR}/neutron-agent.init >${WORKDIR}/neutron-$AGENT.init.sh 108 sed "s:@suffix@:$AGENT:;s:@args@:$ARGS:" < ${WORKDIR}/neutron-agent.init >${WORKDIR}/neutron-$AGENT.init.sh
109 install -m 0755 ${WORKDIR}/neutron-$AGENT.init.sh ${D}${sysconfdir}/init.d/neutron-$AGENT-agent 109 install -m 0755 ${WORKDIR}/neutron-$AGENT.init.sh ${D}${sysconfdir}/init.d/neutron-$AGENT-agent
110 install -m 600 ${WORKDIR}/${AGENT}_agent.ini ${NEUTRON_CONF_DIR}/ 110 install -m 600 ${WORKDIR}/${AGENT}_agent.ini ${NEUTRON_CONF_DIR}/
@@ -112,7 +112,7 @@ do_install_append() {
112 112
113 AGENT=metadata 113 AGENT=metadata
114 ARGS="--config-file=${sysconfdir}/${SRCNAME}/neutron.conf --config-file=${sysconfdir}/${SRCNAME}/metadata_agent.ini" 114 ARGS="--config-file=${sysconfdir}/${SRCNAME}/neutron.conf --config-file=${sysconfdir}/${SRCNAME}/metadata_agent.ini"
115 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then 115 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
116 sed "s:@suffix@:$AGENT:;s:@args@:$ARGS:" < ${WORKDIR}/neutron-agent.init >${WORKDIR}/neutron-$AGENT.init.sh 116 sed "s:@suffix@:$AGENT:;s:@args@:$ARGS:" < ${WORKDIR}/neutron-agent.init >${WORKDIR}/neutron-$AGENT.init.sh
117 install -m 0755 ${WORKDIR}/neutron-$AGENT.init.sh ${D}${sysconfdir}/init.d/neutron-$AGENT-agent 117 install -m 0755 ${WORKDIR}/neutron-$AGENT.init.sh ${D}${sysconfdir}/init.d/neutron-$AGENT-agent
118 install -m 600 ${WORKDIR}/${AGENT}_agent.ini ${NEUTRON_CONF_DIR}/ 118 install -m 600 ${WORKDIR}/${AGENT}_agent.ini ${NEUTRON_CONF_DIR}/
diff --git a/meta-openstack/recipes-devtools/python/python-nova_git.bb b/meta-openstack/recipes-devtools/python/python-nova_git.bb
index fd50173..7e0e861 100644
--- a/meta-openstack/recipes-devtools/python/python-nova_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-nova_git.bb
@@ -137,7 +137,7 @@ do_install_append() {
137 fi 137 fi
138 install -o nova -d ${NOVA_CONF_DIR}/instances 138 install -o nova -d ${NOVA_CONF_DIR}/instances
139 139
140 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then 140 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
141 install -d ${D}${sysconfdir}/init.d 141 install -d ${D}${sysconfdir}/init.d
142 142
143 # nova-all is installed (and packaged), but not used as an initscript by default 143 # nova-all is installed (and packaged), but not used as an initscript by default
diff --git a/meta-openstack/recipes-devtools/python/python-rally_git.bb b/meta-openstack/recipes-devtools/python/python-rally_git.bb
index 30e3283..d29e7cb 100644
--- a/meta-openstack/recipes-devtools/python/python-rally_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-rally_git.bb
@@ -35,7 +35,7 @@ do_install_append() {
35 sed -e "s:%DB_USER%:${DB_USER}:g" -i ${RALLY_CONF_DIR}/rally.conf 35 sed -e "s:%DB_USER%:${DB_USER}:g" -i ${RALLY_CONF_DIR}/rally.conf
36 sed -e "s:%DB_PASSWORD%:${DB_PASSWORD}:g" -i ${RALLY_CONF_DIR}/rally.conf 36 sed -e "s:%DB_PASSWORD%:${DB_PASSWORD}:g" -i ${RALLY_CONF_DIR}/rally.conf
37 37
38 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then 38 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
39 install -d ${D}${sysconfdir}/init.d 39 install -d ${D}${sysconfdir}/init.d
40 sed 's:@suffix@:api:' < ${WORKDIR}/rally.init > ${WORKDIR}/rally-api.init.sh 40 sed 's:@suffix@:api:' < ${WORKDIR}/rally.init > ${WORKDIR}/rally-api.init.sh
41 install -m 0755 ${WORKDIR}/rally-api.init.sh ${D}${sysconfdir}/init.d/rally-api 41 install -m 0755 ${WORKDIR}/rally-api.init.sh ${D}${sysconfdir}/init.d/rally-api
diff --git a/meta-openstack/recipes-devtools/python/python-trove_git.bb b/meta-openstack/recipes-devtools/python/python-trove_git.bb
index 1b8d9ac..830da92 100755
--- a/meta-openstack/recipes-devtools/python/python-trove_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-trove_git.bb
@@ -50,7 +50,7 @@ do_install_append() {
50 install -d ${TROVE_CONF_DIR} 50 install -d ${TROVE_CONF_DIR}
51 51
52 # init. 52 # init.
53 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; 53 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)};
54 then 54 then
55 install -d ${D}${sysconfdir}/init.d 55 install -d ${D}${sysconfdir}/init.d
56 for suffix in api taskmanager conductor; do 56 for suffix in api taskmanager conductor; do