summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools
diff options
context:
space:
mode:
authorMark Asselstine <asselsm@gmail.com>2016-02-03 20:41:04 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:17 -0500
commit529228a7d12d954ea4113879f8e9c200ebcc9ce8 (patch)
tree34c06040f792fc4044b0368f733b1f1b91c456c5 /meta-openstack/recipes-devtools
parent50fc17c94133022446643f1f577efc468ff72f41 (diff)
downloadmeta-cloud-services-529228a7d12d954ea4113879f8e9c200ebcc9ce8.tar.gz
python-oslo.versionedobjects: initial version
This package is required by nova, heat, and others. Signed-off-by: Mark Asselstine <asselsm@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools')
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.versionedobjects_git.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.versionedobjects_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.versionedobjects_git.bb
new file mode 100644
index 0000000..dea4454
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-oslo.versionedobjects_git.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "oslo.versionedobjects library"
2HOMEPAGE = "https://wiki.openstack.org/wiki/Oslo"
3SECTION = "devel/python"
4LICENSE = "Apache-2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7PV = "1.12.0+git${SRCPV}"
8SRCREV = "9261f3ae3678cca8411ba1700e2ae18f3e5dfb9c"
9
10SRCNAME = "oslo.versionedobjects"
11SRC_URI = "git://github.com/openstack/${SRCNAME}.git"
12
13S = "${WORKDIR}/git"
14
15inherit setuptools
16
17DEPENDS += " \
18 python-pip \
19 python-pbr \
20 "
21
22# RDEPENDS_default:
23RDEPENDS_${PN} += " \
24 python-six \
25 python-babel \
26 python-oslo.concurrency \
27 python-oslo.config \
28 python-oslo.context \
29 python-oslo.messaging \
30 python-oslo.serialization \
31 python-oslo.utils \
32 python-oslo.log \
33 python-oslo.i18n \
34 python-webob \
35 python-iso8601 \
36 "