summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools
diff options
context:
space:
mode:
authorMark Asselstine <asselsm@gmail.com>2016-02-03 20:41:08 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:17 -0500
commit832c3806b460b44cd38e0c5f09869e4f8cd81a6e (patch)
tree61ecb8a45b52f477e12f599289ab6d7390ca39a8 /meta-openstack/recipes-devtools
parent76598abddc2950c2cd13b7570c1b014bdaa2d08a (diff)
downloadmeta-cloud-services-832c3806b460b44cd38e0c5f09869e4f8cd81a6e.tar.gz
python-trollius: initial version
This package provides a port of the Tulip project (asyncio module, PEP 3156) on Python 2. This package is required by oslo.messaging. Signed-off-by: Mark Asselstine <asselsm@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools')
-rw-r--r--meta-openstack/recipes-devtools/python/python-trollius_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-trollius_git.bb b/meta-openstack/recipes-devtools/python/python-trollius_git.bb
new file mode 100644
index 0000000..0ae4fef
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-trollius_git.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "Port of the Tulip project (asyncio module, PEP 3156) on Python 2"
2HOMEPAGE = "https://github.com/haypo/trollius"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://COPYING;md5=8f7bb094c7232b058c7e9f2e431f389c"
6
7PV = "2.0+git${SRCPV}"
8SRCREV = "5e9854d7b7bed6eb6e182808379342355e2bfca4"
9
10SRCNAME = "trollius"
11SRC_URI = "git://github.com/haypo/${SRCNAME}.git;branch=trollius"
12
13S = "${WORKDIR}/git"
14
15inherit setuptools
16
17DEPENDS += " \
18 python-pip \
19 "
20
21RDEPENDS_${PN} += " \
22 "