summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2020-09-29 11:19:53 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-10-01 23:11:59 -0400
commit7f775376da134bf50690268664daa1bd77c2a3b4 (patch)
tree71b880ea63711d8808a43105a80dacd9621802ce /meta-openstack/recipes-devtools
parent340e3b92bf52ab43175c73970926a6731f743c16 (diff)
downloadmeta-cloud-services-7f775376da134bf50690268664daa1bd77c2a3b4.tar.gz
python3-pastedeploy: upgrade 2.0.1 -> 2.1.0
Consolidate inc and bb files into a single bb file. -License-Update: Update PKG-INFO. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools')
-rw-r--r--meta-openstack/recipes-devtools/python/python-pastedeploy.inc16
-rw-r--r--meta-openstack/recipes-devtools/python/python3-pastedeploy_2.0.1.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python3-pastedeploy_2.1.0.bb19
3 files changed, 19 insertions, 18 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-pastedeploy.inc b/meta-openstack/recipes-devtools/python/python-pastedeploy.inc
deleted file mode 100644
index db0b4ac..0000000
--- a/meta-openstack/recipes-devtools/python/python-pastedeploy.inc
+++ /dev/null
@@ -1,16 +0,0 @@
1DESCRIPTION = "Load, configure, and compose WSGI applications and servers"
2HOMEPAGE = "http://pythonpaste.org/deploy/"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=d6c3089319205d7e6129f0213b7e949f"
6
7PYPI_PACKAGE = "PasteDeploy"
8
9SRC_URI[md5sum] = "6193afccc0982abedb9b7711d0d6adb0"
10SRC_URI[sha256sum] = "d423fb9d51fdcf853aa4ff43ac7ec469b643ea19590f67488122d6d0d772350a"
11
12inherit pypi
13
14DEPENDS += "${PYTHON_PN}-pytest-runner-native"
15
16RDEPENDS_${PN} += "${PYTHON_PN}-paste"
diff --git a/meta-openstack/recipes-devtools/python/python3-pastedeploy_2.0.1.bb b/meta-openstack/recipes-devtools/python/python3-pastedeploy_2.0.1.bb
deleted file mode 100644
index 91c31a1..0000000
--- a/meta-openstack/recipes-devtools/python/python3-pastedeploy_2.0.1.bb
+++ /dev/null
@@ -1,2 +0,0 @@
1require python-pastedeploy.inc
2inherit setuptools3
diff --git a/meta-openstack/recipes-devtools/python/python3-pastedeploy_2.1.0.bb b/meta-openstack/recipes-devtools/python/python3-pastedeploy_2.1.0.bb
new file mode 100644
index 0000000..c08644f
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-pastedeploy_2.1.0.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "Load, configure, and compose WSGI applications and servers"
2HOMEPAGE = "http://pythonpaste.org/deploy/"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=57609488f8ad28ebf6844a5169a85215"
6
7PYPI_PACKAGE = "PasteDeploy"
8
9SRC_URI[md5sum] = "f1e62dc76092433b7ae150cd81603fbd"
10SRC_URI[sha256sum] = "e7559878b6e92023041484be9bcb6d767cf4492fc3de7257a5dae76a7cc11a9b"
11
12inherit setuptools3 pypi
13
14DEPENDS += "${PYTHON_PN}-pytest-runner-native"
15
16RDEPENDS_${PN} += " \
17 ${PYTHON_PN}-paste \
18 ${PYTHON_PN}-setuptools \
19"