summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2014-03-17 12:25:04 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-03-17 13:12:55 -0400
commitd370e70c089c06241a739b47916a5c6d6c37226b (patch)
tree7241f47e4871abf9bb23011aadea5826fa217542 /meta-openstack/recipes-devtools
parent54c9a71b7f00c7dd35ecff6aad86cd47d83280d6 (diff)
downloadmeta-cloud-services-d370e70c089c06241a739b47916a5c6d6c37226b.tar.gz
python-*: prevent setuptools from fetching required eggs
Several python packages require 'python-pbr' both at build and runtime, as listed in their respective setup.py files, yet this dependency is not included in their recipe. Adding python-pbr to the RDEPENDS to correct this. In addition this situation is complicated by the fact that the setuptools will actually fetch python-pip and python-pbr eggs, regardless of the value of BB_NO_NETWORK, if any of these packages are built before python-pip and python-pbr are in the sysroot. Most dramitically if you were to attempt to build any of these packages with no network connectivity the do_compile() task will fail with the following: | DEBUG: Executing shell function do_compile | Download error: [Errno 110] Connection timed out -- Some packages may not be found! | Couldn't find index page for 'pip' (maybe misspelled?) | Download error: [Errno 110] Connection timed out -- Some packages may not be found! | No local packages or download links found for pip>=1.0 | Traceback (most recent call last): | File "setup.py", line 21, in <module> | pbr=True) Adding the missing DEPENDS will ensure these packages are available without the need for setuptools to fetch them, and avoid possible build issues due to network connectivity. In order to test these modifications all of these packages have been built with a populated sstate cache and the network crippled using: iptables -A OUTPUT -p tcp --destination-port 80 -j DROP to ensure no extra fetches are taking place. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools')
-rw-r--r--meta-openstack/recipes-devtools/python/python-ceilometer_git.bb6
-rw-r--r--meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb6
-rw-r--r--meta-openstack/recipes-devtools/python/python-cinder_git.bb6
-rw-r--r--meta-openstack/recipes-devtools/python/python-cinderclient_git.bb6
-rw-r--r--meta-openstack/recipes-devtools/python/python-django-openstack-auth_1.1.4.bb6
-rw-r--r--meta-openstack/recipes-devtools/python/python-glance_git.bb6
-rw-r--r--meta-openstack/recipes-devtools/python/python-glanceclient_git.bb7
-rw-r--r--meta-openstack/recipes-devtools/python/python-heat_git.bb7
-rw-r--r--meta-openstack/recipes-devtools/python/python-heatclient_git.bb6
-rw-r--r--meta-openstack/recipes-devtools/python/python-horizon_git.bb6
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_git.bb6
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb6
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron_git.bb6
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutronclient_git.bb6
-rw-r--r--meta-openstack/recipes-devtools/python/python-nova_git.bb6
-rw-r--r--meta-openstack/recipes-devtools/python/python-novaclient_git.bb6
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.config_1.2.1.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-sqlalchemy-migrate_0.8.2.bb6
-rw-r--r--meta-openstack/recipes-devtools/python/python-stevedore_0.12.bb9
-rw-r--r--meta-openstack/recipes-devtools/python/python-swift_git.bb6
-rw-r--r--meta-openstack/recipes-devtools/python/python-swiftclient_git.bb10
-rw-r--r--meta-openstack/recipes-devtools/python/python-wsme_0.5b6.bb9
22 files changed, 141 insertions, 2 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb b/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
index cf0d196..e67f2bf 100644
--- a/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
@@ -131,6 +131,11 @@ FILES_${SRCNAME}-controller = "${bindir}/* \
131 ${sysconfdir}/init.d/ceilometer-agent-central \ 131 ${sysconfdir}/init.d/ceilometer-agent-central \
132" 132"
133 133
134DEPENDS += " \
135 python-pip \
136 python-pbr \
137 "
138
134RDEPENDS_${PN} += " \ 139RDEPENDS_${PN} += " \
135 python-ply \ 140 python-ply \
136 python-jsonpath-rw \ 141 python-jsonpath-rw \
@@ -175,6 +180,7 @@ RDEPENDS_${PN} += " \
175 python-pyyaml \ 180 python-pyyaml \
176 python-pip \ 181 python-pip \
177 python-pytz \ 182 python-pytz \
183 python-pbr \
178 " 184 "
179 185
180RDEPENDS_${SRCNAME}-controller = "${PN} ${SRCNAME}-common ${SRCNAME}-alarm-notifier ${SRCNAME}-alarm-evaluator \ 186RDEPENDS_${SRCNAME}-controller = "${PN} ${SRCNAME}-common ${SRCNAME}-alarm-notifier ${SRCNAME}-alarm-evaluator \
diff --git a/meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb b/meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb
index 08b6286..811bbd5 100644
--- a/meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb
@@ -4,12 +4,18 @@ SECTION = "devel/python"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6 6
7DEPENDS += " \
8 python-pip \
9 python-pbr \
10 "
11
7RDEPENDS_${PN} +="python-cliff \ 12RDEPENDS_${PN} +="python-cliff \
8 python-httplib2 \ 13 python-httplib2 \
9 python-iso8601 \ 14 python-iso8601 \
10 python-prettytable \ 15 python-prettytable \
11 python-pyparsing \ 16 python-pyparsing \
12 python-simplejson \ 17 python-simplejson \
18 python-pbr \
13 " 19 "
14 20
15PR = "r0" 21PR = "r0"
diff --git a/meta-openstack/recipes-devtools/python/python-cinder_git.bb b/meta-openstack/recipes-devtools/python/python-cinder_git.bb
index e770e98..a706223 100644
--- a/meta-openstack/recipes-devtools/python/python-cinder_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-cinder_git.bb
@@ -95,6 +95,11 @@ FILES_${SRCNAME} = "${bindir}/* \
95 ${localstatedir}/* \ 95 ${localstatedir}/* \
96 " 96 "
97 97
98DEPENDS += " \
99 python-pip \
100 python-pbr \
101 "
102
98RDEPENDS_${PN} += "lvm2 \ 103RDEPENDS_${PN} += "lvm2 \
99 python-sqlalchemy \ 104 python-sqlalchemy \
100 python-amqplib \ 105 python-amqplib \
@@ -119,6 +124,7 @@ RDEPENDS_${PN} += "lvm2 \
119 python-keystoneclient \ 124 python-keystoneclient \
120 python-swiftclient \ 125 python-swiftclient \
121 python-oslo.config \ 126 python-oslo.config \
127 python-pbr \
122 " 128 "
123 129
124RDEPENDS_${SRCNAME} = "${PN} \ 130RDEPENDS_${SRCNAME} = "${PN} \
diff --git a/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb b/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
index a5c1c20..f12975e 100644
--- a/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
@@ -16,8 +16,14 @@ S = "${WORKDIR}/git"
16 16
17inherit setuptools 17inherit setuptools
18 18
19DEPENDS += " \
20 python-pip \
21 python-pbr \
22 "
23
19RDEPENDS_${PN} += "python-prettytable \ 24RDEPENDS_${PN} += "python-prettytable \
20 python-simplejson \ 25 python-simplejson \
21 python-requests \ 26 python-requests \
22 python-setuptools-git \ 27 python-setuptools-git \
28 python-pbr \
23 " 29 "
diff --git a/meta-openstack/recipes-devtools/python/python-django-openstack-auth_1.1.4.bb b/meta-openstack/recipes-devtools/python/python-django-openstack-auth_1.1.4.bb
index d38b83a..cad82cb 100644
--- a/meta-openstack/recipes-devtools/python/python-django-openstack-auth_1.1.4.bb
+++ b/meta-openstack/recipes-devtools/python/python-django-openstack-auth_1.1.4.bb
@@ -17,6 +17,12 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
17 17
18inherit setuptools 18inherit setuptools
19 19
20DEPENDS += " \
21 python-pip \
22 python-pbr \
23 "
24
20RDEPENDS_${PN} += "python-django \ 25RDEPENDS_${PN} += "python-django \
21 python-keystoneclient \ 26 python-keystoneclient \
27 python-pbr \
22 " \ No newline at end of file 28 " \ No newline at end of file
diff --git a/meta-openstack/recipes-devtools/python/python-glance_git.bb b/meta-openstack/recipes-devtools/python/python-glance_git.bb
index ca09907..1bd24d0 100644
--- a/meta-openstack/recipes-devtools/python/python-glance_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-glance_git.bb
@@ -101,6 +101,11 @@ FILES_${SRCNAME}-registry = "${bindir}/glance-registry \
101 ${sysconfdir}/init.d/glance-registry \ 101 ${sysconfdir}/init.d/glance-registry \
102 " 102 "
103 103
104DEPENDS += " \
105 python-pip \
106 python-pbr \
107 "
108
104RDEPENDS_${PN} += "python-greenlet \ 109RDEPENDS_${PN} += "python-greenlet \
105 python-sqlalchemy \ 110 python-sqlalchemy \
106 python-anyjson \ 111 python-anyjson \
@@ -121,6 +126,7 @@ RDEPENDS_${PN} += "python-greenlet \
121 python-jsonschema \ 126 python-jsonschema \
122 python-keystoneclient \ 127 python-keystoneclient \
123 python-swiftclient \ 128 python-swiftclient \
129 python-pbr \
124 " 130 "
125 131
126RDEPENDS_${SRCNAME} = "${PN} \ 132RDEPENDS_${SRCNAME} = "${PN} \
diff --git a/meta-openstack/recipes-devtools/python/python-glanceclient_git.bb b/meta-openstack/recipes-devtools/python/python-glanceclient_git.bb
index 889b411..1d7a4d1 100644
--- a/meta-openstack/recipes-devtools/python/python-glanceclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-glanceclient_git.bb
@@ -3,7 +3,11 @@ HOMEPAGE = "https://github.com/openstack/python-glanceclient"
3SECTION = "devel/python" 3SECTION = "devel/python"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6DEPENDS = "gmp" 6DEPENDS += " \
7 gmp \
8 python-pip \
9 python-pbr \
10 "
7 11
8SRCREV = "23ad1d6db7ec8116afed7c8aca3832dac440930a" 12SRCREV = "23ad1d6db7ec8116afed7c8aca3832dac440930a"
9PV = "0.12.0+gitr${SRCREV}" 13PV = "0.12.0+gitr${SRCREV}"
@@ -22,5 +26,6 @@ RDEPENDS_${PN} = "gmp \
22 python-pyopenssl \ 26 python-pyopenssl \
23 python-prettytable \ 27 python-prettytable \
24 python-setuptools-git \ 28 python-setuptools-git \
29 python-pbr \
25 " 30 "
26 31
diff --git a/meta-openstack/recipes-devtools/python/python-heat_git.bb b/meta-openstack/recipes-devtools/python/python-heat_git.bb
index 7fa798c..4c12551 100644
--- a/meta-openstack/recipes-devtools/python/python-heat_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-heat_git.bb
@@ -105,6 +105,12 @@ FILES_${SRCNAME}-engine = "${bindir}/heat-engine \
105 ${bindir}/* \ 105 ${bindir}/* \
106 ${sysconfdir}/init.d/heat-engine \ 106 ${sysconfdir}/init.d/heat-engine \
107" 107"
108
109DEPENDS += " \
110 python-pip \
111 python-pbr \
112 "
113
108RDEPENDS_${PN} += " \ 114RDEPENDS_${PN} += " \
109 python-heatclient \ 115 python-heatclient \
110 python-sqlalchemy \ 116 python-sqlalchemy \
@@ -148,6 +154,7 @@ RDEPENDS_${PN} += " \
148 python-pyyaml \ 154 python-pyyaml \
149 python-pip \ 155 python-pip \
150 python-pytz \ 156 python-pytz \
157 python-pbr \
151 " 158 "
152 159
153RDEPENDS_${SRCNAME}-engine = "${PN} ${SRCNAME}-common postgresql postgresql-client python-psycopg2 tgt" 160RDEPENDS_${SRCNAME}-engine = "${PN} ${SRCNAME}-common postgresql postgresql-client python-psycopg2 tgt"
diff --git a/meta-openstack/recipes-devtools/python/python-heatclient_git.bb b/meta-openstack/recipes-devtools/python/python-heatclient_git.bb
index 2f3262c..fc9f020 100644
--- a/meta-openstack/recipes-devtools/python/python-heatclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-heatclient_git.bb
@@ -4,12 +4,18 @@ SECTION = "devel/python"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6 6
7DEPENDS += " \
8 python-pip \
9 python-pbr \
10 "
11
7RDEPENDS_${PN} +="python-cliff \ 12RDEPENDS_${PN} +="python-cliff \
8 python-httplib2 \ 13 python-httplib2 \
9 python-iso8601 \ 14 python-iso8601 \
10 python-prettytable \ 15 python-prettytable \
11 python-pyparsing \ 16 python-pyparsing \
12 python-simplejson \ 17 python-simplejson \
18 python-pbr \
13 " 19 "
14 20
15PR = "r0" 21PR = "r0"
diff --git a/meta-openstack/recipes-devtools/python/python-horizon_git.bb b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
index 3b2dd26..be45a2b 100644
--- a/meta-openstack/recipes-devtools/python/python-horizon_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
@@ -4,6 +4,11 @@ SECTION = "devel/python"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6 6
7DEPENDS += " \
8 python-pip \
9 python-pbr \
10 "
11
7DEPENDS_${PN} += "python-django \ 12DEPENDS_${PN} += "python-django \
8 python-django-compressor \ 13 python-django-compressor \
9 python-django-openstack-auth \ 14 python-django-openstack-auth \
@@ -19,6 +24,7 @@ DEPENDS_${PN} += "python-django \
19 python-six \ 24 python-six \
20 python-swiftclient \ 25 python-swiftclient \
21 python-lockfile \ 26 python-lockfile \
27 python-pbr \
22 " 28 "
23 29
24PR = "r1" 30PR = "r1"
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_git.bb b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
index aa42824..bb44fe4 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
@@ -109,6 +109,11 @@ FILES_${SRCNAME} = "${bindir}/* \
109 ${localstatedir}/* \ 109 ${localstatedir}/* \
110 " 110 "
111 111
112DEPENDS += " \
113 python-pip \
114 python-pbr \
115 "
116
112RDEPENDS_${PN} += " \ 117RDEPENDS_${PN} += " \
113 python-pam \ 118 python-pam \
114 python-webob \ 119 python-webob \
@@ -126,6 +131,7 @@ RDEPENDS_${PN} += " \
126 python-oslo.config \ 131 python-oslo.config \
127 python-dogpile.core \ 132 python-dogpile.core \
128 python-dogpile.cache \ 133 python-dogpile.cache \
134 python-pbr \
129 " 135 "
130 136
131# TODO: 137# TODO:
diff --git a/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb b/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
index 9a615bc..be2395a 100644
--- a/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
@@ -16,9 +16,15 @@ inherit setuptools
16 16
17FILES_${PN}-doc += "${datadir}/keystoneclient" 17FILES_${PN}-doc += "${datadir}/keystoneclient"
18 18
19DEPENDS += " \
20 python-pip \
21 python-pbr \
22 "
23
19RDEPENDS_${PN} += "python-iso8601 \ 24RDEPENDS_${PN} += "python-iso8601 \
20 python-prettytable \ 25 python-prettytable \
21 python-requests \ 26 python-requests \
22 python-simplejson \ 27 python-simplejson \
23 python-oslo.config \ 28 python-oslo.config \
29 python-pbr \
24 " 30 "
diff --git a/meta-openstack/recipes-devtools/python/python-neutron_git.bb b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
index 6ad2289..4aa974e 100644
--- a/meta-openstack/recipes-devtools/python/python-neutron_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
@@ -159,6 +159,11 @@ FILES_${SRCNAME}-extra-agents = "${bindir}/*"
159 159
160FILES_${SRCNAME}-doc = "${datadir}/*" 160FILES_${SRCNAME}-doc = "${datadir}/*"
161 161
162DEPENDS += " \
163 python-pip \
164 python-pbr \
165 "
166
162RDEPENDS_${PN} += "python-paste \ 167RDEPENDS_${PN} += "python-paste \
163 python-pastedeploy \ 168 python-pastedeploy \
164 python-routes \ 169 python-routes \
@@ -181,6 +186,7 @@ RDEPENDS_${PN} += "python-paste \
181 python-mako \ 186 python-mako \
182 python-markupsafe \ 187 python-markupsafe \
183 python-pyparsing \ 188 python-pyparsing \
189 python-pbr \
184 " 190 "
185 191
186RDEPENDS_${SRCNAME} = "${PN} \ 192RDEPENDS_${SRCNAME} = "${PN} \
diff --git a/meta-openstack/recipes-devtools/python/python-neutronclient_git.bb b/meta-openstack/recipes-devtools/python/python-neutronclient_git.bb
index 7dbf2a6..6d295c2 100644
--- a/meta-openstack/recipes-devtools/python/python-neutronclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-neutronclient_git.bb
@@ -4,12 +4,18 @@ SECTION = "devel/python"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6 6
7DEPENDS += " \
8 python-pip \
9 python-pbr \
10 "
11
7RDEPENDS_${PN} +="python-cliff \ 12RDEPENDS_${PN} +="python-cliff \
8 python-httplib2 \ 13 python-httplib2 \
9 python-iso8601 \ 14 python-iso8601 \
10 python-prettytable \ 15 python-prettytable \
11 python-pyparsing \ 16 python-pyparsing \
12 python-simplejson \ 17 python-simplejson \
18 python-pbr \
13 " 19 "
14 20
15PR = "r0" 21PR = "r0"
diff --git a/meta-openstack/recipes-devtools/python/python-nova_git.bb b/meta-openstack/recipes-devtools/python/python-nova_git.bb
index 4770448..e41e796 100644
--- a/meta-openstack/recipes-devtools/python/python-nova_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-nova_git.bb
@@ -195,6 +195,11 @@ FILES_${SRCNAME}-api = " \
195 ${sysconfdir}/init.d/nova-api \ 195 ${sysconfdir}/init.d/nova-api \
196" 196"
197 197
198DEPENDS += " \
199 python-pip \
200 python-pbr \
201 "
202
198RDEPENDS_${PN} = " libvirt \ 203RDEPENDS_${PN} = " libvirt \
199 python-modules \ 204 python-modules \
200 python-misc \ 205 python-misc \
@@ -233,6 +238,7 @@ RDEPENDS_${PN} = " libvirt \
233 python-routes \ 238 python-routes \
234 python-webob \ 239 python-webob \
235 python-websockify \ 240 python-websockify \
241 python-pbr \
236 " 242 "
237 243
238RDEPENDS_${SRCNAME}-common = "${PN} openssl openssl-misc libxml2 libxslt \ 244RDEPENDS_${SRCNAME}-common = "${PN} openssl openssl-misc libxml2 libxslt \
diff --git a/meta-openstack/recipes-devtools/python/python-novaclient_git.bb b/meta-openstack/recipes-devtools/python/python-novaclient_git.bb
index efd514f..2884e0f 100644
--- a/meta-openstack/recipes-devtools/python/python-novaclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-novaclient_git.bb
@@ -15,8 +15,14 @@ S = "${WORKDIR}/git"
15 15
16inherit setuptools 16inherit setuptools
17 17
18DEPENDS += " \
19 python-pip \
20 python-pbr \
21 "
22
18RDEPENDS_${PN} += "python-iso8601 \ 23RDEPENDS_${PN} += "python-iso8601 \
19 python-prettytable \ 24 python-prettytable \
20 python-requests \ 25 python-requests \
21 python-simplejson \ 26 python-simplejson \
27 python-pbr \
22 " 28 "
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.config_1.2.1.bb b/meta-openstack/recipes-devtools/python/python-oslo.config_1.2.1.bb
index 3ffdbe8..548c6cb 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.config_1.2.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.config_1.2.1.bb
@@ -16,4 +16,9 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
16 16
17inherit setuptools 17inherit setuptools
18 18
19DEPENDS += " \
20 python-pbr \
21 python-pip \
22 "
23
19RDEPENDS_${PN} += "python-pbr" \ No newline at end of file 24RDEPENDS_${PN} += "python-pbr" \ No newline at end of file
diff --git a/meta-openstack/recipes-devtools/python/python-sqlalchemy-migrate_0.8.2.bb b/meta-openstack/recipes-devtools/python/python-sqlalchemy-migrate_0.8.2.bb
index 06cb619..7af55a7 100644
--- a/meta-openstack/recipes-devtools/python/python-sqlalchemy-migrate_0.8.2.bb
+++ b/meta-openstack/recipes-devtools/python/python-sqlalchemy-migrate_0.8.2.bb
@@ -16,7 +16,13 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
16 16
17inherit setuptools 17inherit setuptools
18 18
19DEPENDS += " \
20 python-pip \
21 python-pbr \
22 "
23
19RDEPENDS_${PN} += "python-sqlalchemy \ 24RDEPENDS_${PN} += "python-sqlalchemy \
20 python-decorator \ 25 python-decorator \
21 python-tempita \ 26 python-tempita \
27 python-pbr \
22 " 28 "
diff --git a/meta-openstack/recipes-devtools/python/python-stevedore_0.12.bb b/meta-openstack/recipes-devtools/python/python-stevedore_0.12.bb
index 061f6d4..2013fd0 100644
--- a/meta-openstack/recipes-devtools/python/python-stevedore_0.12.bb
+++ b/meta-openstack/recipes-devtools/python/python-stevedore_0.12.bb
@@ -15,3 +15,12 @@ SRC_URI[sha256sum] = "9689a76c09eaeb60b6db5b45aae71de8c53f15d302d790536ac5bf7c47
15S = "${WORKDIR}/${SRCNAME}-${PV}" 15S = "${WORKDIR}/${SRCNAME}-${PV}"
16 16
17inherit setuptools 17inherit setuptools
18
19DEPENDS += " \
20 python-pip \
21 python-pbr \
22 "
23
24RDEPENDS_${PN} += " \
25 python-pbr \
26 "
diff --git a/meta-openstack/recipes-devtools/python/python-swift_git.bb b/meta-openstack/recipes-devtools/python/python-swift_git.bb
index 7248eda..3a31b82 100644
--- a/meta-openstack/recipes-devtools/python/python-swift_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-swift_git.bb
@@ -37,6 +37,11 @@ FILES_${SRCNAME} = "${bindir}/* \
37 ${sysconfdir}/${SRCNAME}/* \ 37 ${sysconfdir}/${SRCNAME}/* \
38" 38"
39 39
40DEPENDS += " \
41 python-pip \
42 python-pbr \
43 "
44
40RDEPENDS_${PN} += " \ 45RDEPENDS_${PN} += " \
41 python-eventlet \ 46 python-eventlet \
42 python-greenlet \ 47 python-greenlet \
@@ -45,6 +50,7 @@ RDEPENDS_${PN} += " \
45 python-swiftclient \ 50 python-swiftclient \
46 python-netifaces \ 51 python-netifaces \
47 python-xattr \ 52 python-xattr \
53 python-pbr \
48 " 54 "
49 55
50RDEPENDS_${SRCNAME} = "${PN}" \ No newline at end of file 56RDEPENDS_${SRCNAME} = "${PN}" \ No newline at end of file
diff --git a/meta-openstack/recipes-devtools/python/python-swiftclient_git.bb b/meta-openstack/recipes-devtools/python/python-swiftclient_git.bb
index a856bbb..fe3f062 100644
--- a/meta-openstack/recipes-devtools/python/python-swiftclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-swiftclient_git.bb
@@ -14,4 +14,12 @@ S = "${WORKDIR}/git"
14 14
15inherit setuptools 15inherit setuptools
16 16
17RDEPENDS_${PN} += "python-simplejson" \ No newline at end of file 17DEPENDS += " \
18 python-pip \
19 python-pbr \
20 "
21
22RDEPENDS_${PN} += " \
23 python-simplejson \
24 python-pbr \
25 "
diff --git a/meta-openstack/recipes-devtools/python/python-wsme_0.5b6.bb b/meta-openstack/recipes-devtools/python/python-wsme_0.5b6.bb
index 86efde6..ccf2189 100644
--- a/meta-openstack/recipes-devtools/python/python-wsme_0.5b6.bb
+++ b/meta-openstack/recipes-devtools/python/python-wsme_0.5b6.bb
@@ -15,3 +15,12 @@ SRC_URI[sha256sum] = "9476b6c80fa9c36e966d80352e589d5fd9cf356b9bdec7f755b07ca5d2
15S = "${WORKDIR}/${SRCNAME}-${PV}" 15S = "${WORKDIR}/${SRCNAME}-${PV}"
16 16
17inherit setuptools 17inherit setuptools
18
19DEPENDS += " \
20 python-pip \
21 python-pbr \
22 "
23
24RDEPENDS_${PN} += "\
25 python-pbr \
26 "