summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2014-05-20 15:26:57 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-05-24 00:27:14 -0400
commit3197668c9c940295e7c824f8cd2b1f69949bf213 (patch)
tree6f2b44b93a21af39c8a8f53be35d27612781b40e /meta-openstack/recipes-devtools/ruby
parent00e6f337dee55167a550066e69346045fc7dfb7a (diff)
downloadmeta-cloud-services-3197668c9c940295e7c824f8cd2b1f69949bf213.tar.gz
Ruby/chef solo: Add recipes-devtools/ruby/yard_git.bb
YARD is a documentation generation tool for the Ruby programming language. It enables the user to generate consistent, usable documentation that can be exported to a number of formats very easily, and also supports extending for custom Ruby constructs such as custom class level definitions. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Amy Fong <amy.fong@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby')
-rw-r--r--meta-openstack/recipes-devtools/ruby/yard_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/yard_git.bb b/meta-openstack/recipes-devtools/ruby/yard_git.bb
new file mode 100644
index 0000000..ff2a685
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/yard_git.bb
@@ -0,0 +1,28 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4SUMMARY = "A documentation generation tool for the Ruby programming language."
5DESCRIPTION = "YARD is a documentation generation tool for the Ruby \
6programming language. It enables the user to generate consistent, \
7usable documentation that can be exported to a number of formats very \
8easily, and also supports extending for custom Ruby constructs such as \
9custom class level definitions."
10
11LICENSE = "MIT"
12LIC_FILES_CHKSUM = "file://LICENSE;md5=b3e127de4b3f2e58562183d9aba9a7f6"
13
14PR = "r0"
15
16BPV = "0.8.7.3"
17PV = "${BPV}"
18SRCREV = "b78dea29adafd937f1ca5e813a5269b62ffceba3"
19
20S = "${WORKDIR}/git"
21
22SRC_URI = " \
23 git://github.com/lsegal/yard.git \
24 "
25
26inherit ruby
27
28BBCLASSEXTEND = "native" \ No newline at end of file