summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-11-13 14:32:22 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-11-14 12:38:27 -0500
commit1853c434f5986bdf763efc07e8b957b74efc9f43 (patch)
tree50a155c42805ed5743638ba9d378f6a50cdfb8d0 /meta-openstack/recipes-devtools/python
parent9ba4c53af7427d1e58e613a7a0641c864714c14d (diff)
downloadmeta-cloud-services-1853c434f5986bdf763efc07e8b957b74efc9f43.tar.gz
python-ceilometerclient: uprev to latest stable/pike
Drop old patches and update runtime dependency list. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python')
-rw-r--r--meta-openstack/recipes-devtools/python/python-ceilometerclient/fix_ceilometerclient_memory_leak.patch37
-rw-r--r--meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb23
2 files changed, 9 insertions, 51 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-ceilometerclient/fix_ceilometerclient_memory_leak.patch b/meta-openstack/recipes-devtools/python/python-ceilometerclient/fix_ceilometerclient_memory_leak.patch
deleted file mode 100644
index 8abc654..0000000
--- a/meta-openstack/recipes-devtools/python/python-ceilometerclient/fix_ceilometerclient_memory_leak.patch
+++ /dev/null
@@ -1,37 +0,0 @@
1---
2 ceilometerclient/openstack/common/apiclient/client.py | 12 ++++++++++++
3 1 file changed, 12 insertions(+)
4
5--- a/ceilometerclient/openstack/common/apiclient/client.py
6+++ b/ceilometerclient/openstack/common/apiclient/client.py
7@@ -90,6 +90,7 @@
8 self.user_agent = user_agent or self.user_agent
9
10 self.times = [] # [("item", starttime, endtime), ...]
11+ self.times_max_len = 200
12 self.timings = timings
13
14 # requests within the same session can reuse TCP connections from pool
15@@ -142,6 +143,12 @@
16 def reset_timings(self):
17 self.times = []
18
19+ def get_timings_max_len(self):
20+ return self.times_max_len
21+
22+ def set_timings_max_len(self, new_len):
23+ self.times_max_len = new_len
24+
25 def request(self, method, url, **kwargs):
26 """Send an http request with the specified characteristics.
27
28@@ -173,6 +180,9 @@
29 if self.timings:
30 self.times.append(("%s %s" % (method, url),
31 start_time, time.time()))
32+ # remove oldest items until we maintain max length
33+ while len(self.times) > self.times_max_len:
34+ del self.times[0]
35 self._http_log_resp(resp)
36
37 if resp.status_code >= 400:
diff --git a/meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb b/meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb
index a830e51..0341cac 100644
--- a/meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb
@@ -9,30 +9,25 @@ DEPENDS += " \
9 python-pbr \ 9 python-pbr \
10 " 10 "
11 11
12RDEPENDS_${PN} +=" \ 12RDEPENDS_${PN} += " \
13 python-cliff \ 13 python-pbr \
14 python-httplib2 \ 14 python-iso8601 \
15 python-iso8601 \ 15 python-keystoneauth1 \
16 python-prettytable \
17 python-pyparsing \
18 python-simplejson \
19 python-pbr \
20 python-oslo.i18n \ 16 python-oslo.i18n \
21 python-oslo.serialization \ 17 python-oslo.serialization \
22 python-oslo.utils \ 18 python-oslo.utils \
23 python-keystoneclient \ 19 python-prettytable \
24 python-requests \ 20 python-requests \
25 python-six \ 21 python-six \
26 python-stevedore \ 22 python-stevedore \
27 " 23 "
28 24
29SRC_URI = "\ 25SRC_URI = "\
30 git://github.com/openstack/python-ceilometerclient.git;branch=master \ 26 git://github.com/openstack/python-ceilometerclient.git;branch=stable/pike \
31 file://fix_ceilometerclient_memory_leak.patch \
32 " 27 "
33 28
34PV = "1.5.0+git${SRCPV}" 29PV = "2.9.0+git${SRCPV}"
35SRCREV = "daed7e59c383f1ca74d75160cbc99fbd89675648" 30SRCREV = "4ee321feeef39fa2a297ad8e58e931b8a03d8f14"
36S = "${WORKDIR}/git" 31S = "${WORKDIR}/git"
37 32
38inherit setuptools rmargparse 33inherit setuptools rmargparse