summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-trove_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2016-02-03 20:41:42 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:18 -0500
commit62cf4f5a509fd0278c1de998fba8cfa6cbfeded7 (patch)
tree863f694ddbf6572191e6ea68d7e1377405a92037 /meta-openstack/recipes-devtools/python/python-trove_git.bb
parente0c82f9b1a4867056aa334ee53f9eb93982acf48 (diff)
downloadmeta-cloud-services-62cf4f5a509fd0278c1de998fba8cfa6cbfeded7.tar.gz
trove: move to latest release
Uprev trove to the latest release. This requires updates to configurations strings since the 'sql_' configs have been deprecated. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-trove_git.bb')
-rwxr-xr-xmeta-openstack/recipes-devtools/python/python-trove_git.bb15
1 files changed, 8 insertions, 7 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-trove_git.bb b/meta-openstack/recipes-devtools/python/python-trove_git.bb
index ae6defd..1b8d9ac 100755
--- a/meta-openstack/recipes-devtools/python/python-trove_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-trove_git.bb
@@ -4,15 +4,14 @@ SECTION = "devel/python"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6 6
7PR = "r0"
8SRCNAME = "trove" 7SRCNAME = "trove"
9 8
10SRC_URI = "git://github.com/openstack/trove.git;branch=stable/juno \ 9SRC_URI = "git://github.com/openstack/trove.git;branch=master \
11 file://trove-init \ 10 file://trove-init \
12 " 11 "
13 12
14SRCREV="6c4ea5b845a4d6d71d3d3786517b5b358c30f3ec" 13SRCREV="11996635299396f181f5aec3c6825f8011d45e2c"
15PV="2014.2+git${SRCPV}" 14PV="4.0.0+git${SRCPV}"
16S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
17 16
18inherit update-rc.d setuptools identity hosts useradd default_configs 17inherit update-rc.d setuptools identity hosts useradd default_configs
@@ -77,13 +76,13 @@ do_install_append() {
77 sed -e "s:#log_dir.*:log_dir = ${TROVE_LOG_DIR}:g" \ 76 sed -e "s:#log_dir.*:log_dir = ${TROVE_LOG_DIR}:g" \
78 -i ${TROVE_CONF_DIR}/$file 77 -i ${TROVE_CONF_DIR}/$file
79 78
80 sed -e "s:^sql_connection = mysql\(.*\):#sql_connection = mysql\1:g" \ 79 sed -e "s:^connection = mysql\(.*\):#connection = mysql\1:g" \
81 -i ${TROVE_CONF_DIR}/$file 80 -i ${TROVE_CONF_DIR}/$file
82 81
83 sed -e "s,^#sql_connection = postgresql://.*,sql_connection = postgresql://${ADMIN_USER}:${ADMIN_PASSWORD}@localhost/trove,g" \ 82 sed -e "s,^#connection = postgresql://.*,connection = postgresql://${ADMIN_USER}:${ADMIN_PASSWORD}@localhost/trove,g" \
84 -i ${TROVE_CONF_DIR}/$file 83 -i ${TROVE_CONF_DIR}/$file
85 84
86 sed -i "/sql_connection = postgres.*n/adefault_datastore = postgresql" \ 85 sed -i "/connection = postgres.*n/adefault_datastore = postgresql" \
87 ${TROVE_CONF_DIR}/$file 86 ${TROVE_CONF_DIR}/$file
88 87
89 sed -e "s,dns_auth_url = .*,dns_auth_url = http://127.0.0.1:8081/keystone/main/v2.0,g" \ 88 sed -e "s,dns_auth_url = .*,dns_auth_url = http://127.0.0.1:8081/keystone/main/v2.0,g" \
@@ -255,6 +254,7 @@ RDEPENDS_${PN} += " \
255 python-neutronclient \ 254 python-neutronclient \
256 python-novaclient \ 255 python-novaclient \
257 python-oslo.config \ 256 python-oslo.config \
257 python-oslo.service \
258 python-passlib \ 258 python-passlib \
259 python-paste \ 259 python-paste \
260 python-pastedeploy \ 260 python-pastedeploy \
@@ -262,6 +262,7 @@ RDEPENDS_${PN} += " \
262 python-sqlalchemy-migrate \ 262 python-sqlalchemy-migrate \
263 python-swiftclient \ 263 python-swiftclient \
264 python-webob \ 264 python-webob \
265 python-monotonic \
265 uwsgi \ 266 uwsgi \
266 " 267 "
267 268