summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-repoze.lru_0.6.bb
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2015-05-13 15:24:24 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-05-13 16:50:29 -0400
commit94c875040f396d5f59255b8814ae10f3a0982f6d (patch)
tree6cc12716498285db18483f507d56b265bdcba2f8 /meta-openstack/recipes-devtools/python/python-repoze.lru_0.6.bb
parentee0bfb3210d4fecd7d16e9b1c730b13dfd600914 (diff)
downloadmeta-cloud-services-94c875040f396d5f59255b8814ae10f3a0982f6d.tar.gz
python-repoze.lru: add new recipe
It's required by python-routes. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-repoze.lru_0.6.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-repoze.lru_0.6.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-repoze.lru_0.6.bb b/meta-openstack/recipes-devtools/python/python-repoze.lru_0.6.bb
new file mode 100644
index 0000000..60a749f
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-repoze.lru_0.6.bb
@@ -0,0 +1,20 @@
1SUMMARY = "A tiny LRU cache implementation and decorator"
2DESCRIPTION = "repoze.lru is a LRU (least recently used) cache implementation. \
3Keys and values that are not used frequently will be evicted from the cache faster \
4than keys and values that are used frequently. \
5"
6HOMEPAGE = "https://pypi.python.org/pypi/repoze.lru"
7SECTION = "devel/python"
8LICENSE = "BSD-derived"
9LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2c33cdbc6bc9ae6e5d64152fdb754292"
10
11SRCNAME = "repoze.lru"
12
13SRC_URI = "http://pypi.python.org/packages/source/r/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
14
15SRC_URI[md5sum] = "2c3b64b17a8e18b405f55d46173e14dd"
16SRC_URI[sha256sum] = "0f7a323bf716d3cb6cb3910cd4fccbee0b3d3793322738566ecce163b01bbd31"
17
18S = "${WORKDIR}/${SRCNAME}-${PV}"
19
20inherit setuptools