diff options
author | Vu Tran <vu.tran@windriver.com> | 2014-09-30 12:22:12 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2014-09-30 14:30:18 -0400 |
commit | b4d666ff63acd269b0acb2c4419643863c683750 (patch) | |
tree | f22e20ee845a0cca1fe0f7837d92a652325ba036 /meta-openstack/recipes-devtools/python/python-novaclient_git.bb | |
parent | 1b8a298689a95c1943f18d8d9c24589e64bbc7b7 (diff) | |
download | meta-cloud-services-b4d666ff63acd269b0acb2c4419643863c683750.tar.gz |
add generic monitor framework
Instead of having a central file or group of files to
describe what data resources should be monitored. The
content of these files will depend on what core system
monitoring is used ((e.g. Nagios or Monasca).
It's desirable to have each recipe describes what
it wants be monitored in generic way such that various system
monitors can understand and convert these into their format.
If a recipe wishes to register itself to system monitor, it
inherits monitor bbclass and use MONITOR_SERVICE_PACKAGES and
MONITOR_SERVICE_<package name> to indicate what processes
should should be monitored. Also MONITOR_CHECKS_<package name>
variale can be used to pass list of scripts which will be run
on target and if any of these scripts fail then will report.
Eventually monitor.bbclass will be expanded to allow recipe
to describe more complicated information passed down to
system monitor (e.g. Nagios or Monasca)
Signed-off-by: Vu Tran <vu.tran@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-novaclient_git.bb')
-rw-r--r-- | meta-openstack/recipes-devtools/python/python-novaclient_git.bb | 7 |
1 files changed, 6 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-novaclient_git.bb b/meta-openstack/recipes-devtools/python/python-novaclient_git.bb index e8f5aa3..a7a501c 100644 --- a/meta-openstack/recipes-devtools/python/python-novaclient_git.bb +++ b/meta-openstack/recipes-devtools/python/python-novaclient_git.bb | |||
@@ -10,13 +10,14 @@ SRC_URI = "\ | |||
10 | git://github.com/openstack/python-novaclient.git;branch=master \ | 10 | git://github.com/openstack/python-novaclient.git;branch=master \ |
11 | file://fix_novaclient_memory_leak.patch \ | 11 | file://fix_novaclient_memory_leak.patch \ |
12 | file://novaclient-specify-full-path-to-test-certificate.patch \ | 12 | file://novaclient-specify-full-path-to-test-certificate.patch \ |
13 | file://nova-api-check.sh \ | ||
13 | " | 14 | " |
14 | 15 | ||
15 | PV="2.18.1+git${SRCPV}" | 16 | PV="2.18.1+git${SRCPV}" |
16 | SRCREV="2a1c07e790cc95b1e847974e4c757f826507834f" | 17 | SRCREV="2a1c07e790cc95b1e847974e4c757f826507834f" |
17 | S = "${WORKDIR}/git" | 18 | S = "${WORKDIR}/git" |
18 | 19 | ||
19 | inherit setuptools | 20 | inherit setuptools monitor |
20 | 21 | ||
21 | DEPENDS = "python-setuptools-git" | 22 | DEPENDS = "python-setuptools-git" |
22 | DEPENDS += " \ | 23 | DEPENDS += " \ |
@@ -44,3 +45,7 @@ do_install_append() { | |||
44 | 45 | ||
45 | PACKAGES =+ "${BPN}-bash-completion" | 46 | PACKAGES =+ "${BPN}-bash-completion" |
46 | FILES_${BPN}-bash-completion = "${sysconfdir}/bash_completion.d/*" | 47 | FILES_${BPN}-bash-completion = "${sysconfdir}/bash_completion.d/*" |
48 | |||
49 | MONITOR_CHECKS_${PN} += "\ | ||
50 | nova-api-check.sh \ | ||
51 | " | ||