diff options
author | Vu Tran <vu.tran@windriver.com> | 2014-02-28 09:11:13 -0500 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2014-03-17 14:24:31 -0400 |
commit | e617d0205fc566ef70b61a75c484d78c540ef791 (patch) | |
tree | c5969046b73ea732f01c692ddfeef599ecb00eeb /meta-openstack/recipes-devtools/python/python-nova_git.bb | |
parent | 2c14cdfb9c34c541a1b3a180ad2a625514300977 (diff) | |
download | meta-cloud-services-e617d0205fc566ef70b61a75c484d78c540ef791.tar.gz |
Readjust the start level of openstack components
Currently all the openstack components have default start level
of 20. There are other services such as glusterfs, rabbbitmq,
database... are also starting at the same start level. On some
platform, this can cause racing condition between services which
in turn causes some of openstack components not started.
By adjusting the openstack components start level to higher will
ensure that system services start in the determistic way.
Signed-off-by: Vu Tran <vu.tran@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-nova_git.bb')
-rw-r--r-- | meta-openstack/recipes-devtools/python/python-nova_git.bb | 10 |
1 files changed, 9 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-nova_git.bb b/meta-openstack/recipes-devtools/python/python-nova_git.bb index e41e796..7f3d2e2 100644 --- a/meta-openstack/recipes-devtools/python/python-nova_git.bb +++ b/meta-openstack/recipes-devtools/python/python-nova_git.bb | |||
@@ -28,7 +28,7 @@ PV="2013.2.2+git${SRCPV}" | |||
28 | 28 | ||
29 | S = "${WORKDIR}/git" | 29 | S = "${WORKDIR}/git" |
30 | 30 | ||
31 | inherit update-rc.d setuptools identity hosts useradd | 31 | inherit update-rc.d setuptools identity hosts useradd default_configs |
32 | 32 | ||
33 | do_install_append() { | 33 | do_install_append() { |
34 | if [ ! -f "${WORKDIR}/nova.conf" ]; then | 34 | if [ ! -f "${WORKDIR}/nova.conf" ]; then |
@@ -268,12 +268,20 @@ INITSCRIPT_PACKAGES += "${SRCNAME}-api" | |||
268 | # INITSCRIPT_PACKAGES += "${SRCNAME}-controller" | 268 | # INITSCRIPT_PACKAGES += "${SRCNAME}-controller" |
269 | # INITSCRIPT_NAME_${SRCNAME}-controller = "nova-all" | 269 | # INITSCRIPT_NAME_${SRCNAME}-controller = "nova-all" |
270 | INITSCRIPT_NAME_${SRCNAME}-network = "nova-network" | 270 | INITSCRIPT_NAME_${SRCNAME}-network = "nova-network" |
271 | INITSCRIPT_PARAMS_${SRCNAME}-network = "${OS_DEFAULT_INITSCRIPT_PARAMS}" | ||
271 | INITSCRIPT_NAME_${SRCNAME}-scheduler = "nova-scheduler" | 272 | INITSCRIPT_NAME_${SRCNAME}-scheduler = "nova-scheduler" |
273 | INITSCRIPT_PARAMS_${SRCNAME}-scheduler = "${OS_DEFAULT_INITSCRIPT_PARAMS}" | ||
272 | INITSCRIPT_NAME_${SRCNAME}-cert = "nova-cert" | 274 | INITSCRIPT_NAME_${SRCNAME}-cert = "nova-cert" |
275 | INITSCRIPT_PARAMS_${SRCNAME}-cert = "${OS_DEFAULT_INITSCRIPT_PARAMS}" | ||
273 | INITSCRIPT_NAME_${SRCNAME}-conductor = "nova-conductor" | 276 | INITSCRIPT_NAME_${SRCNAME}-conductor = "nova-conductor" |
277 | INITSCRIPT_PARAMS_${SRCNAME}-conductor = "${OS_DEFAULT_INITSCRIPT_PARAMS}" | ||
274 | INITSCRIPT_NAME_${SRCNAME}-api = "nova-api" | 278 | INITSCRIPT_NAME_${SRCNAME}-api = "nova-api" |
279 | INITSCRIPT_PARAMS_${SRCNAME}-api = "${OS_DEFAULT_INITSCRIPT_PARAMS}" | ||
275 | 280 | ||
276 | INITSCRIPT_NAME_${SRCNAME}-compute = "nova-compute" | 281 | INITSCRIPT_NAME_${SRCNAME}-compute = "nova-compute" |
282 | INITSCRIPT_PARAMS_${SRCNAME}-compute = "${OS_DEFAULT_INITSCRIPT_PARAMS}" | ||
277 | INITSCRIPT_NAME_${SRCNAME}-consoleauth = "nova-consoleauth" | 283 | INITSCRIPT_NAME_${SRCNAME}-consoleauth = "nova-consoleauth" |
284 | INITSCRIPT_PARAMS_${SRCNAME}-consoleauth = "${OS_DEFAULT_INITSCRIPT_PARAMS}" | ||
278 | INITSCRIPT_NAME_${SRCNAME}-novncproxy = "nova-novncproxy" | 285 | INITSCRIPT_NAME_${SRCNAME}-novncproxy = "nova-novncproxy" |
286 | INITSCRIPT_PARAMS_${SRCNAME}-novncproxy = "${OS_DEFAULT_INITSCRIPT_PARAMS}" | ||
279 | 287 | ||